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Chapter 1: Getting Started 
The following steps will get you started using this software both on the PC and on your mobile device(s). Click on the 
links provided below to view detailed instructions for completing each step.   
  
Note: Most screen shots in this Help file are of the Professional version of MobileAsset. Not all features/tabs shown in 
these screens are available in the Standard version of MobileAsset. For information on the benefits of upgrading your 
software, please click on Help > Benefits of Upgrading.   
  
If you will be using MobileAsset for multiple companies, you will need to create the additional databases using the 
Database Manager. Database backup and restore functions are also performed on the Database Manager. The 
Database Manager can be accessed from Start > All Programs > Wasp > MobileAsset > Database Manager. For 
detailed instructions on backing up databases using the Database Manager, please refer to the Database Manager 
online help. 
  

1. Add Groups: User security in MobileAsset is set up by Group.  (Administration > Security > Group 
Manager) A Group is a collection of security settings that one or more users share. You will need to create your 
Groups first, then add users and assign them to Groups. Before setting up your groups, take some time to think 
about the types of employees you have, who will need access to the software and what features/functions they 
will need to use in the software. You will want to create a Group for each different type of user you may have. 
 You may need a Group for Managers, who have access to all Sites, Reports, Auditing, etc. Another group 
might be Supervisors who only need access to Reports and basic functions such as check in/out, but don't need 
access to Auditing. A third Group may be comprised of warehouse workers who need access to the mobile 
devices, but don't need to be able to log on to the PC. 

2. Add Users: When you first logon to MobileAsset you will use Admin as the user name and leave the password 
blank. This default user profile gives you access to everything in the system. The first step you should take 
upon logging in is to create additional users (Administration > Security > User Manager). You should enter all 
users who will be using the system and you can assign specific rights to each user that limit their activities to 
certain functions. You should also setup at least one additional admin user who has rights to all areas of the 
system. 

3. Enter Company Information: Next you should enter your company's information (Administration > Company 
Information). On the Company Information screen you will enter your company's name and any addresses 
needed for receiving, shipping, corporate correspondence, etc. The company name you enter on this screen will 
appear on all reports and in the title bar of MobileAsset. 
 
 
Note: You can setup a company(s) using a single database in MobileAsset. If you need multiple databases, use 
the Database Manager to create however many you need. Please refer to the Database Manager Online Help 
for more information on creating multiple databases. For details on using multiple companies with different 
databases, please refer to the topic Working with Multiple Companies. 

4. Create Sites and Create Locations: Now you are ready to begin entering sites and locations into the 
database. A site is a major classification for areas that contain assets within your company. For instance, if you 
have two warehouses, you might set up MobileAsset to have two sites: Warehouse 1 and Warehouse 2. You 
must enter at least one site before you can add assets to your system.   
 
 
Assets that you enter into your system must each be assigned to a Site and a Location within that site. Using 
the example above, within Warehouse 1, you might have three locations: Main Storage Area, Manager’s Office 
and Administrative Office. We suggest creating one site for each building that contains assets. 
 
 
It is important to note that you can have the same Location code defined at more than one Site - for instance, 
Warehouse 1 and Warehouse 2 may each have Location codes of Shelf 1 - so always pay attention to which 
Site you are working with when performing transactions. 
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Setting up your locations now will allow you to just pick a Location from a list when you begin adding inventory 
later. It is possible, however, to define Locations as you add inventory.   
 
If you already have location information contained in another database, you may want to use MobileAsset's 
Import function rather than manually entering in this information. For more information on importing locations, 
please refer to the topic Importing Into the Database in the MobileAsset PC Online Help. 
 
You must create a minimum of one Site with one Location at that Site. 

5. Create Vendors, Create Manufacturers, Create Depreciation Classes: These are all optional features. 
You can manually create or import this information. It is helpful to enter this information prior to setting up your 
assets. 

6. Create Asset Types: This is the first step in creating an asset in the software. You must first create your Asset 
Types, then each asset you add to the system must be assigned to a specific Asset Type. You can think of 
Asset Types as a classification for assets. For instance, you may have an Asset Type of IBM Laptop X6000 that 
defines the manufacturer, size specs, etc. of this particular type of computer. Then specific computers of the 
same type are assigned as assets to the IBM Laptop X6000 asset type. Asset Types are created in the 
database using the New Asset Type screen, or you can import this information. You can then assign assets to a 
specific asset type on the New Asset screen. 
 
 
The Asset Type defines the Description, Depreciation Class, Category, Manufacturer and Model Number of the 
asset. 

7. Create Assets: One or more Assets can be assigned to each Asset Type. The individual assets are a unique 
item of a specific make and model number. Each asset is given an Asset Tag that is unique across all Sites and 
Locations. 

8. Prepare Your Mobile Devices: Prepare your mobile device(s) for use, referring to the printed Quick Start 
Guides that accompany them. The Quick Start Guides are also available for download at 
http://support.waspbarcode.com in the Manuals/Hardware folder of the Downloads section. 
 
 
If you are using an iOS or Android device, you will need to download and install the MobileAsset app available 
from the App Store or the Google Play store. 

9. Setup your mobile devices following the instructions in the Working with Mobile Devices chapter. 
 
 
Windows Mobile Device - Downloading and Installing MobileAsset on Windows Mobile/CE 
Android - Downloading and Installing the MobileAsset App 
iOS - Downloading and Installing MobileAsset on your iOS Device 
  

10. You are now ready to perform Asset transactions on your PC and on your mobile devices! 
  
  
Software activation system licensed under Patent No. 5,490,216 
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Chapter 2: PC Operation 

2 .1 Logging onto the System 

The Log On screen allows you to access the software. This screen appears when the application is opened.   
  
The following information is discussed in this topic: 
  
Log On Screen Example 
Activating Your Software 
Using the Sample Company 
Logging On When You Have Access to Multiple Databases (Enterprise Only) 
  

 

2.1.1 Log On Screen Example 

  
Below is an example of the Log On screen: 
 

 
  
The User Name field is not case sensitive. The Password field is case sensitive. Asterisks will be displayed as you type 
the Password. Both fields are required. 
  
On first use, MobileAsset starts with the following defaults: 
  
User Name:  admin   
Password:    (blank)   
  
After log on, the password should be changed. Click here for more information on changing passwords. 
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2.1.2 Activating Your Software 

  
If an Activation Key has not yet been supplied (the application is running in Demo mode) a message will appear on the 
Log On screen notifying you of the cut off date for product registration as shown in the example below: 
 
 

 

The date and time displayed will be 30 days beyond the date and time of installation, after which MobileAsset will cease 
to function if an Activation Key has not yet been supplied to activate the product. For more information on updating 
your license with an Activation Key, click here.  If you would like to extend the trial period beyond thirty days, 
please contact the Sales department at sales@waspbarcode.com. 
 
If the demo period expires before you activate the software, the following screen will appear when you attempt to open 
MobileAsset: 
 

 
 
 
You will need to enter the Activation Key in the field provided, then click the OK button. You can also register your 
software from this screen by clicking the Register button. 
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2.1.3 Using the Sample Company 

  
If you want to log in using the Sample Company, select the Use Sample Company checkbox, then click the OK 
button. This company contains a set of data you can use to learn about MobileAsset. You can practice using the 
features and functions contained in the software using this data.  You can enter information into the Sample Company; 
however, when upgrading to a new version, this data will be lost. It is very important that you do not enter any 
information into the Sample Company that you do not want to lose. The Sample Company is meant for training 
purposes only and should not be used as your working database. For more information on using the Sample Company, 
please refer to the topic Using the Sample Company. 

 

2.1.4 Logging on with Multiple Databases 

  
Enterprise version only.  If you have created multiple databases for use with two or more companies,  you will see the 
Select Company screen after logging on. You will only see this screen if you have access to more than one database. 
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2.2 Navigating the Main Screen 

The Main screen allows you to quickly access all parts of the system using the icons and menus.   
  
  
Note: All screen shots in this Help file are of the Professional version of MobileAsset. Not all features/tabs shown in 
these screens are available in the Standard version of MobileAsset. For information on the benefits of upgrading your 
software, please click on Help>Benefits of Upgrading from the Dashboard menu section. 
  
  
Below is an example of the Main screen as it appears the first time it is accessed: 
 
  

 
 
The screen is divided in to five sections: 
  
  

1. The Title Bar appears at the top of the screen. This bar displays the software name and, if you are using 
multiple databases, which database you currently have open. If you only have one database, the Title Bar will 
appear as follows: 
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2. The next section is the Menu section and contains the File, Dashboard, Help and Alerts menus. 
 
 

 
 
 
The File menu contains the following options: 

• Logout - Logs the current user out of MobileAsset and opens the Login screen so someone else can 
log in. 

• Change Password - Allows the current user to change his/her password. 
• Setup Label Printer - Opens the Select Label Printer screen allowing you to choose the default 

printer. 
• Reset All Forms Settings - Used to reset all forms (screens) to their default settings, including 

sizing, positioning, etc. This is especially useful to correct display problems when MobileAsset has 
been opened on a single monitor following use on dual monitors. 

• Reset All Grid Settings - Used to reset all grids (lists) to their default settings. Any formatting such 
as column arrangement, filters, hidden columns, etc. will be replaced with the default settings. 

• Exit - Closes MobileAsset. 
 

The Dashboard menu allows you to customize what information appears on your Main screen. This menu 
contains options for you to add "widgets" containing charts and graphs of your asset data for display on your 
dashboard. This data will be updated each time you open MobileAsset or when you click Refresh Charts. The 
Dashboard menu contains the following options: 

• Show Dashboard - Click this option to display the dashboard widgets (this is displayed by default). 
• Hide Dashboard - Click this option to hide the dashboard widgets. 
• Refresh Charts - Refreshes the data contained in any widgets you have set up. 
• Use 4 Widget Configuration - This option sets the dashboard to display 4 widgets (Note: you can 

select what data each widget displays). 
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• Use 7 Widget Configuration - This option sets the dashboard to display 7 widgets (Note: you can 
select what data each widget displays). 
 
 

 

 

• Show widget (Left Column) - Displays the widget the Left Column widget. By clicking [Select] you 
can set this widget to Lookup by Asset Type or Lookup by Site. 

• Show widget (Middle Column Row 1) - Displays the middle column, row 1 widget. 
• Show widget (Middle Column Row 2) - Displays the middle column, row 2 widget. 
• Show widget (Middle Column Row 3) - Displays the middle column, row 3 widget. 
• Show widget (Right Column Row 1) - Displays the right column, row 1 widget. 
• Show widget (Right Column Row 2) - Displays the right column, row 2 widget. 

• Show widget (Right Column Row 3) - Displays the right column, row 3 widget. 
 
To setup a widget: 

a. From the Dashboard menu, select which widget you want to create, or select the Use 4 or 
Use 7 widget option. The new widget will appear in the Navigation window.  In the example 
shown below we have selected to use the 4 widget configuration.  Note that we have already 
set up the data in the Left column and the Middle Column Row 1 widgets.  

b. Click on the widget to which you want to add data.. The Red X (close) button and the [Select] 
option appears.  

c. Click [Select]. A menu containing your options for that widget appears: 
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d. Select from the list of data options. Here we have selected Asset Counts by Departments. 
 
 

 
 
 

  
The Help menu contains the following options: 

• Contents - Opens this help file with the Contents tab displayed. 
• Index - Opens this help file with the Index tab displayed. 
• Search - Opens this help file with the Search tab displayed. 
• Training Options - Opens the training page of waspbarcode.com. This page lists available hardware 

and software training. 
• Check for Updates - Use this option to manually check for updates to your software. By default, the 

software will check for updates to the application and notify you if a more recent version is available. 
 You can then access the software updates website and download the latest version.  This ensures 
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you are always working with the most up-to-date version available to you.   This feature is turned on 
by default.  You can turn off the automatic check and perform periodic manual checks, or leave the 
option on and perform a manual check using this option, if desired. 

• About - Opens the About screen allowing you to view basic version and license information, view 
your mobile device license(s) and view and print the EULA (End User License Agreement). 

3.  Alerts displays any overdue checked-out assets, contracts/licenses that have expired and/or maintenance that 
is due. Alerts are not available in the Standard version of MobileAsset. 

4. The Dashboard displays icons you can use to access various parts of the software. When you first open 
MobileAsset, the Dashboard will be blank. To open a menu, click on the icon on the left.  For example, if the 
Asset Management icon is clicked, the Asset Management menu will appear, as shown below: 
 
 

 
 
 
 
You can pin the menu so that it always appears visible in the Dashboard by clicking the Pin icon in the upper, 
right corner of the menu. Unpinned menus will have a Green pin icon. Pinned menus will have a Red pin icon, as 
shown below: 
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If a plus (+) sign precedes an icon on the right side of the screen, click on the icon to reveal additional options. 
 
 

 
 
 
When the menu items are displayed, a minus (-) sign will precede the menu. Click the icon to hide the menu 
options. 

5. The Search bar allows you to enter a full or partial asset tag by which to search the database. 
 
 

 
 
 
To search, enter a full or partial asset tag and press the <ENTER> key. Click the down arrow to the right of the 
search field to view a list of recent searches. If a matching asset tag is found, the Edit Asset screen will appear. 
If there are several matches, the Asset List will appear with the matching tags displayed. 
 

6. The Status Bar at the bottom of the screen displays the menu you currently have open, the login of the user 
currently logged in and the Site to which the user has access. 
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2.3 Using the Sample Company 

The Sample Company contains a set of data you can use to learn about MobileAsset. You can practice working with 
the features and functions contained in the software using this data.   
  
You can enter information into the Sample Company; however, when upgrading to a new version, this data will be 
lost. It is very important that you do not enter any information into the Sample Company that you do not want to lose. 
The Sample Company is meant for training purposes only and should not be used as your working database. 
  
Accessing the Sample Company: 
  

1. On the Log On screen, select the Use Sample Company checkbox, then click the OK button. The following 
message appears: 
 

 
 

2. You can use the software as normal once logged in. You can create additional asset types and assets, link 
assets, dispose of assets, etc.  When using the Sample Company, the Main screen will display Wasp 
MobileAsset Trial Company in the title bar.  On reports, the company name and each address line will be 
followed by "trial". 
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2.4 Working with Alerts 

Alerts are not available in the Standard edition of MobileAsset. 
  
MobileAsset will alert you if there are overdue checked-out assets, contracts/licenses that have expired and/or 
maintenance that is past due.   
  
  
You can quickly check if any of these items are past due by following the instructions below: 
  

1. From the Main screen, click Alerts. A drop down list will notify you of any overdue items as shown below: 
 

 
2. Click on a listing to be taken to a list of the items that are past due. For example, to see what asset is checked-

out and past due, click Assets Past Due. The Asset List will appear displaying the overdue asset. You can 
then follow up as needed to make sure the asset is not lost, etc.  
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2.5 Using Dual Monitors with MobileAsset 

You can use a single monitor or dual monitors with MobileAsset. Using dual monitors allows you to view multiple 
MobileAsset screens at the same time. If you switch back and forth between single and dual, you may find that you 
have problems viewing some screens. For example, if you open the Asset List screen (or any list screen) you will notice 
that you cannot select anything on the Main screen as long as the List screen is open. If you open the Asset List while 
using dual monitors and move the screen so that it displays on the second monitor, the software will remember the 
position of the screen so that the next time you open it, it will reopen on the second monitor. This prevents you from 
having to reposition the screen everytime you access it. If, however, you reopen MobileAsset on a single monitor and 
you are unable to view the entire screen, or it appears that some screens are displaying off the viewable screen area, 
you will need to reset all form settings in MobileAsset, meaning you will erase MobileAsset's memory of previous screen 
positions. 
  
To Reset Form Positions: 
  

1. From the Main screen click File > Reset All Form Settings.  The following question will appear: 
 

 
2. Click Yes to reset all screens to their default positions. 

  
  

2.6 Logging Out of the System 

You can logout of MobileAsset by clicking File > Logout. The Log On screen appears allowing you to login again or 
login as a different user. Click Cancel on the Log On screen to close MobileAsset. 
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2.7 Adding New Information 

2.7.1 Create New Asset 

The New Asset screen is used to enter a new asset into the database. 
  
Note: Most screenshots in this Help file are of the Professional version of MobileAsset. Not all features/tabs shown in 
these screens are available in the Standard version of MobileAsset.  
  
Note for Mobile Device Users: Assets can also be added on a Windows Mobile/CE, iOS (Professional and 
Enterprise Only) or Android (Professional and Enterprise Only) mobile device. 
  
The following topics are discussed in this section: 
Accessing the New Asset Screen 
General Tab 
Asset Linking Tab 
Depreciation Tab 
Picture Tab 
Attachments Tab 
Maintenance Tab 
Contracts Tab - Professional and Enterprise Editions Only 
Funding Tab - Professional and Enterprise Editions Only 
Transaction History Tab 
Custom Fields Tab 
Dynamic Custom Fields 
  

 

Accessing the New Asset Screen 

  
To access this feature, from the Main screen select Asset Management > New Asset. 
 
This feature can also be accessed from the Asset List by clicking the New button on the toolbar. For more 
information on using the list screens, click here. 
  
The New Asset screen is broken into several tabs. Use the following links to jump ahead to the tab of interest: 
  
General, Asset Linking (Professional and Enterprise Editions), Depreciation, Attachments, Picture, 
Maintenance,  Contracts (Professional and Enterprise Editions), Funding (Professional and Enterprise 
Editions), Transaction History, Custom Fields, Dynamic Custom Fields 
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New Asset Screen > General Tab 

  

 

Note:  If the Automatic Asset Tags function is turned on (Administration > Options), the Asset Tag field will appear 
as follows: 
 

 
You may notice that some fields on this and other tabs have a Pin icon in front of them.  These fields represent data that 
can be "pinned".  Pinning allows you to "lock" the information entered into a field. This is convenient if, for example, you 
are entering multiple new assets for a particular site and location. You can enter the site and location once, then pin 
them.  The fields will retain the information you entered through each new entry until you unpin them. Fields are Pinned 

by clicking on their pushpins , causing them to look like this . Click the pushpin again to unlock the field for entry of a 
different value. 
 
 
Click the Pin All icon to pin every field that offers the pinning feature. Click it again to undo pinning for all fields. 

1. Enter information in the required fields. You must enter information in the Asset Tag, Asset Type (The asset 
type is a category for assets.  Assets are assigned to a specific asset type.  For instance, you may have an 
Asset Type of Label Printers that defines the manufacturer, size specs, etc. of this particular type of printer. 
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 Then specific printers of the same type are assigned to the Label Printers asset type.), Site and Location 
fields.  
 
Note:  If you are using Automatic Asset Tags, you do not need to enter anything in the Asset Tag field. The 
tag will be generated when you click the Save button or when you click the button next to the Asset Tag field. 
 
If you have enabled the Edit Inherited Asset Type Data option on the Options screen, the message screen 
below will appear when you select the Asset Type and you can make changes to the information that is 
populated from the Asset Type. These fields include the Manufacturer, Model, Vendor Number, Check Out 
Length, Check Out Lead Time and Reminder Lead Time. Any changes made to these fields apply to the current 
asset only. (If this option is not enabled, these fields will be disabled and you will not be able to make changes.) 
 

 
 
Select Yes to populate fields with information from the Asset Type. For example, if Check Out Length 
information is entered for the Asset Type, it will appear here. 
 
Keep in mind that you can set the check out length to only consider weekdays and the due date to only fall on a 
weekday on the Options screen. You can set the asset to have no due date by leaving the values in the Check 
Out Length fields at 0.  
 
 
 
If you do not want to incorporate information from the Asset Type, other than the Asset Type number and 
Description, click No. 

2. The Department Code, Serial No., Condition, Hyperlink and Additional Info fields are optional. 
 
The Hyperlink field can be used to store a link to the manufacturer's website, or even to a location on your 
network. When a valid web address is entered in this field, the icon next to it will be enabled.  Clicking the icon 
will open your web browser and access the website. 
 
Note: When using the drop down lists to enter information in a field (Asset Type, Site, Location, etc.), the last 
few selections will appear in the list.  If you want to search for an existing value, select <More> from that field's 
drop down list to access the List screen.  Use the vertical scroll bar to select a record from the List and click the 
List dialog's Select button. 
 
  

3. Click Save if you are done entering information for this asset or click on another tab to proceed with entering 
more information. 
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New Asset Screen > Asset Linking Tab 

  
Asset Linking is only available in the Professional and Enterprise editions of MobileAsset.  Asset Linking allows 
you to link two or more assets together to form one new asset. For example, the asset Mary's Computer may consist of 
4 separate assets - CPU, Keyboard, Mouse and Monitor. These four individual assets are linked together to form one 
new asset, Mary's Computer.  For a complete definition of Asset Linking and an example, please refer to the 
Definitions topic. 
  
The Asset Linking tab allows you to create links: 
  

 

1. The Asset Tag value entered on the General tab will be displayed at the top, but can still be edited, if desired. 

2. If this asset is to be the Parent, or top-level asset, of this group, you can leave the "Parent Asset" field blank. If 
you want to give this asset a parent (for instance, if this asset is a monitor and you want to link to the asset 
Mary's Computer), select an asset from the drop down list. 
 
The asset can have a parent assigned to it and be a parent (have child assets assigned to it). 
 
Select <More> from the drop down list to access the Asset List. Remember, you can filter the asset list to only 
display "Top Level" assets, or parent assets, if needed. See the Working with Lists topic for further 
information. 

3. To associate child assets with this asset (the current asset will be the "parent" of these assets), click the Link 
button below the "Child Asset(s)" window. The Asset List will appear. 
 
Highlight the desired asset in the Asset List, then click the Select button. The selected asset will appear in the 
"Child Asset(s)" window as shown below: 
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In this example, Asset 1002 is the parent of the current asset and asset 1 is the child. 
 
A Note about the Transact as Whole Flag: In the example above, the Transact as whole flag is checked; 
therefore, any functions (check in, check out, audit, move, etc.) will be performed as a whole for the group.  This 
flag is driven from the top down, meaning the selection made for the parent asset will override the selection for 
a child asset. If you want to move only one asset that is a child of this asset, you will need to deselect this check 
box. Deselecting it on the Edit Asset > Asset Linking tab for the child asset will not override the selection 
made for this asset, and this group would still be moved as a whole. Similarly, if the Transact as whole flag 
was NOT selected on this tab, but it IS selected for the parent of this asset, the group would still be transacted 
as a whole because the selections made for the parent of this asset would take precedence.   
 
Also keep in mind that when you check out an asset that has Transact as whole turned on and you select to 
use the Default Due Date (on the Check Out screen) MobileAsset will search all assets linked to the selected 
asset to find the maximum checkout duration. The software will use this maximum length to calculate the due 
dates for all the linked assets. This ensures that all the assets in the transaction have the same due date even if 
some of the linked assets have different checkout durations. 

4. You can unlink child assets by highlighting the asset in the Child Assets list and clicking the Unlink button. 

5. Click Save if you are done entering information for this asset or click another tab to proceed with entering more 
information. 
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New Asset Screen > Depreciation Tab 

  
Click the Depreciation tab if you want the software to calculate depreciation for this asset. The method used by the 
system to calculate depreciation is dependent on the Asset Type assigned to this asset. 
  

 

1. The Asset Tag value entered on the General tab will be displayed at the top, but can still be edited, if desired. 

2. Click the Depreciate Asset check box if you want the software to calculate depreciation. The Depreciate 
Asset check box will be disabled if a Depreciation Class has not been defined for the Asset Type specified on 
the General tab -or- that Asset Type  has a Depreciation Class, but its Depreciation Method is "None". 
 
The depreciation method used for an asset is determined by the Depreciation Class assigned to the 
Asset Type. This information appears in the Class Info box and cannot be modified from this screen. If you 
want to change the Depreciation Method or the Life of a particular asset, you will need to make changes to 
the Depreciation Class assigned to the Asset Type, or create a new Depreciation Class to assign to the Asset 
Type. See the Depreciation Class help topic for further information. 

3. Purchase Cost and Depreciation Begin Date are required fields when Depreciate Asset has been enabled, 
therefore, you must complete them if you want to calculate depreciation. These two fields are used in the 
calculation. Please see the Definitions topic for detailed explanations of each Depreciation Method. 
 
A Purchase Cost should also be entered here if you plan to use the Funding feature to track this asset. You 
will need the purchase cost here in order to record this debit from the funding source. 
 
  

4. Purchase Order, Purchase Date and Salvage Value are optional fields. If a Salvage Value is not specified, 
the Calculate Depreciation function will assume a Salvage Value of zero dollars. 
 
The Class Info, Last Depreciation Date, Total Depreciation, Current Depreciation, and Depreciated Value 
cannot be modified. Information is populated in these fields by the system as depreciation functions are 
performed. 

5. Click Save if you are done entering information for this asset or click the next tab to proceed with entering more 
information. 
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New Asset Screen > Picture Tab 

  
Click the Picture tab to view any image files that have been attached to either the Asset Type Attachments folder or 
the Asset Attachments folder: 
  

 
  

1. The first time you access this tab, click on the picture area to add a picture. 
 
The current default picture is always displayed on the Picture tab.  Right click the image to see the popup 
Picture menu. This menu allows you to Add (a new) Image or to Select (a previously added) Image.  Any 
image you select for display will become the new default image.   
 
The files listed in the Select Image sub-menu are a combination of Asset Type Attachment images and Asset 
Attachments images, sorted alphabetically, by filename. 

2. Image files are not actually added to the database until the Save button is clicked. You can click it at this time if 
you are finished adding additional information, or click it later, after you have completed information on other 
tabs. 
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New Asset  Screen > Attachments Tab 
  
To attach an image or other documentation to this asset, click on the Attachments tab: 
  

 

1. To add an attachment, click the Add button. A screen will appear allowing you to navigate to the desired file on 
your computer. Attachments are copied to the MobileAsset database from the external source you browse to 
when you click the Add button. Any change made to the external source file after adding the attachment will not 
update the attachment in the database. To update the database with a later version of an attached file, you 
must first remove the attachment from the database, then add the file again. 
 
Asset Attachments relate only to the specific asset being recorded. Asset Type Attachments relate to every 
asset recorded for this Asset Type. 

2. If you have attached an image, you can designate this the "default" image (meaning this is the image that will 
appear on the Picture tab) by clicking the Set Default Image button. 

3. After you have added at least one file, the View button is enabled. This feature allows you to view the attached 
file. The file associations defined in Windows Explorer determine which application will be started to open files, 
based on their filename extensions. On most machines, a PDF file would be opened by Adobe®  Reader, for 
example. Image attachments can be viewed the same way or you can use the Picture tab to use MobileAsset's 
internal image viewer. 
 
The Save to File button copies the selected attachment from the database to any drive and folder available on 
your system. 
 
The Remove button can only be used to remove asset attachments. It is grayed-out (disabled) when an Asset 
Type Attachment is selected. These Asset Type Attachments may be related to other Asset Tags under the 
same Asset Type. Asset Type Attachments can only be removed via the Edit Asset Type Attachments tab (see 
Create New Asset Type for further information). 

4. Attachments are not actually added to the database until the Save button is clicked. You can click it at this time 
if you are finished adding additional information, or click it later, after you have completed information on other 
tabs. 
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New Asset Screen > Maintenance Tab 

  
The Maintenance tab allows you to define maintenance procedures, a maintenance schedule, and warranty information 
for an asset. 
  
This tab allows you to: 
  
Enter Warranty Information 
Enter New Maintenance Schedules 
Edit Existing Maintenance Schedules 
View Maintenance History 
  
Below is an example of the Maintenance tab: 
  

 
  
Entering Warranty Information 
  

1. You can optionally enter Warranty Begin and End date at the top of this tab.   
 
Click on the Calendar icon to access the calendar feature: 
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You can also click on the Month/Year to view a list of all months. You can then click on a month to quickly 
switch dates: 
 

 

2. You can optionally enter the warranty provider in the Provider field.   

 

Entering New Maintenance Schedules 

To enter a new maintenance schedule 
  

1. Click the New button below the window: 
 

 
 
The Maintenance Schedule screen appears: 
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2. Enter a name for this maintenance schedule. 

3. Select the employee who this asset will be assigned to from the Assigned To drop down list. All employees 
currently entered into the MobileAsset database will appear in the drop down list. 

4. Select how often this maintenance schedule is to happen from the Occurs drop down list. The area below the 
Occurs drop down list will change depending on the selection you make here. Your options are: 

• Date - This option indicates a one-time maintenance procedure. When you select this option, a 
Date field will appear below the Occurs drop down list.   
 
 

 
 
Select the date on which the maintenance should take place. You can click on the calendar 
icon to select a date or type a date directly into the field. 

• Daily - This option allows you to specify a Maintenance Start date, followed by a frequency 
specified as Every x number of days (up to a maximum of every 366 days). 
 

 
 
In this example, maintenance would be performed every 10 days beginning Monday, August 
24, 2009. 
 
The Next Date at the bottom of the screen indicates the next date maintenance will be 
performed on this asset. 

• Weekly - This option allows you to specify a Maintenance Start date, followed by the 
frequency specified as Every x number or weeks. You will also select the days of the week on 
which the maintenance is to be performed. More than one weekday can be selected. 
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In this example, maintenance will be performed every week on Fridays beginning the week of 
Monday, August 24, 2009. 
 
The Next Date at the bottom of the screen indicates the next date maintenance will be 
performed on this asset. In this example, since we have selected Friday as the maintenance 
day, the Next Date is Friday, August 28, 2009. 

• Monthly - This option allows you to specify a Maintenance Start date, followed by your choice 
of two possibilities: Maintenance Every x number of months (up to a maximum of every 99 
months) as shown below: 
 

 
 
In this example, maintenance will occur on the 1st day of each month every month. 
 
Notice the Next Date reflects the first day of the next month. 
 
OR 
 
Maintenance can be set to occur on a specific weekday of every x number of months (up to a 
maximum of every 99 months) as shown below: 
 

 
 
In this example, maintenance will occur on the first Thursday of every month. 
 
Notice the Next Date reflects the first Thursday of the next month from the Start Date. 

• Disable - This option is used when you want to temporarily disable an existing maintenance 
schedule. Highlight the maintenance schedule in the list, then click Edit.  On the Maintenance 
Schedule screen, select Disabled from the Occurs drop down box. You can also set up a new 
maintenance schedule as Disabled then enable it later by select Daily, Weekly, etc. 

5. Select Should Email if you want an email reminder sent when the next maintenance date is due. The email will 
be sent to the recipients indicated on the Options screen. For more information on setting these options, please 
refer to the topic Reminder Alert Options.  
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6. if you select the Should Email checkbox, enter the number of days and/or hours/mins prior to the due date you 
want the email to be sent in the Reminder Lead Time fields. 

7. Enter any special instructions in the Instructions text field. 

8. Click Save when you are done entering information for this maintenance schedule. The schedule will appear in 
the list on the Maintenance tab: 
 

 

Editing Existing Maintenance Schedules 

1. Highlight the maintenance entry you want to edit, then click the Edit button. The Maintenance Schedule 
screen will appear populated with the selected entry's information. 

2. Make changes as necessary, then click the Save button. The edited entry will appear in the list on the 
Maintenance tab. 

Viewing Maintenance History 

The Maintenance History screen displays all completed maintenance on this asset. 

1. Click the View History button. The Maintenance History screen will appear: 
 
 

 

2. When you first access this screen, all maintenance entries associated with the selected maintenance schedule 
are displayed. You can change the selected schedule using the Schedule drop down menu. You can also enter 
From and To dates to further filter the list. 
 
Click the Show All button to remove the filter. 
 
Select the Print History button to print a list of the displayed maintenance entries. 
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New Asset Screen > Contracts Tab 

  
The Contracts tab is only available in the Professional and Enterprise editions of MobileAsset. The Contracts 
tab allows you to record contract and/or software licenses associated with this asset. The tab will appear empty when 
you are first adding a new asset. You can add contracts and licenses to this asset as needed from this tab. 
Contracts/licenses can be added to the database via the Contracts List screen. 
 

 
  

1. To add a contract/license, click the Add button. The Contracts List will appear. Select the desired contract 
from the list, then click Select on the Contracts List screen. The selected contract(s) will appear on the 
Contracts tab as shown in the example below: 
 

 

2. You can remove a contract by highlighting it in the window, then clicking the Remove button. 
 
Click Select All to select all contracts in the window. 
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Click Clear All to deselect all contract in the window. 

3. Click Save if you are done entering information for this asset or click the next tab to proceed with entering more 
information 

 
  

New Asset Screen - Funding 

The Funding tab is only available in the Professional and Enterprise editions of MobileAsset. The Funding tab 
allows you to keep track of any grants or funding sources for your assets. Below is an example of the Funding tab: 
  

 
  
To associate a funding source with this asset: 
  

1. Click the Add button at the bottom of the tab. The Funding List appears.   

2. Highlight the desired funding source, then click the Select button to add it to this asset. Note: You can also 
create a new funding source from the Funding List by clicking the New button. 
 
The selected funding source will appear on the Funding tab. 
 

 

3. The Debited from Fund field in the list is editable. You can click on this field to enter the amount of funds used. 
The Available Funds column will update by subtracting the debited amount. Please note that the amount 
entered here must be less than the Purchase Cost entered on the New/Edit Asset screen > Depreciation 
tab. 
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New Asset Screen > Transaction History Tab 
  
The Transaction History tab displays data only after one or more Asset Management transactions have been 
performed (check in, check out, etc.). 
  

 
  

1. Click Print Transactions to send a list of the transactions for this asset to the printer. 

2. Click Save if you are done entering information for this asset or click another tab to proceed with entering more 
information. 

 
  

30 



 
  

Wasp MobileAsset User Manual 

New Asset Screen > Custom Fields Tab 

  

 
  
Please refer to the Using Custom Fields topic for instructions on creating custom text, number and date fields.   
  
If the Close New Form option is enabled on the Options screen and no fields are pinned, the screen will close when 
the Save button is clicked. 
  

 

New Asset Screen > Dynamic Custom Fields 

  
Dynamic Custom Fields are customized text, date and/or number fields that you create on Asset Types. The field(s) 
will appear on the Dynamic Custom Field tab of any assets that are assigned to that asset type. These fields differ from 
regular custom fields in that you can set them to be associated with a specific asset type, multiple asset types that you 
select or on all asset types. You can also create a tooltip for each field to provide users with information on what data 
should be entered.  Dynamic Custom Fields can be searched via the Search screens or the Search field on the Main 
screen. In addition, Dynamic Custom Fields can be edited via the Mass Update function. 

  
Please refer to the Using Dynamic Custom Fields topic for instructions on creating dynamic text, number and date 
fields. 
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2.7.2 Create New Customer 

The Create New Customer screen, allows you to enter a new Customer into the database. Assets can then be 
checked-out to that customer.    
  

1. To access this screen, from the Main screen click New > Customer. The New Customer screen appears. 
 
Create New Customer can also be accessed from the Customer List by clicking the New button on the 
toolbar. For more information on using the List screens, see the Working with Lists topic.    
 
 
In addition, the New Customer screen can also be opened automatically from the Check-Out screen if an 
unknown customer is entered.   
 
Below is an example of the New Customer screen. 
 

 

2. Complete the information on the screen. Only the Customer No. and Address Type fields are required. 
 
Select an Address Type from the drop down list, then provide any of the associated information you have for 
this customer: Address 1, Address 2, Mail Stop, City, State, Postal Code and Country.  Address information 
can be entered for each Address Type you select. 

3. The Additional Information tab provides optional fields where other information about the customer can be 
recorded: Phone, Extension, Fax, Cell No., Home No., Email and Notes. 
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Notes is a text field available to record any additional information you might have about this customer. See the 
Notes topic. 
 

 

For information about the Custom Texts and Custom Numbers and Dates tabs, see Using Custom Fields. 

When the Close New Form option is turned off: Click Save to commit your entry or click Close to exit the form. 
 
When the Close New Form option is turned on: Click OK to commit your entry and exit the form or Cancel to exit the 
form without saving your entry. 
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2.7.3 Create New Asset Type 

The Create New Asset Type screen allows you to enter a new Asset Type in the database. The asset type is a 
category for assets. Assets are assigned to a specific asset type.  For instance, you may have an Asset Type of Label 
Printers that defines the manufacturer, size specs, etc. of this particular type of printer. Then specific printers of the 
same type are assigned to the Label Printers asset type. 
  
Note: Most screen shots in this Help file are of the Professional edition of MobileAsset. Not all features/tabs shown in 
these screens are available in the Standard version of MobileAsset. For information on the benefits of upgrading your 
software, please click on Help>Benefits of Upgrading. 
  
The following topics are discussed in this section: 
  
Accessing the New Asset Type Screen 
General Tab 
Attachments Tab 
Picture Tab 
Custom Fields Tab 
Dynamic Custom Fields Tab 
  
  

 

Accessing the New Asset Type Screen 

  
1. To access the screen, from the Main screen, click New > Asset Type.   

 
The New Asset Type screen can also be accessed from the Asset Type List by clicking the New button on the 
toolbar. For more information on using the List screens, see the Working with Lists topic.    

2. Complete the information on the screen. The New Asset Type screen is divided into tabs. You can use the 
following links to jump to the tab of interest: 
 
General, Attachments, Picture, Custom Fields, Dynamic Custom Fields. 
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New Asset Type Screen > General Tab 

  

 

To create a new Asset Type, supply the required Asset Type value. All other fields, including Description, are optional. 
 
Asset Types must be unique across all Sites and Locations. A particular value can occur only once in the software 
database. 

• Select a Manufacturer from the drop down list or create a new one by entering the new value and clicking OK 
to launch the Create New Manufacturer screen. 

• Enter a Model name or number for the Asset Type. 

• Select a Vendor Code from the drop down list or create a new one by entering the new value and clicking OK 
to launch the Create New Vendor screen. 

• Select a Class from the drop down list or create a new one by entering the new value and clicking OK to launch 
the Create New Asset Class screen. 

• Select a Category from the drop down list or create a new one by entering the new value.   

• Length is the length of one unit of measure. 
Width is the width of one unit of measure. 
Height is the height of one unit of measure. 
Weight is the mass of one unit of measure. 
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These are text fields in which the units of measure can be specified along with the dimension or weight.  (5 mm, 
10 in, 3 lbs, etc.) 

• Check Out Length specifies the default period, in days, that assets assigned to this Asset Type may be 
Checked Out to a Customer or an Employee. Keep in mind that you can set the check out length to only 
consider weekdays and the due date to only fall on a weekday on the Options screen. Leave the values in this 
section at 0 to have no due date for this asset type. 

• Check Out Lead Time indicates how long after an asset is received, checked in, etc. before it is available. The 
lead time allows time for recalibration, cleaning, etc. 

• Reminder Lead Time indicates how long before an asset is due that a reminder e-mail will be sent to the 
customer/employee to whom it is checked out. 

• The Hyperlink field can be used to store a link to the manufacturer's website, or even to a location on your 
network. When a valid web address is entered in this field, the icon next to it will be enabled.  Clicking the icon 
will open your web browser and access the website. 

• If you want to search for an existing value, select <More> from that field's drop down list to open the relevant 
List screen.  Use the vertical scroll bar to select a record from the List and click the List screen's Select button. 

 
  

New Asset Type Screen >  Attachments Tab 

To attach an image or other documentation for this Asset Type, click on the Attachments tab: 
  

 
  

1. To add an attachment, click the Add button. A screen will appear allowing you to navigate to the desired file on 
your computer. Attachments are copied to the MobileAsset database from the external source you browse to 
when you click the Add button. Any change made to the external source file after adding the attachment will not 
update the attachment in the database. To update the database with a later version of an attached file, you 
must first Remove the attachment from the database, then Add the file again. 
  

2. If you have attached an image, you can designate this the "default" image (meaning this is the image that will 
appear on the Picture tab) by clicking the Set Default Image button. 
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3. After you have added at least one file, the View button is enabled. This feature allows you to view the attached 
file. The file associations defined in Windows Explorer determine which application will be used to open files, 
based on their filename extensions. On most machines, a PDF file would be opened by Adobe®  Reader, for 
example. Image attachments can be viewed the same way or you can use the Picture tab to use Asset's 
internal image viewer. 
 
The Save to File button copies the selected attachment from the database to any drive and folder available on 
your system. 
 
To remove an attachment, highlight it in the list and click the Remove button. 

4. Attachments are not actually added to the database until the OK button is clicked. You can click it at this time if 
you are finished adding additional information, or click it later, after you have completed information on other 
tabs. 

 

New Asset Type Screen >  Picture Tab 

  
Click the Picture tab to view any image files that have been attached to this Asset Type. 
  

 
  

1. The current default picture is always displayed on the Picture tab. Right click the image to see the popup 
Picture menu. This menu allows you to Add (a new) Image or to Select (a previously added) Image. Any 
image you select for display will become the new default image.   
 
The files listed in the Select Image sub-menu are a combination of Asset Type Attachment images and Asset 
Attachments images, sorted alphabetically, by filename. 

2. Image files are not actually added to the database until the OK button is clicked. You can click it at this time if 
you are finished adding additional information, or click it later, after you have completed information on other 
tabs. 
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New Asset Type Screen > Custom Fields Tab 

The Custom Fields tab allows users with Admin rights to create custom text, number or number fields for this asset 
type.  
  

 
  
Please refer to the Using Custom Fields topic for instructions on creating custom text, number and date fields.   
  

 

New Asset Type Screen > Dynamic Custom Fields 

  
Dynamic Custom Fields are customized text, date and/or number fields that you create on Asset Types. The field(s) 
will appear on the Dynamic Custom Field tab of any assets that are assigned to that asset type. These fields differ from 
regular custom fields in that you can set them to be associated with a specific asset type, multiple asset types that you 
select or on all asset types. You can also create a tooltip for each field to provide users with information on what data 
should be entered.  Dynamic Custom Fields can be searched via the Search screens or the Search field on the Main 
screen. In addition, Dynamic Custom Fields can be edited via the Mass Update function. 

  
  
Please refer to the Using Dynamic Custom Fields topic for instructions on creating dynamic text, number and date 
fields. 

2.7.4 Create New Contract/License 

 
The Contracts/Licenses feature is available in the Professional and Enterprise editions of MobileAsset. 
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Contracts/Licenses can be entered into the database so you can associate them with specific assets. For example, you 
may have 15 licenses for Microsoft Windows and each license is assigned to a different computer. You can track which 
assets those licenses are tied to by associating the license with the assets on the New/Edit Asset screens.   
  

1. To create a new contract/license, from the Main screen, click New > Contract/License. 
 
The New Contract screen can also be accessed from the Contract List by clicking the New button on the 
toolbar. For more information on using the List screens, see the Working with Lists topic.    
 

 

2. Complete the requested information at the top of the screen. 
 
When you enter a Vendor, the icon next to the field is enabled as shown below: 
 

 
 
Click on this icon to open the Edit Vendor screen so you can view this vendor's information. 
 
You can optionally enter a hyperlink for this vendor. This can be a hyperlink to the vendor's website or to a 
document stored on your network. Cost is also an optional field. You can enter cost here, but keep in mind it is 
not tracked in MobileAsset. 

3. You can associate assets with this contract/license by clicking the Associate button. The Asset List appears. 
Highlight the desired listing, then click the Select button on the Asset List.  The selected asset appears in the 
Associated Assets grid as shown below: 
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You can remove an asset by highlighting it in the grid and clicking the Remove button. 
 
If you associate an asset to a contract/license from this screen, this contract will display on the asset's Edit 
Asset screen > Contracts tab. 

4. Click OK save your changes. 
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2.7.5 Create New Depreciation Class 

The Create New Depreciation Class screen allows you to specify what Depreciation Method, if any, should be used to 
calculate depreciation for an Asset Type ( The asset type is a category for assets.  Assets are assigned to a specific 
asset type.  For instance, you may have an Asset Type of Label Printers that defines the manufacturer, size specs, etc. 
of this particular type of printer.  Then specific printers of the same type are assigned to the Label Printers asset type.) 
  associated with the Class, and for what period. 
  

1. To access this screen, from the Main screen click New > Depreciation Class. 
 
The Create New Depreciation Class screen can also be accessed from the Depreciation Class List by 
clicking the New button on the toolbar. For more information on using the List screens, see the Working 
with Lists topic.    
 

 

2. Complete the fields on this screen. Name and Depreciation Method are required fields. 
 
It is a good idea to use a descriptive Class name that incorporates some indication of the depreciation method 
and the Years/Months you intend to specify for depreciation classes (with Depreciation Method other than 
None). (Examples:  DepNone, DepSL5yr, DepSL1yr6mo, etc.) 
 
 
Select the depreciation method you would like to use from the Depreciation Method drop down 
menu. Selecting None from the list specifies that depreciation is not to be calculated for Asset Types of this 
Class. Remember that these depreciation methods are selected on the Add/Edit Depreciation Class screen. 
Please refer to the Definitions section for detailed definitions of each depreciation type. 

Fully depreciate to salvage value option: If you select Double Declining, Custom or 150% Declining, the Fully 
depreciate to salvage value option will be enabled. Leave this checkbox selected (default) if you want 
MobileAsset to fully depreciate your assets to the salvage value.   
 
Example: Assume you select double declining balance over five years, and enter a salvage value (entered on the 
Create New Asset screen) of $20.00. Assume that after 4 years, following the double declining balance method, 
the asset may have depreciated to $40.00. In this situation, if this checkbox is selected, MobileAsset will lower 
the value of the asset to the salvage value - $20.00 in this case - at year 4 despite what the actual depreciated 
value is. 
 
Uncheck this option if you do not want MobileAsset to fully depreciate the asset.   

3. Click OK when you have completed the screen. 
  

If any method other than None has been selected, information must be entered in the Years and/or Months fields. 
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2.7.6 Create New Department 

The Create New Department screen allows you to enter a new Department to which an asset and/or employee is 
assigned.   
  

1. To access this screen, from the Main screen select New > Department. 
 
The Create New Department screen can also be accessed from the Department List by clicking the New 
button on the toolbar. For more information on using the List screens, see the Working with Lists topic.    
 

 

2. Complete the fields on this screen. All fields are required.  (Example:  "GA" and "Graphic Arts") 

3. Click OK after entering information to save the new record. 
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2.7.7 Create New Employee 

The New Employee screen allows you to enter a new employee into the database. Employees, like customers, can 
have assets checked-out to them. 
  
Note: All screen shots in this Help file are of the Professional version of MobileAsset. Not all features/tabs shown in 
these screens are available in the Standard version of MobileAsset. For information on the benefits of upgrading your 
software, please click on Help>Benefits of Upgrading. 
  
Accessing the New Employee Screen 
Using the General Tab 
Using the Attachments Tab 
Using the Picture Tab 
Using the Transaction History Tab 
Using the Custom Fields Tab 
  

 

Accessing the New Employee Screen 

  
1. To access the screen, from the Main menu, click New > Employee.   

 
The New Employee screen can also be accessed from the Employee List by click the New button on the 
toolbar. For more information on using the List screens, see the Working with Lists topic.    
 
In addition, it can also be opened automatically from the Check-Out screen if an unknown Employee is entered. 
   

2. The First Name, Last Name, Employee No., and Address Type fields are required and must be completed. 
The remaining fields are optional. 

3. The New Employee screen is divided into tabs. Use the following links to jump ahead to the tab of interest: 
 
General, Attachments, Picture, Transaction History, Custom Fields 
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New Employee Screen > General Tab 

  

 
  
If you intend to use the optional Manager field when defining one or more Employees, you must define all the manager 
Employees ahead of non-manager Employees, working through your organizational chart from the top down.   
  
Select an Address Type from the drop down list, then provide any of the associated information you have for this 
Employee. Address information can be entered for each Address Type you select. 

 
  

New Employee Screen >  Attachments Tab 

  
To attach an image or other documentation for this Employee, click on the Attachments tab: 
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Adding Attachments: 
  

1. To add an attachment, click the Add button. A browser window will appear allowing you to navigate your 
computer to find the desired file.   
 
If you are adding a picture, and want to make the current image the "default" image (the image that displays first 
on the Picture tab) click the Set Default Image button. 

2. Click OK to add the file. 
 
Attachments are copied to the MobileAsset database from external sources you browse to when you click the 
Add button. Any change made to the external source file after adding the attachment will not update the 
attachment in the database. To update the database with a later version of an attached file, you must first 
remove the attachment from the database, then add the file again. 

Viewing Attachments: 
  
To view an attachment that is already attached to the employee record, click the View button. The File Associations 
defined in Windows Explorer determine which application will be started to open files, based on their filename 
extensions. On most machines, a PDF file would be opened by Adobe®  Reader, for example. Image attachments can 
be viewed the same way or you can use the Picture tab to use MobileAsset's internal image viewer. 
  
Removing Attachments: 
  
To remove an attachment from the database, highlight the item in the Attachments window, then click Remove. 
  
Saving to File: 
  
The Save to File button copies the selected attachment from the database to a location you specify on your computer. 
  
Attachments are not actually added to the database until the OK button is clicked. 

 

New Employee Screen >  Picture Tab 

  
Click the Picture tab to view any image files that have been attached to this employee. 
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The current default picture is always displayed on the Picture tab.  Right click the image to see the pop up menu. This 
menu allows you to Add (a new) Image or to Select (a previously added) Image. Any image you select for display will 
become the new default image.   
  
The files listed in the Select Image sub-menu are sorted alphabetically, by filename. (In the example shown, only one 
image file has been attached to this Employee record.) 
  
Image files are not actually added to the database until the OK button is clicked. 

 
  

New Employee Screen > Transaction History 

  
The Transaction History tab displays the assets check-out to the employee and any assets the employee previously 
had checked-out that have been checked back in. 
  

 
  
You can print a list of these transactions by selecting the Print Transactions button. 

 
  

New Employee Screen > Custom Fields 

  
See the Using Custom Fields topic for instructions on creating custom text, number and date fields.   
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2.7.8 Create New Funding 

Funding is only available in the Professional and Enterprise editions of MobileAsset.  
  
The New Funding screen allows you to create new funding sources and associate them with specific assets.  
  

1. From the Main screen, click Lists > Funding > New. 
 
OR 
 
From the Main screen, click New > Funding.  
 
The New Funding screen appears: 
 

 

2. Enter a Name (required) and Description for the funding source at the top of the New Funding screen. 

3. On the General tab, enter the following information: 

• Amount - Enter the dollar amount you received from this funding source. 
• Start/End Dates - Select the start and end dates for this funding source. 
• Notes - Enter any additional information you want to associate with this funding source. 

 
Note: The Total Debits and Available Funds fields are view only fields that display any debits 
taken from this fund and the resulting available funds amount.  

4. The Associated Assets section allows you to select individual assets that will receive funding from this 
source. To add an asset: 

a. Click the Add button.  The Asset List appears. 

47 



 
  

Wasp MobileAsset User Manual 

b. Select the Asset or Assets you want to associate with this funding source, then click the Select 
button at the bottom of the Asset List. The selected assets will appear in the Associated Assets 
list. 
 

 

c. You can remove an asset from this list by highlighting it, then clicking the Remove button. 
 
Highlight an asset and click the Detail button to see the Edit Asset screen for the selected asset. 

d. The Debited from Fund field in the list can be edited. You can click on this field to enter the 
amount of funds used. Please note that the number entered here must be less than the Purchase 
Cost entered on the New/Edit Asset screen > Depreciation tab. 
 

5. The Attachments tab allows you to add documents to the fund. 
 
 

 
 
To attach a document to the fund: 

a. Click the Add button on the Attachments tab. A browser window appears. 

b. Navigate to the document, then click the Open button at the bottom of the browser screen. 
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c. The document will be added to the New Funding screen as shown below: 
 
 

 

d. To view the document, click the View button. 
 
To Remove the document, click the Remove button. 
 
To save the document as a file on your computer, click the Save to File button. 

6. The Transaction History tab lists any transactions that have been performed on this funding source. 
 

 

7. The Custom tab allows users with to add custom text, numbers or dates. Please refer to the Using 
Custom Fields topic for instructions on creating custom text, number and date fields.   
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2.7.9 Create New Location 

The New Location screen allows you to enter a new Location for an existing site to the database.  Locations are places 
within a particular Site where Assets reside.  Typically, a Site is a building that contains one or more inventory 
Locations.  For instance, Sebastian's Office might be a location within the site Executive Building A23. 
  

1. To access the New Location screen, from the Main screen, click New > Location.  The New Location screen 
appears. 
 
You can also access the New Location screen from the Location List by clicking the New Record button on 
the toolbar.  For more information on using the List screens, see the Working with Lists topic. 
 

 

2. Enter the requested information on the screen.  The Site and Location fields are required. If you enter a site 
that does not exist in the database, the system will ask if you want to create the new site now. 
 
Description allows you to enter a description of the Location.  This is useful when the Location value is cryptic 
(For example, Location "A7B2" could be described as "Aisle 7 Bin 2".) 
 
Notes is a text field available to record any additional information you might have about this Location.  Click the 
Add Notes button to edit the Notes field. 

3. For information about the Custom Texts and Custom Numbers and Dates tabs, see Using Custom Fields. 
 

4. When the Close New Form option is turned off:  Click Save to commit your entry or click Close to exit the form. 
 
 
When the Close New Form option is turned on: Click OK to commit your entry and exit the form or Cancel to 
exit the form without saving your entry. 
 
 
Users setup in the Admin Group  in Security can limit use of MobileAsset to a single Site.  See the Set Working 
Site help topic for more information. 
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2.7.10 Create New Manufacturer 

The Create New Manufacturer screen allows you to enter a new Manufacturer in the database.  Manufacturers can be 
assigned to Asset Types. 
 . 
  
If a Manufacturer is also your Vendor for an Asset Type, it is best to define the company in the software as a Vendor, in 
addition to defining it as a Manufacturer. 
  

1. To access this screen, from the Main screen, click New > Manufacturer.  The New Manufacturer screen will 
appear. 
 
The New Manufacturer screen can also be accessed from the Manufacturer List by clicking the New button on 
the toolbar. For more information on using the List screens, see the Working with Lists topic. 
 

 

2. Complete the information on the screen.  The Name and Address Type fields are required; all other fields are 
optional. 
 
Select an Address Type from the drop down list, then provide any of the associated information you have for 
this Manufacturer:  Address 1, Address 2, Mail Stop, City, State, Postal Code and Country.  Address 
information can be entered for each Address Type you select. 
 
Different Phone, Fax, Email and Web Site information can be entered for different Address Types. 

3. The Additional Information tab provides optional fields where other information about the Manufacturer can be 
recorded:  Contact Name, Contact Phone, Extension, Contact Cell No., Contact Fax and Notes fields. 
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Notes is a text field available to record any additional information you might have about this Manufacturer. 
 Click the Add Notes button to edit the Notes field.   
 

 

4. For information about the Custom Texts and Custom Numbers and Dates tabs, see Using Custom Fields. 

5. When the Close New Form option is turned off: Click Save to save your entry or click Close to exit the screen.  
 
When the Close New Form option is turned on: Click OK to save your entry and exit the form or Cancel to exit 
the screen without saving your entry. 
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2.7.11 Create New Site 

The New Site screen allows you to add a new Site to your database.  Typically, a Site is a building that contains one or 
more asset Locations.  For instance, Sebastian's Office might be a location within the site Executive Building A23.  Pay 
attention to the Site you are working with when using MobileAsset.  
 
Users setup with Administrative Privileges in Security can limit use of MobileAsset to a single Site.  See the Set 
Working Site help topic for more information. 
 
It is not uncommon to use this product with only one Site defined.  A minimum of one Site is required. 
  

1. To access the New Site screen, from the Main screen click New > Site.  The New Site screen appears. 
 
The New Site screen can be accessed from the Site List by clicking the New button on the toolbar.  For more 
information on using the List screens, see the Working with Lists topic. 
 

 

2. Description allows you to enter a description of the Site.  This is useful when the Site value is cryptic (For 
example, Site "H7" could be described as "Hangar 7".) 
 
Notes is a text field available to record any additional information you might have about this Site.  Click the Add 
Notes button to edit the Notes field. 
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3. For information about the Custom Texts and Custom Numbers and Dates tabs, see Using Custom Fields. 
 

4. When the Close New Form option is turned off: Click Save to save your entry or click Close to exit the screen. 
 
 
When the Close New Form option is turned on: Click OK to save your entry and exit the form or Cancel to exit 
the screen without saving your entry. 
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2.7.12 Create New Vendor 

The Create New Vendor screen is used to enter a new vendor into the database.  Vendors can be assigned to Asset 
Type.  
 

1. To access the screen, from the Main screen click New > Vendor.  The New Vendor screen appears. 
 
The New Vendor screen can also be accessed from the Vendor List by clicking the New button on the toolbar. 
 For more information on using the List screens, see the Working with Lists topic. 
 
If a Vendor is also your Manufacturer for an Asset Type, it is best to define the company in the software as a 
Manufacturer, in addition to defining it as a Vendor. 
 

 

2. Enter the requested information on this screen.  The Vendor Code and Address Type fields are required.  All 
other fields are optional. 
 
Select an Address Type from the drop down list, then provide any of the associated information you have for 
this Vendor:  Address 1, Address 2, Mail Stop, City, State, Postal Code and Country.  Address information 
can be entered for each Address Type you select. 
 
Different Phone, Fax, Email and Web Site can be entered for different Address Types. 

3. The Additional Information tab provides optional fields where other information about the Vendor can be 
recorded:  Contact Name, Contact Phone, Extension, Contact Cell No., Contact Fax and Notes fields. 
 
 
Notes is a text field available to record any additional information you might have about this Vendor.  Click the 
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Add Notes button to edit the Notes field.   
 

 

4. You can optionally enter information on the Custom tabs.  For information about the Custom Texts and 
Custom Numbers and Dates tabs, see Using Custom Fields. 
 

5. When the Close New Form option is turned off: Click Save to save your entry or click Close to exit the screen.  
 
 
When the Close New Form option is turned on: Click OK to save your entry and exit the form or Cancel to exit 
the screen without saving your entry. 
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2.7.13 Using Custom Fields 

Custom fields allow you to define fields in MobileAsset to capture information specific to your needs. For 
example, if you want to capture a special code called Widget Code for each asset entered into MobileAsset, you 
can turn on the Edit Field Names function, then create your field on the Custom Fields tab of the New/Edit 
Asset screen. 
  
Creating Custom Fields: 
  

1. Make sure the Edit Field Names function is turned on in the Options screen. 

2. Open the Custom Fields tab on any screen that contains that tab. When the Edit Field Names 
function is turned on, the fields will appear as shown below: 
 
 

 

3. Click in the field for which you want to create custom data. Your options differ depending on what type 
of custom field you are creating (Text, Number or Date). 
 
Custom Text Fields: If you are creating a Custom Text Field, the screen shown below appears: 
 

 
a. Enter a new name for this field in the New Name field. 
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b. You can optionally enter a tool tip in the Tool Tip field. Tool Tips provide special instructions to 
your users when they hover their mouse over the field. 

c. Select if this custom field will be: 
• Visible - Selecting this check box makes the custom field visible to all users 
• Required - Selecting this check box means the custom field must be completed in 

order for the new asset (employee, asset type, etc.) to be saved. 
• Send to Mobile Device - Selecting this check box causes the custom field to be 

included in the mobile database that is sent to the mobile device. The custom field will 
appear on the mobile device. 

d. Click the Set to Default button to clear your changes and return the field to its default values. 
e. You can leave this field as a free-form entry field, or create pre-defined values that will appear 

in a drop down list. Enter a value in the Pre-Defined Values section, then click the Add button. 
The new value will appear in the list as shown below: 
 

 
 
You can select to make a field the default field by selecting the Default checkbox. This means 
the selected field will appear first in the drop down list. After you enter two or more values, you 
can highlight one and use the up and down arrows to move it's position in the list. 
 
Select the Allow Only These Values checkbox to prevent users from entering free form text in 
the field. 

f. Click the OK button when you are done adding information. The information will now appear in 
the custom field: 
 

 
  

4. Custom Number or Date Field: If you are creating a custom number or custom date field, the screen 
shown below appears: 
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a. Enter a name for the custom field in the New Name field. 

b. You can optionally enter a tool tip in the Tool Tip field. Tool Tips provide special 
instructions to your users when they hover their mouse over the field. 

c. Select if this custom field will be: 

• Visible - Selecting this check box makes the custom field visible to all 
users 

• Required - Selecting this check box means the custom field must be 
completed in order for the new asset (employee, asset type, etc.) to be 
saved. 

• Send to Mobile Device - Selecting this check box causes the custom 
field to be included in the mobile database that is sent to the mobile 
device. The custom field will appear on the mobile device. 

a. Click OK when you are done entering information. 
 
Below is an example of a Custom Number field: 
 
 

 
 
The user can enter a number in the free form field. Custom Number fields will accept 
values ranging from -999999999999999.9999 to 999999999999999.9999. 
 
 
Below is an example of a Custom Date field: 
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The user can select the Calendar icon to choose a date. Custom Dates will be 
displayed in the same format as found elsewhere in the product: "day of the week, 
month dd, ccyy". 

4. Repeat these steps until you have created the needed number of custom fields. 
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2.7.14 Using Dynamic Custom Fields 

  
Dynamic Custom Fields are customized text, date and/or number fields that you create on Asset Types. The field(s) 
will appear on the Dynamic Custom Field tab of any assets that are assigned to that asset type. These fields differ from 
regular custom fields in that you can set them to be associated with a specific asset type, multiple asset types that you 
select or on all asset types. You can also create a tooltip for each field to provide users with information on what data 
should be entered.  Dynamic Custom Fields can be searched via the Search screens or the Search field on the Main 
screen. In addition, Dynamic Custom Fields can be edited via the Mass Update function. 
  
You may not want to use Dynamic Custom Fields to capture certain data. Though they can be set to appear on 
specific Asset Types, the data within them cannot be sorted, grouped, exported or imported. If you need to perform 
any of these functions on the data captured in the field, you may want to create a Custom Field. 
  
Create a New Dynamic Custom Field 
Edit a Dynamic Custom Field 
Delete a Dynamic Custom Field 
Add an Existing Dynamic Custom Field 
  

 

Create a New Dynamic Custom Field 

  
1. On the New/Edit Asset Type screen, click on the Dynamic Custom Fields tab. 
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Note: If a Dynamic Custom Field has been created on a different Asset Type and marked Global, it will 
appear in this list. 

2. Click the New button. A drop down menu will appear.  

3. Select Text, Number or Date from the drop down menu. 
 
The Create New Dynamic Custom Field will appear. This screen will differ depending on which type of field 
you chose to create. 
 
Creating a Text Field: 

a. On the Create New Dynamic Custom Field, enter the name of the field in the DCF Name field. This 
name will appear as the field label on the New/Edit Asset Screen > Dynamic Custom Fields tab. 
 

 

b. Enter the text of the tooltip that will appear when the user hovers their mouse over the field. This 
should be instructional text telling the user what type of information to enter. 
 

 

c. Use the check boxes to mark if you want this dynamic custom field to be: 
 

• Visible - Selecting this check box makes the custom field visible to all users. 
• Required - Selecting this check box means the custom field must be completed in order for 

the new asset to be saved. 
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• Sent to Mobile Device - Selecting this check box means this field will be visible to the mobile 
device and will appear on the Type tab when creating new assets.  
 
 

 
 

d. Select the asset types on which you want this field to appear.  
 
 

 
 
 
 
The DCF Asset Type List contains a list of all your asset types. Select the check box in front of the 
Asset Type to add the field to it. You can also use the radio buttons above the list to make your 
selection. 

• Current - Select this option to only add this field to the asset type you are currently creating. 
This is the default selection. 
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• Multiple - Select this option to allow the selection of additional assets in the list. Selecting this 
option enables the Select All and De-Select All buttons at the bottom of the list. 
 

 

• Global - Select this option to add the field to all Asset Types in your system.  
 

 
e. You can leave this field as a free-form entry field, or create pre-defined values that will appear in a 

drop down list. Enter a value in the Pre-Defined Values section, then click the Add button. The new 
value will appear in the list as shown below: 
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You can select to make a field the default field by selecting the Default check box. This means the 
selected field will appear first in the drop down list. After you enter two or more values, you can 
highlight one and use the up and down arrows to move it's position in the list. 
 
Select the Allow Only These Values check box to prevent users from entering free form text in the 
field. 
 
Highlight a value and click the Delete button to remove it from the list. 

f. When you have finished setting up the field, click the OK button. The new field now appears in the list 
on the Dynamic Custom Field tab of the New/Edit Asset Type screen.. 
 

 
 
 
The field will appear on the New/Edit Asset > Dynamic Custom Field tab of any assets associated 
with the asset types to which this new field is assigned. 
 
 

 
 

Creating a Number Field: 
  

a. On the Create New Dynamic Custom Field screen, enter the name of the field in the DCF Name field. This 
name will appear as the field label on the New/Edit Asset Screen > Dynamic Custom Fields tab. 
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b. Enter the text of the tooltip that will appear when the user hovers their mouse over the field. This should be 
instructional text telling the user what type of information to enter. 
 

 
c. Use the check boxes to mark if you want this dynamic custom field to be: 
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• Visible - Selecting this check box makes the custom field visible to all users. 
• Required - Selecting this check box means the custom field must be completed in order for the new 

asset to be saved. 
• Sent to Mobile Device - Selecting this check box means this field will be visible to the mobile device 

and will appear on the Type tab when creating new assets.  
d. Select the asset types on which you want this field to appear.  

 
 

 
 
 
 
The DCF Asset Type List contains a list of all your asset types. Select the check box in front of the Asset 
Type to add the field to it. You can also use the radio buttons above the list to make your selection. 

• Current - Select this option to only add this field to the asset type you are currently creating. This is 
the default selection. 
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• Multiple - Select this option to allow the selection of additional assets in the list. Selecting this option 
enables the Select All and De-Select All buttons at the bottom of the list. 
 

 

• Global - Select this option to add the field to all Asset Types in your system.  
 

 

e. When you have finished setting up the field, click the OK button. The new field now appears in the list on the 
Dynamic Custom Field tab on the New/Edit Asset Type screen. 
 

 
 
The field will appear on the New/Edit Asset > Dynamic Custom Field tab of any assets associated with the 
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asset types to which this new field is assigned. 
 
 

 

 
Create a Date Field: 
  

a. On the Create New Dynamic Custom Field, enter the name of the field in the DCF Name field. This name 
will appear as the field label on the New/Edit Asset Screen > Dynamic Custom Fields tab. 
 
 

 

b. Enter the text of the tooltip that will appear when the user hovers their mouse over the field. This should be 
instructional text telling the user what type of information to enter. 
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c. Use the check boxes to mark if you want this dynamic custom field to be: 

 
 

 

• Visible - Selecting this check box makes the custom field visible to all users. 
• Required - Selecting this check box means the custom field must be completed in order for the new 

asset to be saved. 
• Sent to Mobile Device - Selecting this check box means this field will be visible to the mobile device 

and will appear on the Type tab when creating new assets.  
d. Select the asset types on which you want this field to appear.  
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The DCF Asset Type List contains a list of all your asset types. Select the check box in front of the Asset 
Type to add the field to it. You can also use the radio buttons above the list to make your selection. 

• Current - Select this option to only add this field to the asset type you are currently creating. This is 
the default selection. 

• Multiple - Select this option to allow the selection of additional assets in the list. Selecting this option 
enables the Select All and De-Select All buttons at the bottom of the list. 
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• Global - Select this option to add the field to all Asset Types in your system.  
 

 

e. When you have finished setting up the field, click the OK button. The new field now appears in the list on the 
Dynamic Custom Field tab on the New/Edit Asset Type screen. 
 

 
 
 
The field will appear on the New/Edit Asset > Dynamic Custom Field tab of any assets associated with the 
asset types to which this new field is assigned. 
 
 

 
 

Edit an Existing Dynamic Custom Field 

  
1. On the New Asset Type screen > Dynamic Custom Field tab, highlight the listing you want to edit, then click 

the Edit button. 
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The Edit Dynamic Custom Field screen appears: 
 

 

2. Make changes as needed on this screen, then click the OK button. 
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Delete a Dynamic Custom Field 

  
Highlight a listing on the New Asset Type > Dynamic Custom Fields screen, then click the Delete button. A drop 
down menu will appear. Options are: 
 
For Current - Deletes the Dynamic Custom Field you have selected on the list for this asset type only. 
For All - Deletes the Dynamic Custom Field you have selected from all asset types to which it is assigned.  
  
Note: If you select For All, all unsaved Dynamic Custom Fields will be deleted from the asset type. 

 

Add An Existing Dynamic Custom Field 

1. On the New/Edit Asset screen > Dynamic Custom Field tab, click the Add Existing button. 
 
 

 
 
 
The Dynamic Custom Field List appears displaying all fields you have already created. 
 
 
 

 

2. Highlight the field you want to add, then click the OK button. 
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3. The Edit Dynamic Custom Field screen will appear displaying the select field's information. Edit the field as 
needed. 

4. Click OK on the Edit screen to close it. 

5. The field is added to the Dynamic Custom Field tab on the New/Edit Asset screen and will appear on the 
New/Edit Asset > Dynamic Custom Field tab of any assets associated with the asset types to which this 
new field is assigned. 
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2.8 Editing Information 

2.8.1 Edit Asset 

The Edit Asset screen allows you to modify an existing asset.  This screen is accessed from the Asset List by 
highlighting an asset in the list, then clicking the Edit button on the toolbar.  For more information on using the List 
screens, see the Working with Lists topic. 
  
The Edit Asset screen is identical to the New Asset screen, except all the information previously entered for the asset 
appears on the screen.  You can change any of this information.  For information on using each tab of the screen, 
please refer to the Create New Asset topic. 
  

  

2.8.2 Edit Asset Type 

The Edit Asset Type screen allows you to modify an existing asset type.  This screen is accessed from the Asset Type 
List by highlighting an asset type in the list, then clicking the Edit button on the toolbar.  For more information on 
using the List screens, see the Working with Lists topic. 
  
Keep in mind that editing an Asset Type(The asset type is a category for assets.  Assets are assigned to a specific 
asset type.  For instance, you may have an Asset Type of Label Printers that defines the manufacturer, size specs, etc. 
of this particular type of printer.  Then specific printers of the same type are assigned to the Label Printers asset type.) 
will affect every Asset associated with that Asset Type. 
  
The Edit Asset Type screen is identical to the New Asset Type screen, except all the information previously entered 
for the asset type appears on the screen.  You can change any of this information.  For information on using each tab 
of the screen, please refer to the Create New Asset Type topic. 
  

  

2.8.3 Edit Contract/License 

The Contracts/Licenses feature is only available in the Professional and Enterprise versions of MobileAsset. 
  
The Edit Contract/License screen allows you to modify an existing contract/license.  This screen is accessed from the 
Contracts List by highlighting an contract in the list, then clicking the Edit button on the toolbar.  For more 
information on using the List screens, see the Working with Lists topic. 
  
The Edit Contract/License screen is identical to the New Contract/License screen, except all the information 
previously entered for the contract appears on the screen.  You can change any of this information.  For information 
on using each tab of the screen, please refer to the Create New Contract/License topic. 
  
  

  

2.8.4 Edit Customer 

The Edit Customer screen allows you to modify an existing customer.  This screen is accessed from the Customer 
List by highlighting an customer in the list, then clicking the Edit button on the toolbar.  For more information on 
using the List screens, see the Working with Lists topic. 
  
The Edit Customer screen is identical to the New Customer screen, except all the information previously entered for 
the customer appears on the screen.  You can change any of this information.  For information on using the New 
Customer screen, please refer to the Create New Customer topic. 
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2.8.5 Edit Depreciation Class 

The Edit Depreciation Class screen allows you to modify an existing Depreciation Class.  This screen is accessed 
from the Depreciation Class List by highlighting a listing and clicking the Edit Record button on the toolbar.  See the 
Working with Lists help topic for more information. 
  
The Edit Depreciation Class screen is identical to the New Depreciation Class screen, except all the information 
previously entered for the class appears on the screen.  You can change any of this information.  For information on 
using the screen, please refer to the Create New Depreciation Class topic. 
  
Keep in mind that any changes made to an existing Depreciation Class will impact depreciation calculations for every 
Asset Type associated with this class. 
  

  

2.8.6 Edit Department 

The Edit Department screen allows you to modify an existing department.  This screen is accessed from the 
Department List by highlighting an department in the list, then clicking the Edit button on the toolbar.  For more 
information on using the List screens, see the Working with Lists topic. 
  
The Edit Department screen is identical to the New Department screen, except all the information previously entered 
for the department appears on the screen.  You can change any of this information.  For information on using the 
Department screen, please refer to the Create New Department topic. 
  

  

2.8.7 Edit Employee 

The Edit Employee screen allows you to modify an existing employee.  This screen is accessed from the Employee 
List by highlighting an employee in the list, then clicking the Edit button on the toolbar.  For more information on 
using the List screens, see the Working with Lists topic. 
  
The Edit Employee screen is identical to the New Employee screen, except all the information previously entered for 
the employee appears on the screen.  You can change any of this information.  For information on using each tab of 
the Employee screen, please refer to the Create New Employee topic. 
  

  

2.8.8 Edit Funding 

Funding is only available in the Professional and Enterprise editions of MobileAsset.  
  
The Edit Funding screen allows you to modify an existing funding source.  This screen is accessed from the Funding 
List by highlighting an funding source in the list, then clicking the Edit button on the toolbar.  For more information on 
using the List screens, see the Working with Lists topic. 
  
  
The Edit Funding screen is identical to the New Funding screen, except all the information previously entered for the 
funding source appears on the screen.  You can change any of this information.  For information on using each tab 
of the screen, please refer to the Create New Funding topic. 
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2.8.9 Edit Location 

The Edit Location screen allows you to modify an existing location.  This screen is accessed from the Location List by 
highlighting a location in the list, then clicking the Edit button on the toolbar.  For more information on using the List 
screens, see the Working with Lists topic. 
  
The Edit Location screen is identical to the New Location screen, except all the information previously entered for the 
location appears on the screen.  You can change any of this information.  For information on using the Location 
screen, please refer to the Create New Location topic. 
  

  

2.8.10 Edit Manufacturer 

The Edit Manufacturer screen allows you to modify an existing Manufacturer.  This screen is accessed from the 
Manufacturer List by highlighting a manufacturer in the list, then clicking the Edit button on the toolbar.  For more 
information on using the List screens, see the Working with Lists topic. 
 
The Edit Manufacturer screen is identical to the New Manufacturer screen, except all the information previously 
entered for the manufacturer appears on the screen.  You can change any of this information.  For information on 
using the Manufacturer screen, please refer to the Create New Manufacturer topic. 
  
  

  

2.8.11 Edit Site 

The Edit Site screen allows you to modify an existing site.  This screen is accessed from the Site List by highlighting a 
site in the list, then clicking the Edit button on the toolbar.  For more information on using the List screens, see the 
Working with Lists topic. 
  
The Edit Site screen is identical to the New Site screen, except all the information previously entered for the site 
appears on the screen.  You can change any of this information.  For information on using the Site screen, please 
refer to the Create New Site topic. 
  

  

2.8.12 Edit Vendor 

The Edit Vendor screen allows you to modify an existing vendor.  This screen is accessed from the Vendor List by 
highlighting a vendor in the list, then clicking the Edit button on the toolbar.  For more information on using the List 
screens, see the Working with Lists topic. 
  
The Edit Vendor screen is identical to the New Vendor screen, except all the information previously entered for the 
vendor appears on the screen.  You can change any of this information.  For information on using the Vendor 
screen, please refer to the Create New Vendor topic. 
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2.8.13 Mass Update 

MobileAsset allows you to select multiple assets from the Asset List and update a number of fields. For example, if you 
want to update warranty information for all assets under a certain Asset Type, you can select all of those assets on the 
Asset List and make the change at one time. 
  
Using Mass Update: 
  

1. From the Main screen, select List Forms > Asset List. 
 
or 
 
From the Main screen, select Asset Management > List Assets. 

2. On the Asset List screen, select the assets you want to update. You can use the filter features to drill down to 
the assets you want. In the example below, we have filtered for Asset Type = Laptop IBM. 
 
  

3. Now select all assets you want to change by holding down the Ctrl key and clicking on each one you want. Or 
you can select assets by holding down the SHIFT key and clicking on two assets. All assets in between the two 
you clicked on will be selected. 
 
 
  

4. When you have selected the assets you want to change, click the Mass Update button on the toolbar: 
 
 

 
 
 
The Mass Update screen appears: 
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5. The top portion of the Mass Update screen displays the assets you have selected. If needed, scroll through the 
columns in this window using the bar on the right. As with other lists in MobileAsset, you can sort the list by 
clicking on the column headers. 

6. Select the checkboxes in front of each field you want to update, then enter the information you want to change. 
Any fields you have selected (a checkmark will appear in the box as shown in the example below) will be 
updated. Unchecked fields will not be updated. Remember that once you click Save, any information you enter 
here will be applied to all assets that appear in the window. 
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You can manually type information into the fields or use the drop down menus. Most drop down menus will 
provide the options of <Blank> and <More>.  <Blank> means any information previously contained in the field 
will be removed.  <More> accesses the associated List screen allowing you to select from all Manufacturers, 
Vendors, etc. 
 
Any fields that appear in bold are required fields. You cannot select Blank for required fields. Which fields are 
required will vary depending on your Custom Field Name settings. 
 
Keep in mind that the Depreciation checkbox cannot be selected unless all assets in the Mass Update window 
are associated with an Asset Type that can be depreciated. Depreciation is activated at the Asset Type level 
on the New Asset Type or Edit Asset Type screen. 
 
If the Edit Inherited Asset Type Data option is disabled on the Options screen, you will not be able to edit 
data under the Asset Type. 
 
 
Tap on the Custom Fields or Dynamic Custom Fields tabs to make updates to the values selected for any 
custom fields. Dynamic Custom Fields will only appear if they are associated with every asset being updated. 
For example, if you have selected 3 assets with the Asset Type - Printer, and one asset with the Asset Type - 
Monitor, and a DCF has been created for Printer, but not for Monitor, the Dynamic Custom Fields tab will be 
blank. 
 

7. After you have entered information in the desired fields, click the Save button. Remember that once you click 
Save, any information you enter here will be applied to all assets that appear in the window. 
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2.9 Using the List Screens 

2.9.1 Working with Lists 

The software contains several list screens that enable you to quickly view and access a variety of information.  Available 
list screens are: 
  

• Assets 
• Asset Types 
• Contracts/Licenses 
• Customers 
• Departments 
• Depreciation Classes 

• Employees 
• Funding 
• Locations 
• Manufacturers 
• Sites 
• Transactions 
• Vendors 

  
  
Note: These screens all function the same; however, individual options may vary for each screen. This topic covers how 
to use all functions available on the list screens. Keep in mind that not all list screens contain all functions mentioned 
here. In addition, some of these functions are available in the Professional and Enterprise editions of MobileAsset only. 
If you are using the Standard edition of MobileAsset, those options specific to the Professional and Enterprise editions 
will not appear on your screen.  Most screen shots in this Help file are of the Professional edition of MobileAsset. Not all 
features/tabs shown on these screens are available in the Standard edition of MobileAsset. Any items that are specific 
to the Professional and Enterprise editions are marked as such in this documentation.  
  
Below is an example of the basic list screen layout. This is an example of the Asset List, the list screen you will probably 
use most often. The list screens are divided into sections (labeled A through E in the example below): 
  

 
  
A. Menu Bar 
B. Toolbar 
C. Search Field 
D. Contents List  
E. Buttons  
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In addition to these menus there are also "Context-Sensitive Menus" that appear when you right-click on certain areas 
of the screen. These provide another way to access many of the functions available in the toolbar. These types of 
menus are also discussed later in this section. 
  
Quick Links 
  
Click a link below to jump to that section of the topic: 
  
Section A: Menu Bar 
Section B: Toolbar 
Section C: Search Field 
Section D: Contents List 
Section E: Buttons 
"Context-Sensitive Menus" 

 

Section A: Menu Bar 

The menu bar appears at the top of the screen and provides access to two menus: 
  
Tools- Accesses the Reset View Settings function. This option is found at the top of all lists. Select this option to reset 
all lists to their default settings. All filters, rearranged columns, group settings, etc. will be reverted to their default 
statuses. 
  
View (Asset List Only) - The View menu option allows you to filter what assets display in the list. Options are: 
  

• Linked Assets Only  - (Professional and Enterprise editions) Displays only Linked assets 
• Unlinked Assets Only - (Professional and Enterprise editions) Displays only assets that are not linked to other 

assets. 
• Top Level (linked) Assets Only - (Professional and Enterprise editions) Displays only "Parent" assets, not the 

assets associated with them. 
• Top Level (all) Assets Only - (Professional and Enterprise editions) 
• Disposed Assets - Displays all assets that have been marked as Disposed. 

Section B: Toolbar 

The toolbar at the top of the list screen provides quick access to a variety of functions and also allows you to customize 
how the information on the list is displayed. Keep in mind that if the >> icon appears in the toolbar of your list, there are 
hidden icons. 
  
Re-Ordering Icons - You can re-order the icons contained in the toolbars. For example, you can move the Magnifying 
Glass icon (access the Filter function) from the far left position on the toolbar to the far right position. To do this: 
  

1. Press and hold the ALT key on your keyboard, 
2. Click on an icon and drag it to a new position on the toolbar. 

Displaying Hidden Icons - If the list contains too many icons to display at one time you will see a double arrows icon in 
the top right corner of the toolbar as shown below: 
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Click on the double arrows to display the hidden icons: 

 
Each of the functions available on the toolbars is described below: 

Button Description 
Filter Accesses the Find screen allowing you to quickly enter information to narrow your search. For more 

information on the Find screen, please see the Simple Find help topic. 
Toggle Filter Toggle Filter - Once you have entered a filter(specific search criteria entered on the Find screen to 

narrow the search results) on the Find screen, the list results will be limited to the information you 
entered. For example, if on the Find screen you designated that you want to view only items with Asset 
Tag 243, only the item with Asset Tag 243 will appear in your list. You can click on the Toggle Filter 
button to revert back to seeing all of the list items.  Click it again to reapply your filter. 

New New - Accesses the New screen allowing you to enter a new Asset, Asset Type, etc.   
Edit Edit - Assesses the Edit screen allowing you to update and change information. 
Dispose Dispose or Delete - This icon is called Dispose on the Asset List. It allows you to Dispose of the selected 

item in the list. For more information on the Dispose transaction, please see the Dispose help topic. 
This icon is called Delete on other lists. It allows you to delete selected items in the lists.   

Duplicate Duplicate - Allows you to copy the information from the item selected in the list to a new item. 
Mass 
Update 

Mass Update - MobileAsset allows you to select multiple Assets from the Asset List and update a 
number of fields. For example, if you want to update warranty information for all Assets under a certain 
Asset Type, you can select all of those assets on the Asset List and make the change at one time. For 
more information on the Mass Update transaction, please see the Mass Update help topic. 

Check In Check In-  Accesses the Check In screen allowing you to check in an asset. For more information on 
the Check In feature, please see the Check-In help topic. 

Check Out Check Out - Accesses the Check Out screen allowing you to check out an asset to an employee or 
customer. For more information on the Check Out feature, please see the Check-Out help topic. 

Move Move - Accesses the Move screen allowing you to move one or more assets from one location to 
another. For more information on the Move feature, please see the Move help topic. 

Maintenance Maintenance - Accesses the Maintenance screen allowing you to set up one time or recurring 
maintenance on an asset. For more information on the Maintenance feature, please see the 
Maintenance help topic. 

View View Linking- This option appears on the Professional and Enterprise editions only. If you are 
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Linking using asset linking, highlight a listing, then click the View Links button to view the parent asset and any 
children. Below is an example of the View Linked Assets screen. 
 

 
 
There is a toolbar at the top of this screen allowing you to perform actions on the assets on the screen. 
These functions are listed below: 

• New 
• Edit 
• Dispose 
• Duplicate 
• Check In 
• Check Out 
• Move 

Print Print - Allows you to print the list.  When this button is selected, a standard Page Setup screen appears 
allowing you to enter margins. An example of this screen is shown below: 
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Click the OK button on the Page Setup screen to print the list. The list will print to your default printer.   
  
  

Export Export - Allows you to export the entire asset list to a comma-delimited text file.   
  
What is a comma-delimited file? This is a type of data format in which each piece of data is separated 
by a comma. This is a popular format for transferring data from one application to another, because most 
database systems are able to import and export comma-delimited data. 
 
For example, data pulled from a database and represented in comma-delimited format looks something 
like the following. Each column value is separated by a comma from the next column’s value and each 
row starts a new line: 
 
Adams, Jane, 46, female, New York 
Doe, John, 32, male, California 
Jones, Sam, 13, male, Texas 
Smith, Mary, 64, female, Louisiana 
 
When data is represented in comma-delimited format they also are referred to as comma-separated 
values, abbreviated CSV. 
  
When the Export button is selected, a screen appears allowing you to specify where the exported data 
will be saved on your computer. An example of the Export screen is shown below: 
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Make sure you save this to a location you can remember. You must also choose a name for your file on 
this screen. After you have made your selections, click Save to export your data. 
  
A confirmation message will appear when your data has been successfully exported by the system.   

Group Display/Hide Group Selections - The list screens provide you with the capability of "grouping" the 
displayed information so you can view data in a way that is most easy-to-read for you.  You can have one 
group, two groups, or many groups depending on how you want to view your information. For instance, if 
you want all assets on the Asset List to be displayed grouped by location, you can quickly set this up.   
To see the grouping options, click the Display/Hide Group Selections button. The top of the list screen 
expands to display the group selections as shown below: 
  

 
  
Creating Groups 
  

1. To create a new group, click on a column header, then drag it to the space indicated on the 
screen. For example, if you want to group information by Site, click on the Site column header 
and drag it to the indicated space. 
 

87 



 
  

Wasp MobileAsset User Manual 

 

2. The screen now lists Site as one of your groups and the assets are grouped according to what 
Site they are assigned. 
 

 

3. You can create additional groups to further organize your information by continuing to drag and 
drop column headers. For example, you can create a second group for Locations within Sites by 
dragging the Location column header to the top of the screen.   
 
Now the Asset List groups information by Site, and then by Location. 
 

 

4. By default, the groups list information in ascending order (Site 001, Site 002, etc.). You can 
change this to descending order by clicking on the group name. Notice that after you click on the 
group name, the arrow next to the name is now pointing in the opposite direction and the 
information on the screen is reorganized. 
 

 
Deleting Groups 
  

1. If you no longer want to display information in a particular group you can easily ungroup the data. 
For instance, if you have created a group for Site and another for Location, but now wish to only 
group by site, you can remove the location group by clicking on the group name and dragging it 
down into the column header section. Let go of your cursor anywhere in the column header 
section and the group disappears.  
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2. The information contained in that group still appears on the display screen, but it is no longer 
grouped together. 
 

 
  

Print Tags Print Tags/Labels/Badges - This button is available on the Asset, Employee and Location Lists. This 
option allows you to print barcode labels for any assets, employees, etc. selected in the list.   
  
Note:  You must select a Label Printer prior to printing tags from the List screens. To do this, see the 
topic Selecting a Label Printer. 
  
To Print Tags/Labels: 
  

1. Click the Print Tags button on the toolbar. The following screen will appear: 
 

 

2. Enter the number of labels you want to print for each selected item. 

3. Click the OK button. 
  

Show 
Hidden 
Columns 

Show Hidden Columns - The list allows you to hide columns by right-clicking on a column label and 
selecting Hide Column. This enables you to hide information you do not usually need.  You can quickly 
view the columns you have hidden by clicking the Show Hidden Columns button. A popup screen similar 
to the one below appears listing all columns that are not currently visible. 
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You can return these columns to the full List screen by clicking on a listing in the Hidden Columns 
screen and dragging it back to the column labels section on the List screen.   
 
When you hide a column, it will remain hidden until you manually return it to the List screen by following 
the instructions above. 
  

Views Views - This icon allows you to save your list settings, including any filters (search criteria), group 
settings, reordered columns, etc. Click on the icon arrow to view available options for this feature, as 
shown below: 
  

 
  
Options are: 
  

• Save/Save as - Accesses the Save View screen allowing you to name and save list settings. 
• Delete - Click the arrow to view a list of views. To delete: 

  
a. Select Views > Delete. A list of all saved views appears. 
b. Click on the filter you want to delete. 

 

 

c. A confirmation message similar to the one below appears: 
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Click Yes on the confirmation message. 
  

• Load -This option allows you to apply a saved view to the list. 
 
To load a saved filter: 

a. Select Views > Load. A list of all saved views appears. 
b. Click on the view you want to apply: 

 
 

 

c. The selected view will be applied to your list. 
  

• Reset View Settings - This option is found at the top of all lists. Select this option to reset all lists 
to their default settings. All filters, rearranged columns, group settings, etc. will be reverted to 
their default statuses. 

 

Section C: Search Field 

 
  
The Search bar allows you to enter a full or partial asset tag by which to search the database. To search enter a full or 
partial asset tag and press the <ENTER> key. Click the down arrow to the right of the search field to view a list of recent 
searches. If a matching asset tag is found, the Edit Asset screen will appear. If there are several matches, the Asset 
List will appear with the matching tags displayed. 
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Section D: Contents List 

 

The contents list displays all data related to the selected list. For example, if you selected the Asset List, all assets will 
display here, if you selected the Locations list, all locations will display here, etc. 
  
Sorting Columns: Most of the columns that appear in the lists can be sorted ascending or descending. The columns 
sort ascending by default. To change the sort order, click on the column heading.  An arrow will appear next to the 
column name to let you know in which direction the information is sorted. The example below shows the Site column 
sorted Ascending. 
 

 
  
Selecting a Listing: The list screens can display up to 1000 lines of information at a time (for information on setting the 
row limit, click here). You can quickly scroll through the listings, or view columns that are hidden from view by using the 
buttons directly below the contents list. Keep in mind that you can also use the Display Hidden Columns button to 
view columns that are normally hidden (see Section A: Toolbars, above).   
  
You can click on a listing to highlight it, then click the button that accesses the desired function. For example, if you 
want to edit Asset Tag 4002, use your mouse to click on that item in your Asset List, then click the Edit button. 
  
Selecting Multiple Listings: You can select multiple listings at one time by holding down the Ctrl and clicking the 
listings with your mouse. Multi-select can be used for Deleting items, the Mass Update feature and Maintenance. 
  
Arranging Columns: You can arrange the columns in the list into any order you wish.  To change the order, click on a 
column heading and drag it somewhere else on the list. For example, if you want to make Site the first column in your 
Asset List, click on the Site column heading and drag it to the first column in the list as shown below: 
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After you drop the column into its new position, the list will reorganize with the Site information appearing first: 
  

 
 

Section E: Buttons and Status Bar 

 
 
This section contains the following: 
  
Help - Click this button to access this help document. 
Close - Click this button to close the list.  Keep in mind when closing the list that your groups and column settings will 
be retained. 
Status Bar - The bar at the bottom of the screen indicates what filters you currently have set for the list. 

 

Context-Sensitive Menus 

MobileAsset provides you with a toolbar for quick access to various list features and, in addition, many of these features 
can also be accessed via "context-sensitive menus". By right-clicking on a column heading, a list of available features 
appears, as shown below: 
  
  

 
  
These features allow you to sort, group and hide columns in the list. Any changes you make to the list via this menu will 
be retained when the screen is closed and re-opened. 
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Save View Screen 

This screen, accessed from some List screens, allows you to save settings you have made on the List screen, including 
search criteria, grouping, column reordering, etc. For more information on the Save Named Filters function, please 
refer to the topic Working with Lists.   
  
Using the Save View Screen: 
  

1. After you have arranged, grouped, filtered the list as desired, select the Views icon from the toolbar.   
 
 

 
  

2. Click on Save/Save As. The Save View screen appears: 
 

 

3. Enter a name for these list settings in the Name field. 

4. You can optionally enter a description for the filter in the Description field. 

5. If you want this view to be the default list view, select the Set as Default checkbox. The list will always open 
with the saved settings when you open it. 

6. If you want the view to be visible to everyone who accesses the List screen, select the Visible for All Users 
checkbox. This means that any users who is logged in to MobileAsset and has access to the List screens can 
see this view. 

7. Click the OK button to save your settings.    
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2.9.2 Asset List 

The Asset List, accessed from the Main screen by selecting List Forms > Assets, allows you view assets you have 
already setup and to create new or modify existing assets. For detailed information on working with list screens, please 
see Working with Lists. Below is an example of the Asset List. 
  
  
  

 
 
Notice that in the example above, the highlighted asset has a Dynamic Custom Field associated with it. The Dynamic 
Custom Field and its value appear in the window on the right side of the screen. 
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2.9.3 Asset Type List 

The Asset Type List, accessed from the Main screen by selecting List Forms > Asset Types, allows you to view 
Asset Types you have already setup and to create new or modify existing asset types. For detailed information on 
working with list screens, please see Working with Lists.   
  
  
Below is an example of the Asset Type List. 
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2.9.4 Contracts List 

The Contracts/Licenses feature is only available in the Professional and Enterprise editions of MobileAsset. 
  
The Contracts List, accessed from the Main screen by selecting List Forms > Contracts, allows you view contracts 
you have already setup and to create new or modify existing contracts. For detailed information on working with list 
screens, please see Working with Lists. Below is an example of the Contracts List. 
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2.9.5 Customer List 

The Customer List, accessed from the Main screen by selecting List Forms > Customers, allows you view customers 
you have already setup and to create new or modify existing customers. For detailed information on working with list 
screens, please see Working with Lists. Below is an example of the Customer List. 
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2.9.6 Department List 

The Department List, accessed from the Main screen by selecting List Forms > Departments, allows you view 
Departments you have already setup and to create new or modify existing departments. For detailed information on 
working with list screens, please see Working with Lists. Below is an example of the Department List. 
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2.9.7 Depreciation Class List 

The Depreciation Class List, accessed from the Main screen by selecting List Forms > Depreciation Classes, 
allows you view depreciation classes you have already setup and to create new or modify existing classes. For detailed 
information on working with list screens, please see Working with Lists. Below is an example of the Depreciation 
Class List. 
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2.9.8 Employee List 

The Employee List, accessed from the Main screen by selecting List Forms > Employees, allows you view 
employees you have already setup and to create new or modify existing employees. For detailed information on working 
with list screens, please see Working with Lists. Below is an example of the Employee List. 
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2.9.9 Funding List  

Funding is only available in the Professional and Enterprise editions of MobileAsset.  
  

The Funding List, accessed from the Main screen by selecting List Forms > Funding , allows you view any Funding 
sources you have already setup and to create new or modify existing funds. For detailed information on working with list 
screens, please see Working with Lists. Below is an example of the Funding List. 
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2.9.10 Location List 

The Location List, accessed from the Main screen by selecting List Forms > Locations allows you view Locations 
you have already setup and to create new or modify existing locations. For detailed information on working with list 
screens, please see Working with Lists. Below is an example of the Location List. 
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2.9.11 Manufacturer List 

The Manufacturer List, accessed from the Main screen by selecting List Forms > Manufacturers allows you view 
Manufacturers you have already setup and to create new or modify existing manufacturers. For detailed information on 
working with list screens, please see Working with Lists. Below is an example of the Manufacturer List. 
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2.9.12 Site List 

The Site List, accessed from the Main screen by selecting List Forms > Sites, allows you view Sites you have already 
setup and to create new or modify existing Sites. For detailed information on working with list screens, please see 
Working with Lists. Below is an example of the Site List. 
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2.9.13 Transaction List 

The Transaction List displays all transactions completed in MobileAsset. For detailed information on working with list 
screens, please see Working with Lists.   

Below is an example of the Transaction List: 

Note: If a Maintenance transaction is selected, the Signature icon will change to "Pictures". Click the Pictures icon to 
view any pictures taken of the asset during that maintenance transaction. 
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Note: You can re-print the check out/check in receipt created on a mobile device by highlighting the check 
out/check in transaction, then clicking the Reprint Receipt button.
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2.9.14 Vendor List 

The Vendor List, accessed from the Main screen by selecting List Forms > Vendors, allows you view Vendors you 
have already setup and to create new or modify existing Vendors. For detailed information on working with list screens, 
please see Working with Lists. Below is an example of the Vendor List. 
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2.10 Asset Management 

2.10.1 Create New Asset 

The New Asset screen is used to enter a new asset into the database. 
  
Note: Most screenshots in this Help file are of the Professional version of MobileAsset. Not all features/tabs shown in 
these screens are available in the Standard version of MobileAsset.  
  
Note for Mobile Device Users: Assets can also be added on a Windows Mobile/CE, iOS (Professional and 
Enterprise Only) or Android (Professional and Enterprise Only) mobile device. 
  
The following topics are discussed in this section: 
Accessing the New Asset Screen 
General Tab 
Asset Linking Tab 
Depreciation Tab 
Picture Tab 
Attachments Tab 
Maintenance Tab 
Contracts Tab - Professional and Enterprise Editions Only 
Funding Tab - Professional and Enterprise Editions Only 
Transaction History Tab 
Custom Fields Tab 
Dynamic Custom Fields 
  

 

Accessing the New Asset Screen 

  
To access this feature, from the Main screen select Asset Management > New Asset. 
 
This feature can also be accessed from the Asset List by clicking the New button on the toolbar. For more 
information on using the list screens, click here. 
  
The New Asset screen is broken into several tabs. Use the following links to jump ahead to the tab of interest: 
  
General, Asset Linking (Professional and Enterprise Editions), Depreciation, Attachments, Picture, 
Maintenance,  Contracts (Professional and Enterprise Editions), Funding (Professional and Enterprise 
Editions), Transaction History, Custom Fields, Dynamic Custom Fields 
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New Asset Screen > General Tab 

  

 

Note:  If the Automatic Asset Tags function is turned on (Administration > Options), the Asset Tag field will appear 
as follows: 
 

 
You may notice that some fields on this and other tabs have a Pin icon in front of them.  These fields represent data that 
can be "pinned".  Pinning allows you to "lock" the information entered into a field. This is convenient if, for example, you 
are entering multiple new assets for a particular site and location. You can enter the site and location once, then pin 
them.  The fields will retain the information you entered through each new entry until you unpin them. Fields are Pinned 

by clicking on their pushpins , causing them to look like this . Click the pushpin again to unlock the field for entry of a 
different value. 
 
 
Click the Pin All icon to pin every field that offers the pinning feature. Click it again to undo pinning for all fields. 

1. Enter information in the required fields. You must enter information in the Asset Tag, Asset Type, Site and 
Location fields.  
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Note:  If you are using Automatic Asset Tags, you do not need to enter anything in the Asset Tag field. The 
tag will be generated when you click the Save button or when you click the button next to the Asset Tag field. 
 
If you have enabled the Edit Inherited Asset Type Data option on the Options screen, the message screen 
below will appear when you select the Asset Type and you can make changes to the information that is 
populated from the Asset Type. These fields include the Manufacturer, Model, Vendor Number, Check Out 
Length, Check Out Lead Time and Reminder Lead Time. Any changes made to these fields apply to the current 
asset only. (If this option is not enabled, these fields will be disabled and you will not be able to make changes.) 
 

 
 
Select Yes to populate fields with information from the Asset Type. For example, if Check Out Length 
information is entered for the Asset Type, it will appear here. 
 
Keep in mind that you can set the check out length to only consider weekdays and the due date to only fall on a 
weekday on the Options screen. You can set the asset to have no due date by leaving the values in the Check 
Out Length fields at 0.  
 
 
 
If you do not want to incorporate information from the Asset Type, other than the Asset Type number and 
Description, click No. 

2. The Department Code, Serial No., Condition, Hyperlink and Additional Info fields are optional. 
 
The Hyperlink field can be used to store a link to the manufacturer's website, or even to a location on your 
network. When a valid web address is entered in this field, the icon next to it will be enabled.  Clicking the icon 
will open your web browser and access the website. 
 
Note: When using the drop down lists to enter information in a field (Asset Type, Site, Location, etc.), the last 
few selections will appear in the list.  If you want to search for an existing value, select <More> from that field's 
drop down list to access the List screen.  Use the vertical scroll bar to select a record from the List and click the 
List dialog's Select button. 
 
  

3. Click Save if you are done entering information for this asset or click on another tab to proceed with entering 
more information. 

 

New Asset Screen > Asset Linking Tab 

  
Asset Linking is only available in the Professional and Enterprise editions of MobileAsset.  Asset Linking allows 
you to link two or more assets together to form one new asset. For example, the asset Mary's Computer may consist of 
4 separate assets - CPU, Keyboard, Mouse and Monitor. These four individual assets are linked together to form one 
new asset, Mary's Computer.  For a complete definition of Asset Linking and an example, please refer to the 
Definitions topic. 
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The Asset Linking tab allows you to create links: 
  

 

1. The Asset Tag value entered on the General tab will be displayed at the top, but can still be edited, if desired. 

2. If this asset is to be the Parent, or top-level asset, of this group, you can leave the "Parent Asset" field blank. If 
you want to give this asset a parent (for instance, if this asset is a monitor and you want to link to the asset 
Mary's Computer), select an asset from the drop down list. 
 
The asset can have a parent assigned to it and be a parent (have child assets assigned to it). 
 
Select <More> from the drop down list to access the Asset List. Remember, you can filter the asset list to only 
display "Top Level" assets, or parent assets, if needed. See the Working with Lists topic for further 
information. 

3. To associate child assets with this asset (the current asset will be the "parent" of these assets), click the Link 
button below the "Child Asset(s)" window. The Asset List will appear. 
 
Highlight the desired asset in the Asset List, then click the Select button. The selected asset will appear in the 
"Child Asset(s)" window as shown below: 
 

 
 
 
In this example, Asset 1002 is the parent of the current asset and asset 1 is the child. 
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A Note about the Transact as Whole Flag: In the example above, the Transact as whole flag is checked; 
therefore, any functions (check in, check out, audit, move, etc.) will be performed as a whole for the group.  This 
flag is driven from the top down, meaning the selection made for the parent asset will override the selection for 
a child asset. If you want to move only one asset that is a child of this asset, you will need to deselect this check 
box. Deselecting it on the Edit Asset > Asset Linking tab for the child asset will not override the selection 
made for this asset, and this group would still be moved as a whole. Similarly, if the Transact as whole flag 
was NOT selected on this tab, but it IS selected for the parent of this asset, the group would still be transacted 
as a whole because the selections made for the parent of this asset would take precedence.   
 
Also keep in mind that when you check out an asset that has Transact as whole turned on and you select to 
use the Default Due Date (on the Check Out screen) MobileAsset will search all assets linked to the selected 
asset to find the maximum checkout duration. The software will use this maximum length to calculate the due 
dates for all the linked assets. This ensures that all the assets in the transaction have the same due date even if 
some of the linked assets have different checkout durations. 

4. You can unlink child assets by highlighting the asset in the Child Assets list and clicking the Unlink button. 

5. Click Save if you are done entering information for this asset or click another tab to proceed with entering more 
information. 

 
  

New Asset Screen > Depreciation Tab 

  
Click the Depreciation tab if you want the software to calculate depreciation for this asset. The method used by the 
system to calculate depreciation is dependent on the Asset Type assigned to this asset. 
  

 

1. The Asset Tag value entered on the General tab will be displayed at the top, but can still be edited, if desired. 

2. Click the Depreciate Asset check box if you want the software to calculate depreciation. The Depreciate 
Asset check box will be disabled if a Depreciation Class has not been defined for the Asset Type specified on 
the General tab -or- that Asset Type  has a Depreciation Class, but its Depreciation Method is "None". 
 
The depreciation method used for an asset is determined by the Depreciation Class assigned to the 
Asset Type. This information appears in the Class Info box and cannot be modified from this screen. If you 
want to change the Depreciation Method or the Life of a particular asset, you will need to make changes to 
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the Depreciation Class assigned to the Asset Type, or create a new Depreciation Class to assign to the Asset 
Type. See the Depreciation Class help topic for further information. 

3. Purchase Cost and Depreciation Begin Date are required fields when Depreciate Asset has been enabled, 
therefore, you must complete them if you want to calculate depreciation. These two fields are used in the 
calculation. Please see the Definitions topic for detailed explanations of each Depreciation Method. 
 
A Purchase Cost should also be entered here if you plan to use the Funding feature to track this asset. You 
will need the purchase cost here in order to record this debit from the funding source. 
 
  

4. Purchase Order, Purchase Date and Salvage Value are optional fields. If a Salvage Value is not specified, 
the Calculate Depreciation function will assume a Salvage Value of zero dollars. 
 
The Class Info, Last Depreciation Date, Total Depreciation, Current Depreciation, and Depreciated Value 
cannot be modified. Information is populated in these fields by the system as depreciation functions are 
performed. 

5. Click Save if you are done entering information for this asset or click the next tab to proceed with entering more 
information. 

 
  

New Asset Screen > Picture Tab 

  
Click the Picture tab to view any image files that have been attached to either the Asset Type Attachments folder or 
the Asset Attachments folder: 
  

 
  

1. The first time you access this tab, click on the picture area to add a picture. 
 
The current default picture is always displayed on the Picture tab.  Right click the image to see the popup 
Picture menu. This menu allows you to Add (a new) Image or to Select (a previously added) Image.  Any 
image you select for display will become the new default image.   
 
The files listed in the Select Image sub-menu are a combination of Asset Type Attachment images and Asset 
Attachments images, sorted alphabetically, by filename. 
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2. Image files are not actually added to the database until the Save button is clicked. You can click it at this time if 
you are finished adding additional information, or click it later, after you have completed information on other 
tabs. 

  
 

  
New Asset  Screen > Attachments Tab 
  
To attach an image or other documentation to this asset, click on the Attachments tab: 
  

 

1. To add an attachment, click the Add button. A screen will appear allowing you to navigate to the desired file on 
your computer. Attachments are copied to the MobileAsset database from the external source you browse to 
when you click the Add button. Any change made to the external source file after adding the attachment will not 
update the attachment in the database. To update the database with a later version of an attached file, you 
must first remove the attachment from the database, then add the file again. 
 
Asset Attachments relate only to the specific asset being recorded. Asset Type Attachments relate to every 
asset recorded for this Asset Type. 

2. If you have attached an image, you can designate this the "default" image (meaning this is the image that will 
appear on the Picture tab) by clicking the Set Default Image button. 

3. After you have added at least one file, the View button is enabled. This feature allows you to view the attached 
file. The file associations defined in Windows Explorer determine which application will be started to open files, 
based on their filename extensions. On most machines, a PDF file would be opened by Adobe®  Reader, for 
example. Image attachments can be viewed the same way or you can use the Picture tab to use MobileAsset's 
internal image viewer. 
 
The Save to File button copies the selected attachment from the database to any drive and folder available on 
your system. 
 
The Remove button can only be used to remove asset attachments. It is grayed-out (disabled) when an Asset 
Type Attachment is selected. These Asset Type Attachments may be related to other Asset Tags under the 
same Asset Type. Asset Type Attachments can only be removed via the Edit Asset Type Attachments tab (see 
Create New Asset Type for further information). 

4. Attachments are not actually added to the database until the Save button is clicked. You can click it at this time 
if you are finished adding additional information, or click it later, after you have completed information on other 
tabs. 
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New Asset Screen >  Maintenance Tab 

  
The Maintenance tab allows you to define maintenance procedures, a maintenance schedule, and warranty information 
for an asset. 
  
This tab allows you to: 
  
Enter Warranty Information 
Enter New Maintenance Schedules 
Edit Existing Maintenance Schedules 
View Maintenance History 
  
Below is an example of the Maintenance tab: 
  

 
  
Entering Warranty Information 
  

1. You can optionally enter Warranty Begin and End date at the top of this tab.   
 
Click on the Calendar icon to access the calendar feature: 
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You can also click on the Month/Year to view a list of all months. You can then click on a month to quickly 
switch dates: 
 

 

2. You can optionally enter the warranty provider in the Provider field.   

 

Entering New Maintenance Schedules 

To enter a new maintenance schedule 
  

1. Click the New button below the window: 
 

 
 
The Maintenance Schedule screen appears: 
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2. Enter a name for this maintenance schedule. 

3. Select the employee who this asset will be assigned to from the Assigned To drop down list. All employees 
currently entered into the MobileAsset database will appear in the drop down list. 

4. Select how often this maintenance schedule is to happen from the Occurs drop down list. The area below the 
Occurs drop down list will change depending on the selection you make here. Your options are: 

• Date - This option indicates a one-time maintenance procedure. When you select this option, a 
Date field will appear below the Occurs drop down list.   
 
 

 
 
Select the date on which the maintenance should take place. You can click on the calendar 
icon to select a date or type a date directly into the field. 

• Daily - This option allows you to specify a Maintenance Start date, followed by a frequency 
specified as Every x number of days (up to a maximum of every 366 days). 
 

 
 
In this example, maintenance would be performed every 10 days beginning Monday, August 
24, 2009. 
 
The Next Date at the bottom of the screen indicates the next date maintenance will be 
performed on this asset. 

• Weekly - This option allows you to specify a Maintenance Start date, followed by the 
frequency specified as Every x number or weeks. You will also select the days of the week on 
which the maintenance is to be performed. More than one weekday can be selected. 
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In this example, maintenance will be performed every week on Fridays beginning the week of 
Monday, August 24, 2009. 
 
The Next Date at the bottom of the screen indicates the next date maintenance will be 
performed on this asset. In this example, since we have selected Friday as the maintenance 
day, the Next Date is Friday, August 28, 2009. 

• Monthly - This option allows you to specify a Maintenance Start date, followed by your choice 
of two possibilities: Maintenance Every x number of months (up to a maximum of every 99 
months) as shown below: 
 

 
 
In this example, maintenance will occur on the 1st day of each month every month. 
 
Notice the Next Date reflects the first day of the next month. 
 
OR 
 
Maintenance can be set to occur on a specific weekday of every x number of months (up to a 
maximum of every 99 months) as shown below: 
 

 
 
In this example, maintenance will occur on the first Thursday of every month. 
 
Notice the Next Date reflects the first Thursday of the next month from the Start Date. 

• Disable - This option is used when you want to temporarily disable an existing maintenance 
schedule. Highlight the maintenance schedule in the list, then click Edit.  On the Maintenance 
Schedule screen, select Disabled from the Occurs drop down box. You can also set up a new 
maintenance schedule as Disabled then enable it later by select Daily, Weekly, etc. 

5. Select Should Email if you want an email reminder sent when the next maintenance date is due. The email will 
be sent to the recipients indicated on the Options screen. For more information on setting these options, please 
refer to the topic Reminder Alert Options.  
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6. if you select the Should Email checkbox, enter the number of days and/or hours/mins prior to the due date you 
want the email to be sent in the Reminder Lead Time fields. 

7. Enter any special instructions in the Instructions text field. 

8. Click Save when you are done entering information for this maintenance schedule. The schedule will appear in 
the list on the Maintenance tab: 
 

 

Editing Existing Maintenance Schedules 

1. Highlight the maintenance entry you want to edit, then click the Edit button. The Maintenance Schedule 
screen will appear populated with the selected entry's information. 

2. Make changes as necessary, then click the Save button. The edited entry will appear in the list on the 
Maintenance tab. 

Viewing Maintenance History 

The Maintenance History screen displays all completed maintenance on this asset. 

1. Click the View History button. The Maintenance History screen will appear: 
 
 

 

2. When you first access this screen, all maintenance entries associated with the selected maintenance schedule 
are displayed. You can change the selected schedule using the Schedule drop down menu. You can also enter 
From and To dates to further filter the list. 
 
Click the Show All button to remove the filter. 
 
Select the Print History button to print a list of the displayed maintenance entries. 
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New Asset Screen > Contracts Tab 

  
The Contracts tab is only available in the Professional and Enterprise editions of MobileAsset. The Contracts 
tab allows you to record contract and/or software licenses associated with this asset. The tab will appear empty when 
you are first adding a new asset. You can add contracts and licenses to this asset as needed from this tab. 
Contracts/licenses can be added to the database via the Contracts List screen. 
 

 
  

1. To add a contract/license, click the Add button. The Contracts List will appear. Select the desired contract 
from the list, then click Select on the Contracts List screen. The selected contract(s) will appear on the 
Contracts tab as shown in the example below: 
 

 

2. You can remove a contract by highlighting it in the window, then clicking the Remove button. 
 
Click Select All to select all contracts in the window. 
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Click Clear All to deselect all contract in the window. 

3. Click Save if you are done entering information for this asset or click the next tab to proceed with entering more 
information 

 
  

New Asset Screen - Funding 

The Funding tab is only available in the Professional and Enterprise editions of MobileAsset. The Funding tab 
allows you to keep track of any grants or funding sources for your assets. Below is an example of the Funding tab: 
  

 
  
To associate a funding source with this asset: 
  

1. Click the Add button at the bottom of the tab. The Funding List appears.   

2. Highlight the desired funding source, then click the Select button to add it to this asset. Note: You can also 
create a new funding source from the Funding List by clicking the New button. 
 
The selected funding source will appear on the Funding tab. 
 

 

3. The Debited from Fund field in the list is editable. You can click on this field to enter the amount of funds used. 
The Available Funds column will update by subtracting the debited amount. Please note that the amount 
entered here must be less than the Purchase Cost entered on the New/Edit Asset screen > Depreciation 
tab. 
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New Asset Screen > Transaction History Tab 
  
The Transaction History tab displays data only after one or more Asset Management transactions have been 
performed (check in, check out, etc.). 
  

 
  

1. Click Print Transactions to send a list of the transactions for this asset to the printer. 

2. Click Save if you are done entering information for this asset or click another tab to proceed with entering more 
information. 
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New Asset Screen > Custom Fields Tab 

  

 
  
Please refer to the Using Custom Fields topic for instructions on creating custom text, number and date fields.   
  
If the Close New Form option is enabled on the Options screen and no fields are pinned, the screen will close when 
the Save button is clicked. 
  

 

New Asset Screen > Dynamic Custom Fields 

  
Dynamic Custom Fields are customized text, date and/or number fields that you create on Asset Types. The field(s) 
will appear on the Dynamic Custom Field tab of any assets that are assigned to that asset type. These fields differ from 
regular custom fields in that you can set them to be associated with a specific asset type, multiple asset types that you 
select or on all asset types. You can also create a tooltip for each field to provide users with information on what data 
should be entered.  Dynamic Custom Fields can be searched via the Search screens or the Search field on the Main 
screen. In addition, Dynamic Custom Fields can be edited via the Mass Update function. 

  
Please refer to the Using Dynamic Custom Fields topic for instructions on creating dynamic text, number and date 
fields. 
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2.10.2 Move Asset 

The Move Asset function is used to relocate an Asset from one location to another. 
  
Note for Mobile Device Users:  Move Asset can also be done on a Windows Mobile/CE, Android (Pro and Ent 
only) and iOS (Pro and Ent only) devices. 
  

1. To access this function, from the Main screen select Asset Management > Move. The Move screen shown 
below appears. 
 
You can also access this function from the Asset List by highlighting an asset and clicking the Move button 
on the toolbar, or just clicking the Move button on the toolbar. For more information on using the List 
screens, click here. 
 

 

2. The Move screen offers two modes of Asset selection - Filter and Custom Filter: 
 
Filter is the default selection mode, allowing you to select the Assets you want to Move by specifying any 
combination of values for the four filter criteria: Asset Tag, Location, Department and Purchase Order.   
 
Note:  Pinning can be used with Move transactions.  
 
Custom Filter may be selected instead of Filter. This makes use of the Simple Find or Advanced Find 
forms to select the Assets you want to move. 

3. The assets matching your criteria will appear in the grid. You can manually limit the list of Assets further by 
highlighting only those assets in the list you want to move. To multi-select, hold down the CTRL key while 
clicking on assets with your mouse. 
 
The Select All button can be used to select all the records found by your choice of filter criteria. De-Select All 
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can be used to clear any selections previously made.   
 
The Detail button will open the Edit Asset screen for the highlighted record, to view or modify the Asset 
record prior to moving it. If more than one record is selected, the Detail button will be disabled. 
 
The Notes button allows you to enter Notes on the record. 

4. After you have selected the assets you want to move, you need to select the To Location. Notice that the 
items listed in the To Location drop down list consist of both a Site and a Location at that Site. Select a 
recently used To Location from the drop down, select <More> to select a location from the Location List, or 
<New> to enter a new Location. 
 
In the example below, assets were filtered only by Location, then only the last two Assets listed at that 
Location were selected for the Move to the specified To Location.   
 

 

5. Click the Move button when you are ready to move the selected assets to the new location..   
 
Click Close when you are ready to exit the Move function. 
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Check Out Asset 

The Check Out Asset function, provides the ability to check-out assets to a customer or employee, specifying a due 
date and time by which the asset should be returned. Keep in mind that you can set the check out length to only 
consider weekdays and the due date to only fall on a weekday on the Options screen. 
  
You can also check out assets on a Windows Mobile/CE, Android (Pro and Ent only) and iOS (Pro and Ent only) 
devices. 

1. To access this function, from the Main screen click Asset Management > Check Out. 
 
You can also access this feature from the Asset List by highlighting the asset you want to check-out, then 
clicking the Check Out button on the Asset List toolbar. When accessed this way, the selected asset's 
information will be pre-populated on the screen. For more information on using the Asset List, click here. 
 
 

 

2. The Check Out function offers two modes of asset selection - Filter and Custom Filter: 
 
Filter is the default selection mode, allowing you to select the assets you want to check out by specifying any 
combination of values for the four filter criteria: Asset Tag, Description, Location, and Category.   
 
Note: Pinning can be used with Check Out transactions. Pinning allows you to "lock" the information entered 
into a field.  This is convenient if, for example, you are entering multiple new assets for a particular site and 
location.  You can enter the site and location once, then pin them.  The fields will retain the information you 
entered through each new entry until you unpin them.  In the example screen shown below, values are entered 
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in the Site, Location and Department Code fields.  These three fields were Pinned by clicking on their  
pushpins, causing them to look like  this.  Click the  pushpin again to unlock the field for entry of a different 
value. 
 
 
Custom Filter may be selected instead of Filter. This makes use of the Simple Find or Advanced Find 
screens to select the assets you want to Check Out. 

Note for MobileAsset Professional and Enterprise edition users: If you have installed the Professional or 
Enterprise edition of MobileAsset and are using asset linking, the system will check for the Transact as Whole 
flag. If the flag is turned on for this asset (or the parent of this asset), a message will appear notifying you. You 
can either leave the flag on to perform the transaction on the entire group of linked assets, or select to turn the 
flag off to perform the transaction only on this asset. 
 
 
What is Transact as Whole? When an asset is set to "Transact as whole" (on the New/Edit Asset screen > 
Linking tab) any functions (check in, check out, audit, move, etc.) will be performed as a whole for the group. 
This flag is driven from the top down, meaning the selection made for the parent asset will override the selection 
for a child asset. If you want to move only one asset that is a child of this asset, you will need to deselect this 
checkbox. Deselecting it on the Edit Asset > Asset Linking tab for the child asset will not override the 
selection made for this asset, and this group would still be moved as a whole. Similarly, if the Transact as 
whole flag was NOT selected on this tab, but it IS selected for the parent of this asset, the group would still be 
transacted as a whole because the selections made for the parent of this asset would take precedence.   

 
3. After applying your choice of filter criteria, you can manually limit the list of assets further by using CTRL and 

the left mouse button, clicking to highlight only those assets in the Assets available to check-out list that 
should be Checked Out, then click the > button to move them to the Assets pending check-out list. All the 
listed assets can be shifted to the Assets pending check out list via the >> button. 
 
The Select All button can be used to highlight all the records found by your choice of filter criteria. De-Select 
All can be used to clear any selections previously made.   
 
The Detail button will open the Edit Asset screen for a highlighted record, to view or modify the asset record 
prior to checking out the asset(s). If more than one record is selected, the Detail button will be disabled. 

4. When you are satisfied with the assets accumulated in the Assets pending check-out list, you can optionally 
apply Notes to the transaction, then specify either a Customer or an Employee to whom the asset will be 
checked out. 

5. Next, enter a Due Date (and time) for this asset. 
 
You have three options for selecting a Due Date.   

• Use each asset's checkout duration - highlight a pending asset in the Assets pending Check Out 
window. The selected asset's due date will appear in the window. The due date is based on the check 
out length set for the selected asset or asset type. Note that if an asset has the due date set to  '0' in 
the Edit Asset screen, the asset does not have a due date. If  the asset selected in the Pending 
Check Out window does not have a due date 'No Due Date' will appear in the Due Date field. 
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• None - No due date will be assigned. 
• Custom - You can set a specific due date for all assets in the list. Highlight the asset in the Assets 

pending Check Out window, then enter a date and time in the fields provided. 
 
Keep in mind if you are checking out a linked asset and the Transact as Whole flag is checked for the 
group, if you choose to use the default due date (rather than entering a new due date, MobileAsset will 
search all linked assets to find the maximum checkout duration. The maximum length is used to 
calculate the due dates for all the linked assets. This ensures that all the assets in the transaction have 
the same due date even if some of the linked assets have different checkout durations.  
  

6. You can optionally change the location of the asset being checked out using the Change Location To field. For 
instance, you would use this feature if you are checking the asset out to someone at a different location, such 
as another building or warehouse. To change the location, select a location from the Change Location To drop 
down list. 
  

7. Enter a number in the Print Receipt - Copies box to print Check Out receipts for this transaction. 

8. When the required fields have been satisfied, the Check Out button will be enabled. Click it to post the 
transaction or click the Close button to exit without checking out the asset. 
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2.10.3 Check In Asset 

The Check In Asset function is used to check in assets that are currently checked out to a Customer or Employee. 
  
  
Note for Mobile Device Users: Assets can also be checked in directly on a  Windows Mobile/CE, Android 
(Professional and Enterprise Editions) and iOS (Professional and Enterprise Editions) devices. 
  

1. To access the Check In feature, from the Main screen, select Asset Management > Check-In. The Check In 
screen shown below appears.   
 
You can also access this feature from the Asset List by highlighting the asset you want to check-in, then 
clicking the Check In button on the Asset List toolbar. When accessed this way, the selected asset's information 
will be pre-populated on the screen.  For more information on using the Asset List, click here. 
 

 

2. Select the asset or assets you want to check in.  Asset selection can be done by specifying an Asset Tag, a 
Customer or an Employee. If an Asset Tag is supplied, the Checked Out To window will display the Customer 
or Employee information recorded at the time of Check Out. 
 
Note: Pinning can be used with Check In transactions. What is Pinning?  Pinning allows you to "lock" the 
information entered into a field.  This is convenient if, for example, you are entering multiple new assets for a 
particular site and location.  You can enter the site and location once, then pin them.  The fields will retain the 
information you entered through each new entry until you unpin them.  In the example screen shown below, 
values are entered in the Site, Location and Department Code fields.  These three fields were Pinned by 
clicking on their  pushpins, causing them to look like  this.  Click the  pushpin again to unlock the field for 
entry of a different value. 
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3. After applying your choice of filter criteria, you can manually limit the list of Assets further by using CTRL and 
the left mouse button, clicking to highlight only those Assets in the Assets Checked Out list that should be 
Checked In, then click the > button to move them to the Assets ready to check-in list. All the listed Assets can 
be shifted to the Assets ready to check-in list via the >> button. 
 
The Select All button can be used to highlight all the records found by your choice of filter criteria. De-Select 
All can be used to clear any selections previously made.   
 
The Detail button will open the Edit Asset screen for a highlighted record, to view or modify the Asset record 
prior to doing the Check In. If more than one record is selected, the Detail button will be disabled. 
 
When you are satisfied with the Assets accumulated in the Assets ready to check-in list, you can optionally 
apply Notes to the transaction. 
 
When the Print Receipt - Copies box has a value greater than zero, one or more Check In receipts will be 
printed for this transaction. 

4. You can optionally add Notes to these assets by clicking the Notes button or enter a Check In location in the 
Location field. Select a new location for the asset will check the asset into the selected location, effectively 
moving it from its former location. 

5. When the required fields have been satisfied, the Check In button will be enabled. Click it to post the 
transaction or click the Close button to exit without doing a Check In. 

  
  

130 



 
  

Wasp MobileAsset User Manual 

2.11.4 Transferring Checked Out Assets 

The Transfer Check Out function allows you to transfer physical possession of a checked out item from one person to 
another. Transferring a checked out asset prevents you from having to check the asset back in, then check it out again 
to another person. If the asset won't be returning to your company's possession before going to another customer or 
employee, use this function to transfer it. 
 
Keep in mind that you can set the check out length to only consider weekdays and the due date to only fall on a 
weekday on the Options screen. 
  
  

1. From the Main screen, click Asset Management > Transfer Check Out. The Transfer Check Out screen 
appears. 
 

 
 
This screen is similar to the Check Out screen. 

2. The Transfer Check Out function offers two modes of asset selection - Filter and Custom Filter: 
 
Filter is the default selection mode, allowing you to select the assets you want to check out by specifying any 
combination of values for the four filter criteria: Asset Tag, Description, Location, and Category.   
 
Note: Pinning can be used with Transfer transactions. Pinning allows you to "lock" the information entered into 
a field.  This is convenient if, for example, you are entering multiple new assets for a particular site and location. 
 You can enter the site and location once, then pin them.  The fields will retain the information you entered 
through each new entry until you unpin them.  In the example screen shown below, values are entered in the 
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Site, Location and Department Code fields.  These three fields were Pinned by clicking on their  pushpins, 
causing them to look like  this.  Click the   pushpin again to unlock the field for entry of a different value. 
 
 
Custom Filter may be selected instead of Filter. This makes use of the Simple Find or Advanced Find forms 
to select the assets you want to check out. 

3. After applying your choice of filter criteria, you can manually limit the list of assets further by using CTRL and 
the left mouse button, clicking to highlight only those assets in the Assets available to check out list that 
should be checked out, then click the > button to move them to the Assets ready to transfer check out  list. 
All the listed assets can be shifted to the Assets ready to transfer check out list via the >> button. 
 
The Select All button can be used to highlight all the records found by your choice of filter criteria. De-Select 
All can be used to clear any selections previously made.   
 
The Detail button will open the Edit Asset screen for a highlighted record, to view or modify the asset record 
prior to doing the Check Out. If more than one record is selected, the Detail button will be disabled. 
 
When you are satisfied with the assets accumulated in the assets pending check out list, you can optionally 
apply Notes to the transaction, then specify either a Customer No. or an Employee No. and a Due Date (and 
time).   
 
When the Print Receipt - Copies box has a value greater than zero, one or more Check Out receipts will be 
printed for this transaction. 

4. When the required fields have been satisfied, the Transfer Check Out button will be enabled. Click this button 
to post the transaction or click the Close button to exit without transferring the asset.   
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2.11.5 Audit Assets 

The Audit function is used to determine the current location of your assets. With this function, you can verify that your 
assets are in the locations to which they are assigned. 
  
Location Audit 
Funding Audit (Professional and Enterprise Editions Only) 

 
  

Location Audit 

  
1. To access the Audit screen from the Main screen, select Asset Management > Audit. 

 

 

2. The  Filter section allows you to quickly select which assets you wish to audit. Select the desired audit Site and 
Location. 

3. Set an Audit Start Time. This feature allows you to stop and restart an audit without auditing the same inventory 
twice by telling MobileAsset to only include those assets that were not audited prior to the entered start date and 
time. For example, if you begin an audit on November 6, but had to stop at midnight and the audit was not 
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completed, you can enter 11/7/2014 at 12am to begin the new audit. This means that only items that have not 
been audited as of 12am on November 7 will be included in this audit. 

4. After the site and location are selected, you can further define your asset search by entering a Department, 
Category or specific Asset Tag. 
 
Note: Pinning can be used with Audit transactions. Pinning allows you to "lock" the information entered into a 
field.  This is convenient if, for example, you are entering multiple new assets for a particular site and location. 
 You can enter the site and location once, then pin them.  The fields will retain the information you entered 
through each new entry until you unpin them.  In the example screen shown below, values are entered in the Site, 
Location and Department Code fields.  These three fields were Pinned by clicking on their  pushpins, causing 
them to look like  this.  Click the  pushpin again to unlock the field for entry of a different value. 

5. After applying your choice of filter criteria, a list of assets matching your criteria appears in the Selected Assets 
list.   

The Select All button can be used to highlight all the records found by your choice of filter criteria. De-Select All 
can be used to clear any selections previously made.   
 
If you want to edit an asset in the Selected Assets list, highlight the listing, then click the Detail button. If more 
than one record is highlighted or no assets are selected, the Detail button will be disabled.   
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Note: Assets being audited to a location different than the one on record will display a special icon, as shown below: 
 
 

 
 
 
 
Note on Linked Assets (Linking is available in the Enterprise and Professional Editions only): Special rules apply 
when auditing linked assets. If the Transact as Whole flag has been selected for the parent of this asset (on the Edit 
Asset>Linking tab), then ALL assets linked to this asset will be audited. If this flag is not selected, the single asset will be 
audited. See the Create New Asset topic for more information. 

5. When you are satisfied with the assets in the Selected Assets list, you can optionally apply Notes to the 
transaction.   

6. You can print a receipt for each audited asset by entering the desired number of receipts in the Print Receipts - 
Copies field. Keep in mind that if you enter 3 in this field, for example, 3 audit receipts will print for each asset 
audited. 
 
You can also print the Not Audited Assets Report by entering the number of copies you would like in the Print 
Not Audited Assets Report - Copies field. 

7. When you are ready to audit the assets, select the check box next to the assets you want to audit, or click Select 
All, and click the Audit button. The Audit button will not be enabled until you select at least one asset. After you 
select the Audit button, the audited assets will disappear from the Selected Assets list. 
 
When the required fields have been completed, the Audit button will be enabled. Click it to post the transaction or 
click the Close button to exit without doing an Audit. 

  
• If at the location being audited, an asset is found that wasn't recorded in the MobileAsset database, a 

message will appear giving you the option to relocate the asset to the location you are currently auditing, 
then auditing it or leaving the asset in its current location and auditing it. Keep in mind that whether you 
move the asset to the current location or leave it where it is, the asset will be audited. An example of this 
message is shown below: 
 

 

• If an asset is missing at the location being audited and you have discontinued all efforts to find it, you can 
perform a Dispose transaction. Keep in mind that once disposed, assets cannot be "un-disposed", 
meaning there is no way to reactivate the asset. You would need to create a new asset if the asset is 
found. There may be situations where you will want to move an asset to a temporary location, rather than 
disposing of it, if the asset is misplaced. For example, if you regularly have items that are not found during 
an audit, but are found later, you may not want to dispose of them. Moving them to a temporary location 
you set up in MobileAsset enables you to move them back to their regular location when they are found. 
 Disposing of these assets requires you to create a new asset later if they are found. 
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Funding Audit 

The Funding Audit Function is available in the Enterprise and Professional Editions. The Funding Audit function 
allows you to audit those assets associated with a funding source. 
  

1. To access the Audit screen from the Main screen, select Asset Management > Audit. 

2. From the Audit screen, select the Funding Audit tab. 
 

 

3. The  Filter section allows you to quickly select which assets you wish to audit. Select the desired audit Funding 
Name and/or Site and Location. 

4. Select an Audit Start Time.  You can select from recent audits from the drop down list or set a new time. This 
feature allows you to stop and restart an audit without auditing the same inventory twice by telling MobileAsset 
to only include those assets that were not audited prior to the entered start date and time. For example, if you 
begin an audit on November 6, but had to stop at midnight and the audit was not completed, you can enter 
11/7/2014 at 12am to begin the new audit. This means that only items that have not been audited as of 12am 
on November 7 will be included in this audit. 

5. After applying your choice of filter criteria, a list of assets matching your criteria appears in the Selected Assets 
list.   
 
The Select All button can be used to highlight all the records found by your choice of filter criteria. De-Select 
All can be used to clear any selections previously made.   
 
If you want to edit an asset in the Selected Assets list, highlight the listing, then click the Detail button. If more 
than one record is highlighted or no assets are selected, the Detail button will be disabled.   
 
Complete steps 5 - 7 from the Location Audit section above to complete the audit. 
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2.11.6 Dispose Asset 

The Dispose function is used to delete one or more assets from your database. You will use this function when you no 
longer have an asset. 
  
Keep in mind that once disposed, assets cannot be "un-disposed", meaning there is no way to reactivate the asset. You 
would need to create a new asset if the asset is found. There may be situations where you will want to move an asset to 
a temporary location, rather than disposing of it, if the asset is misplaced. For example, if you regularly have items that 
are not found during an audit, but are found later, you may not want to dispose of them. Moving them to a temporary 
location you set up in MobileAsset enables you to move them back to their regular location when they are found. 
Disposing of these assets requires you to create a new asset later if they are found. 
  

1. To access the Dispose screen, from the Main screen, click Asset Management > Dispose. The Dispose 
screen shown below appears. 
 
You can also access this screen from the Asset List by highlighting the asset you want to Dispose, then click 
the Dispose button on the toolbar. For more information on using the list screens, click here. 
 

 

2. You can search for specific assets using the Filter or the Custom Filter at the top of the screen. 
 
Filter: This is the default selection mode and allows you to select assets by specifying any combination of 
values for the four filter criteria: Asset Tag, Location, Department and Purchase Order.   
 
Note: Pinning can be used with Dispose transactions. Pinning allows you to "lock" the information entered into 
a field.  This is convenient if, for example, you are entering multiple new assets for a particular site and location. 
 You can enter the site and location once, then pin them.  The fields will retain the information you entered 
through each new entry until you unpin them.  In the example screen shown below, values are entered in the 
Site, Location and Department Code fields.  These three fields were Pinned by clicking on their  pushpins, 
causing them to look like  this.  Click the   pushpin again to unlock the field for entry of a different value. 
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Custom Filter: This feature uses the Simple Find or Advanced Find screens to select the assets you want to 
dispose. 

3. The assets matching your criteria will appear in the grid. You can manually limit the list of Assets further by 
highlighting only those assets in the list you want to dispose. To multi-select, hold down the CTRL key while 
clicking on assets with your mouse.    
 
The Select All button can be used to highlight all the records found by your choice of filter criteria. De-Select 
All can be used to clear any selections previously made.   
 
The Detail button will open the Edit Asset screen for a highlighted record, to view or modify the Asset record 
prior to doing the Dispose. If more than one record is selected, the Detail button will be disabled. 

4. A Disposal Reason must be selected from the drop list. Reasons are: Sale, Lost, Damaged, Trade In, Stolen 
or Other. 

5. You can optionally apply Notes to the transaction. 

6. When you are finished entering information in the required fields, the Dispose button will be enabled. Click it to 
dispose of the selected assets or click the Close button to exit without disposing of any assets. 
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2.11.7 Maintenance Entry 

The Maintenance Entry screen is used to record maintenance activity for one or more Assets. You can schedule 
maintenance on this screen and record when maintenance was completed and the condition of the asset. 
  

  
1. To access this screen, from the Main screen, select Asset Management > Maintenance Entry.   

 
OR 
 
From the Main screen, select Lists > Asset List. Highlight an Asset in the Asset List, then click the 
Maintenance icon on the toolbar. The Maintenance Entry screen appears. Note that if you access the 
Maintenance Entry screen from the Asset List, the screen will appear populated with the selected Asset's 
information and any scheduled maintenance. 
 

 
  

2. The Maintenance Entry screen offers two modes of Asset selection - Filter and Custom Filter. 
 
Filter is the default selection mode, allowing you to select the Assets for which you want to record a Maintenance 
Entry by specifying any combination of values for the four filter criteria: Asset Tag, Location, Department and 
Date Due.   
 
Date Due will select those Assets with a scheduled Next Date that occurs on or before the Date Due specified. 
The Next Date is set on the Edit Asset > Maintenance tab. 
 
Note: Pinning can be used with Maintenance transactions. Pinning allows you to "lock" the information entered 
into a field.  This is convenient if, for example, you are entering multiple new assets for a particular site and 
location.  You can enter the site and location once, then pin them.  The fields will retain the information you 
entered through each new entry until you unpin them.  In the example screen shown below, values are entered in 
the Site, Location and Department Code fields.  These three fields were Pinned by clicking on their  pushpins, 
causing them to look like  this.  Click the  pushpin again to unlock the field for entry of a different value. 
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Custom Filter may be selected instead of Filter. This makes use of the Simple Find or Advanced Find forms to 
select the Assets for which you want to record a Maintenance Entry. 

3. The assets matching your criteria will appear in the grid. You can manually limit the list of Assets further by 
highlighting only those assets in the list for which you want to create a maintenance entry. To multi-select, hold 
down the CTRL key while clicking on assets with your mouse.    
 
The Select All button can be used to highlight all the records found by your choice of filter criteria. De-Select All 
can be used to clear any selections previously made.   
 
The Detail button will open Edit Asset screen for a highlighted record. You can view or modify the Asset record 
prior to recording the Maintenance Entry. If more than one record is selected, the Detail button will be disabled. 

4. If the maintenance is completed, select the Complete checkbox. You can also specify a Completion Date, the 
Asset's current Condition and the Cost of the maintenance. The Complete checkbox does not need to be 
selected to enter a Completion Date, Condition or Cost. 

5. Enter a Description of Maintenance for this Maintenance Entry. The Description of Maintenance field allows 
you to enter a brief overview of the maintenance performed. You can type a one-time entry into the Description 
field, or you can set up recurring descriptions from which you an select. 

a. To setup descriptions, click the  ... button above the Description of Maintenance field. The 
Maintenance Selection screen appears: 
 

 

b. Any descriptions you already have setup will appear in the Maintenance Short Name Description 
field. To enter a new description, click the New button. A new entry will appear in the Maintenance Short 
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Name Description field: 
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c. Enter a name for this maintenance. 
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d. Click in the Details section, then type in the description for this maintenance. 
 

 

e. Click Apply to save your changes.   

f. Select which maintenance description you want to use by checking the desired listing, the click the OK 
button. Your selection will be added to the Description of Maintenance field. 
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6. When all required fields have been completed, the Save button will be enabled. Click Save to save your changes 
or click the Close button to exit without recording a Maintenance Entry. 

Entering Maintenance Prior to Due Date: If maintenance is entered for an asset before that maintenance schedule is 
due, the following screen appears: 
 

 

Select Yes if you want to advance the schedule. This means the maintenance will be marked completed for this period 
and the due date will be moved to the next due date on the schedule. 

Select No to keep the current due date. The maintenance will be marked completed but the due date will stay the same. 

Example: Monthly maintenance is due on the 1st of every month. The current due date is September 1st. If the user 
enters maintenance for August 20th, he/she will see the screen above. If Yes is selected, the due date will advance to 
October 1st. If No is selected, the due date will remain September 1st. 
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2.11.8 Calculating Depreciation 

The Calculate Depreciation function is used to calculate depreciation up to the specified Through Date for all Assets 
with Asset Types having Depreciation Methods other than None. 

  
1. To access this function, from the Main screen, click Asset Management > Calculate Depreciation. The 

Calculate Depreciation screen appears. 
 

 
 
The Last Used Date indicates the last date depreciation was calculated. 

2. Specify the Through Date through which you want depreciation to be calculated or just click OK to accept the 
default date. The default Through Date can be changed on the Options screen.  
 
Reminder: If you are using the Standard version of MobileAsset, only Straight-Line depreciation will be 
calculated. 

Depreciation Definitions and Examples: 

Click on the depreciation type below to view a definition and example. Remember that these depreciation methods 
are selected on the Add/Edit Depreciation Class screen. Click here for more information on Adding/Editing 
Depreciation Classes. 

Straight-Line 
Definition: The simplest and most commonly used depreciation method, straight line depreciation is calculated by 
taking the purchase or acquisition price of an asset subtracted by the salvage value divided by the total productive 
years (Life) the asset can be reasonably expected to benefit the company. 

Example: 
purchase price of asset – approximate salvage value 
-------------------------- (divided by) -------------------------- 
estimated useful life of asset 
You buy a new computer for your business costing approximately $5,000. You expect a salvage value of $200 
selling parts when you dispose of it. Accounting rules allow a maximum useful life of five years for computers; in 
the past, your business has upgraded its hardware every three years, so you think this is a more realistic estimate 
of useful life, since you are apt to dispose of the computer at that time.  Using that information, you would plug it 
into the formula: 
$5,000 purchase price - $200 approximate salvage value 
-------------------------- (divided by) -------------------------- 
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3 years estimated useful life 
The answer, $1,600, is the depreciation charges your business would take annually if you were using the straight 
line method. 
Double Declining Balance 
Definition: The double declining balance depreciation method is similar to the straight-line method. To use it, the 
system first calculates depreciation as if it were the straight line method. Then it determines the total percentage of 
the asset that is depreciated the first year and doubles it. Each subsequent year, that same percentage is 
multiplied by the remaining balance to be depreciated. At some point, the value will be lower than the straight-line 
charge, at which point, the double declining method will be scrapped and straight line used for the remainder of the 
asset’s life. 

Example: 
In our straight-line example, we calculated that a $5,000 computer with a $200 salvage value and an estimated 
useful life of three years would be depreciated by $1,600 annually. The first year, we have to compare this to the 
total amount to be depreciated, in this case, $4,800 [$5,000 base - $200 salvage value = $4,800]. Dividing $1,600 
by $4,800, we discover the straight-line depreciation charge [$1,600] is 33.33% of the total depreciation amount 
[$4,800]. Using this information, we double the 33.33% figure to 66.67%. 
In the first year, we would take $4,800 multiplied by .6667 to get a total depreciation charge of approximately 
$3,200. In the second year, we would take the same percentage [66.67%] and multiply it by the remaining amount 
to be depreciated. Continuing with the example, we find that $1,600 is the remaining amount to be depreciated at 
the start of the second year [$4,800 - $3,200 = $1,600]. Multiply 1,600 by .6667 to get $1,066. This is the 
depreciation charge for the second year – or not! Remember that once the depreciation charges dip below the 
amount that would be charged using the straight-line method, the double declining balance is scrapped and straight 
line immediately utilized. The straight line method called for charges of $1,600 per year. Obviously, the $1,066 
charge is smaller than the $1,600 that would have occurred under straight line. Thus, the deprecation charge for 
the second year would be $1,600. 
The equation below illustrates this method: 
depreciable base * (2 * 100% / useful life in years) 
150% Declining Balance 
Definition: This method uses 150% of the straight-line percentage for the first year. The same percentage is then 
applied to the remaining balance, each succeeding year. 

  
Declining Balance Custom 
Definition: This method allows you to enter a custom declining balance percentage.  Declining Balance is a 
common depreciation-calculation system that involves applying the depreciation rate against the non-depreciated 
balance. Instead of spreading the cost of the asset evenly over its life, this system expenses the asset at a 
constant rate, which results in declining depreciation charges each successive period. 

 Example:   
 If an asset that costs $1,000 is depreciated at 25% each year, the deduction is $250.00 in the first year and 
$187.50 in the second year, and so forth. 

Sum of the Year's Digits 

Definition: To calculate depreciation charges using the sum of the year’s digits method, take the expected life of 
an asset (in years) count back to one and add the figures together. 

Example: 
10 years useful life = 10 + 9 + 8 + 7 + 6 + 5 + 4 + 3 + 2 + 1 Sum of the years = 55 
In the first year, the asset would be depreciated 10/55 in value [the fraction 10/55 is equal to 18.18%] the first year, 
9/55 [16.36%] the second year, 8/55 [14.54%] the third year, and so on. Going back to our example from the 
straight-line method: a $5,000 computer with a $200 salvage value and 3 years useful life would be calculated as 
follows: 
3 years useful life = 3 + 2 + 1 Sum of the years = 6 
Taking $5,000 - $200 we have a depreciable base of $4,800. In the first year, the computer would be depreciated 
by 3/6ths [50%], the second year, by 2/6 [33.33%] and the third and final year by the remaining 1/6 [16.67%]. This 
would have translated into depreciation charges of $2,400 the first year, $1,599.84 the second year, and $800.16 
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the third year. The straight-line example would have simply charged $1,600 each year, distributed evenly over the 
three years of useful life. 

3. After depreciation for all applicable assets has been completed, the screen will appear as follows: 
 

 
 
Click the OK button to view the Asset Depreciation by Department Report or Cancel to close the screen. 

• This software does not track depreciation over multiple periods. For example, after calculating depreciation for an 
asset using the variables in the examples provided above, if you were to later change the Purchase Cost or 
Salvage Value or any other relevant variable, the next time you calculate depreciation the system would not take 
into account any previous calculations. 

• Any changes made to an existing Depreciation Class will impact depreciation calculations for every Asset defined 
with that Depreciation Class (via the Asset Type). 
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2.11.9 Mass Update 

MobileAsset allows you to select multiple assets from the Asset List and update a number of fields. For example, if you 
want to update warranty information for all assets under a certain Asset Type, you can select all of those assets on the 
Asset List and make the change at one time. 
  
Using Mass Update: 
  

1. From the Main screen, select List Forms > Asset List. 
 
or 
 
From the Main screen, select Asset Management > List Assets. 

2. On the Asset List screen, select the assets you want to update. You can use the filter features to drill down to 
the assets you want. In the example below, we have filtered for Asset Type = Laptop IBM. 
 
  

3. Now select all assets you want to change by holding down the Ctrl key and clicking on each one you want. Or 
you can select assets by holding down the SHIFT key and clicking on two assets. All assets in between the two 
you clicked on will be selected. 
 
 
  

4. When you have selected the assets you want to change, click the Mass Update button on the toolbar: 
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The Mass Update screen appears: 
 

 
 

5. The top portion of the Mass Update screen displays the assets you have selected. If needed, scroll through the 
columns in this window using the bar on the right. As with other lists in MobileAsset, you can sort the list by 
clicking on the column headers. 

6. Select the checkboxes in front of each field you want to update, then enter the information you want to change. 
Any fields you have selected (a checkmark will appear in the box as shown in the example below) will be 
updated. Unchecked fields will not be updated. Remember that once you click Save, any information you enter 
here will be applied to all assets that appear in the window. 
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You can manually type information into the fields or use the drop down menus. Most drop down menus will 
provide the options of <Blank> and <More>.  <Blank> means any information previously contained in the field 
will be removed.  <More> accesses the associated List screen allowing you to select from all Manufacturers, 
Vendors, etc. 
 
Any fields that appear in bold are required fields. You cannot select Blank for required fields. Which fields are 
required will vary depending on your Custom Field Name settings. 
 
Keep in mind that the Depreciation checkbox cannot be selected unless all assets in the Mass Update window 
are associated with an Asset Type that can be depreciated. Depreciation is activated at the Asset Type level 
on the New Asset Type or Edit Asset Type screen. 
 
If the Edit Inherited Asset Type Data option is disabled on the Options screen, you will not be able to edit 
data under the Asset Type. 
 
 
Tap on the Custom Fields or Dynamic Custom Fields tabs to make updates to the values selected for any 
custom fields. Dynamic Custom Fields will only appear if they are associated with every asset being updated. 
For example, if you have selected 3 assets with the Asset Type - Printer, and one asset with the Asset Type - 
Monitor, and a DCF has been created for Printer, but not for Monitor, the Dynamic Custom Fields tab will be 
blank. 
 

7. After you have entered information in the desired fields, click the Save button. Remember that once you click 
Save, any information you enter here will be applied to all assets that appear in the window. 
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2.11.10 View Linking 

View Links - This option appears on the Professional and Enterprise versions only. If you are using asset linking, 
highlight a listing in the Asset List, then click the View Links button to view the parent asset and any children. Below is 
an example of the View Linked Assets screen. 
 
 

 
  
  
There is a toolbar at the top of this screen allowing you to perform actions on the assets on the screen. These functions 
are listed below: 

• New 
• Edit 
• Dispose 
• Duplicate 
• Check In 
• Check Out 
• Move 
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2.12 Administration 

2.12.1 Company Information 

The Company Information screen allows you to enter or update information about your business. The value entered in 
the Company Name field will appear at the top of the Main screen and also be used as the header for all reports and 
pre-defined labels. This screen should be filled out first when you initially setup the software. 
  

1. To access the Company Information screen, from the Main menu, click Administration > Company 
Information. The Company Information screen shown below will appear: 
 

 

2. Select an Address Type from the drop down list, then provide any of the associated information you have: 
Address 1, Address 2, Mail Stop, City, State, Zip Code and Country. Address information can be entered for 
each Address Type you select. 
 
The Phone, Fax, Email and Website fields are available if you would like to record this information. 

3. Click OK to save your data or Cancel to close the screen without saving. 
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2.12.2 Backing Up Your Database 

  
Standard Edition:  

Backing up your database is an important maintenance step that should be performed on a regular basis. Having a 
current backup helps to minimize data loss in the case of a system shut down or power failure. If you do experience a 
catastrophic system failure of some kind, having a current backup ensures you can quickly restore the most recent 
database. For information on restoring your database, please refer to the Restoring the Database topic. 
  
  

1. From the Main screen, click the Administration icon.  

2. On the Administration Menu, click Backup. The Backup Database screen appears. 
 
 

 

3. Enter a name for this backup in the Backup File field, or accept the default name. It is a good idea to specify a 
name that will help you select the right backup file later if you need to restore the database. Adding the date in 
the file name is a good way to know which file is the latest. 

4. Click OK to backup the database. 
 
By default, the backup file is written to: 
 
C:\Program Files (x86)\Microsoft SQL Server\MSSQL10_50.WASPDBEXPRESS\MSSQL\Backup 

  
  
Professional Edition:  
  
The Backup procedure is performed on the Database Manager.  This separate application can be accessed from Start 
> All Programs > Wasp > MobileAsset > Database Manager.  If you do not have the Database Manager installed you 
will need to install it using the MobileAsset Installation DVD.  For detailed instructions on backing up databases using 
the Database Manager, please refer to the Database Manager online help. 
  
When the Backup Database button in MobileAsset is selected the following screen appears: 
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Enterprise Edition:  
  
The Backup feature is not available in the Enterprise version. You must use SQL to perform backups.  
  
When the Backup Database button in MobileAsset is selected the following screen appears: 
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2.12.3 Restoring the Database 

  
Standard Edition: 
  
You can quickly restore a previously backed-up database using the Restore function. This is useful if something 
happens to corrupt your database. You can easily restore your last backed up database.  This is why it is important to 
regularly backup your database. 
  
Keep in mind that this operation will erase all the data currently in your database and replace it with the data in the 
backup including all Assets, Customers and Users. If there is any chance you will want to recover transactions that have 
been entered since the Backup was done, you might want to do a fresh Backup to a different file name right before 
restoring an older backup file, if possible. 
  
  

1. From the Main Window, click the Administration icon.  

2. On the Administration menu, click Restore. The Restore Database screen appears. 
 
 

 

3. Enter thename of the backup in the Restore From File field. By default the most recently created backup will 
appear. 
 
Backup files are located in: 
 
C:\Program Files (x86)\Microsoft SQL Server\MSSQL10_50.WASPDBEXPRESS\MSSQL\Backup 

4. Click OK to perform the database restore. 
  
  
Professional Edition:  
  
The Restore procedure is performed on the Database Manager. This separate application can be accessed from Start 
> All Programs > Wasp > MobileAsset > Database Manager. If you do not have the Database Manager installed you 
will need to install it using the MobileAsset Installation CD.  For detailed instructions on backing up databases using the 
Database Manager, please refer to the Database Manager online help. 
  
  
When the Restore Database button on MobileAsset is selected the following screen appears: 
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Enterprise Edition:  
  
The Restore feature is not available in the Enterprise edition. You must use SQL to restore backups.  
  
When the Restore Database button on MobileAsset is selected the following screen appears: 
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2.12.4 Security 

Managing Groups 

User security in MobileAsset is set up by Group. A Group is a collection of security settings that one or more users 
share. You will need to create your Groups first, then add users and assign them to Groups. Before setting up your 
groups, take some time to think about the types of employees you have, who will need access to the software and what 
features/functions they will need to use in the software. You will want to create a Group for each different type of user 
you may have.  You may need a Group for Managers, who have access to all Sites, Reports, Auditing, etc.  Another 
group might be Supervisors who only need access to Reports and basic functions such as check in/out, but don't need 
access to Auditing. A third Group may be comprised of warehouse workers who need access to the mobile devices, but 
don't need to be able to log on to the PC. 
  
For example, your company may have 5 supervisors who all need access to the same functions in the software. Instead 
of setting up each user and assigning these functions individually, you will enter the basic user information, then assign 
that user to a Group. The security access is then automatically assigned to the user based on the Group settings.   
  
If you are upgrading from a previous version of MobileAsset, existing employees are automatically divided into groups 
based on their security settings. The groups are named a generic name similar to Group 1, Group 2, Group 3, etc. You 
can consolidate and/or rename these groups as needed. 
  
The structure of Groups to users is shown in the diagram below: 
 

 
  
Keep in mind that changes you make to a Group, such as assigning new security privileges, will affect all users 
assigned to that Group. 
  
The topics covered in this section are: 
  
Group Security Roles Screen Overview 
Adding a Group 
Duplicating a Group 
Deleting a Group 
Viewing the User List 
  
Enterprise Edition Only:  Enterprise users have the option to utilize Active Directory Integration. Please refer to the 
topic Active Directory Integration for more information. 

 

Group Security Roles Screen Overview 

  
1. From the Main screen, click Administration > Security > Group Manager.   
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The Group Manager screen appears: 
 
 

 
 
This screen lists any Groups that you have previously created, plus the default Admin group. Note that Admin 
has access to all features/functions and to all Sites.   
 
You can view the Security Privileges and Site Privileges of a Group by selecting that Group in the list.   
 
From this screen you can Add a Group, Duplicate a Group, Delete a Group or View the User List. 

 

Adding a Group 

  
1. Click the Add Group button on the toolbar. The Group Manager screen appears with a new entry in the Group 

List and the privileges fields appear unchecked as shown below: 
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2. Enter a Group Name and a Description for this group.   

3. Now you can select the features to which the users assigned to this Group will have access. Select the 
checkbox next to the features you want to add to this Group. You can select individual features or choose the 
Select All button to select all features in the list. Click Select None to prevent this Group from having access to 
any features in MobileAsset. 
  

4. Next you can select the Sites to which this Group will have access. You have two options in this section. You 
can select one or more Sites using the checkboxes. This gives the Group permission to access those Sites. 
You can select individual Sites or choose the Select All button to select all Sites in the list.  Click Select None 
to prevent this Group from having access to any Sites. 
 
OR 
 
You can select the User can access all current and future sites checkbox. This disables the Sites. Selecting 
this option means users in this Group will have access to all current Sites and any future Sites you may add. 
  

5. When you have finished making your selections, click the Save button. 
 

Duplicating a Group 

  
If you want to use most or all of a Group's settings for a new Group, you can create a copy, or duplicate, of the Group, 
then add a new name and description. To do this: 
  

1. On the Group Security Roles screen, select the Group you want to duplicate, then click the Duplicate button 
on the toolbar.   
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The screen appears populated with the selected Group's settings, but with the Group Name and Description 
fields blank. 
 

 

2. Enter a new Group Name and Description, then select to which sites this user will have access. You can also 
modify any feature or Site privileges as needed. 

3. Click the Save button when you are done making changes. The new Group will be added to the list. 
 
  

 

Deleting a Group 

Note: Groups with users assigned to them cannot be deleted. 
  

1. On the Group Security Roles screen, select the Group you want to delete, then click the Delete button on the 
toolbar. The confirmation screen shown below appears: 

160 



 
  

Wasp MobileAsset User Manual 

 

 
2. Click OK on the confirmation screen. The Group will disappear from the list. 

 

Viewing the User List 

  
1. On the Group Security Roles screen, click the User List button. The User List will appear.   
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Adding, Editing or Duplicating Users 

The Add New User screen allows users assigned to the Admin Group to create new users who will have access to the 
system. The Edit User screen allows you to edit users you have already added to the database. These two screens are 
identical and function in the same way, so they are both discussed in this topic. 
  
Note for Enterprise Users: If you have set up MobileAsset to work with multiple companies (i.e. you have created 
multiple databases) and you have users that you want to have access to two or more of the additional databases, you 
will need to add them on each database. When the user logs in, the companies that appear on the Select Company 
screen depends on which databases the user has been added to. If the user is only added on one database, the Select 
Company screen will not appear. 
  

1. To Add/Edit Users: 
 
 
To add a user: 

a. From the Main screen, select Administration > Security > User Manager. The User List appears.   

b. On the User List, select the New button from the toolbar. 

c. The Add New User screen appears. 
 

To edit an existing user: 

1.  
a. From the Main screen, select Administration > Security > User Manager. The User List  appears. 

This screen lists all users you have already setup in your system.   

b. Highlight the user you want to edit in the User List, then click the Edit button on the toolbar. 

To duplicate a user profile: 
2.   

a. From the Main screen, select Administration > Security > User Manager. The User List appears. 
This screen lists all users you have already setup in your system.  

b. Highlight the user you want to copy in the User List, then click the Duplicate button on the toolbar. The 
Add New User screen will appear with the Group privileges already populated. Keep in mind that you 
cannot change the Privileges settings for the group. 
  

3.  
The example shown below is the Add New User screen. This is identical to the Edit User screen; however, the 
Edit User screen will be populated with the information of the user you selected in the User List. 
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a. From the Main screen, select Administration > Security > User Manager. The User 
List  appears. This screen lists all users you have already setup in your system.   

b. Highlight the user you want to edit in the User List, then click the Edit button on the 
toolbar. 

2. The fields in bold on this screen are required. 

• Enter information in the First Name, Last Name, and User Name fields. These fields are used for 
Logging On.   

• An initial Password and a Status. The user should change their password using the Change 
Password screen upon logging in. The Password field is masked for security reasons. 
 
The Status is usually set to Active, meaning the user will be able to access and use they system 
based on his/her security settings. Inactive users will show the text "Inactive" next to their names in the 
User List and will not be able to access the system.   
 
Note on Creating Passwords: 
 
A Password can contain any of the following characters: 

• A - Z (uppercase & lowercase), 
• 0 - 9 
• or any of these special characters:  ` ~ ! @ # $ % ^ & * ( ) _ + - = [ ] { } | < > ? : ; . , 

  
• You must assign this user to a Group.  Groups are setup and managed from Administration > 

Security > Manage Groups. Each user must be assigned to a group. 
 
Note that after you chose a Group, the features and functions in MobileAsset to which the user will 
have access will display in the Security Settings > Privileges section. The Privileges settings cannot 
be changed on a per user basis. If you want to customize the settings for a user (by allowing one 
supervisor access to reports, while other supervisors do not have this access, for example), then you 
will need to create a new Group with the desired privileges and assign it to that user. Note that this 
section is divided into two tabs.  The Privileges tab contains general functions related to the PC and 
mobile device. The Report Privileges tab contains individual reports and report types. 
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Below is an example of the Security Settings > Privileges section: 
 

 
 
Below is an example of the Security Settings > Report Privileges section: 
 

 
 
In addition, the sites to which this Group has access will appear in the List of sites that <Group> can 
access section. This is set at the Group level and can only be changed from the Edit Group screen. 
An example of the Site section with the User can access all current and future sites checkbox 
highlighted is displayed below: 
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• You may optionally enter information in the Title, Department, Manager, and Email fields. 

3. Click OK when you have finished entering information on this screen. 
   
Note: If you intend to define only one new user other than the default Admin account, we recommend you set that user 
up as an Admin as well. 
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User Manager Example 

  
The User Manager, accessed from the Main screen by selecting Administration > Security > Manage Users.  The 
User List allows you to view users you have already setup and to create new or modify existing users. A user is anyone 
who is set up to have access to the software. For detailed information on working with list screens, please see Working 
with Lists. For detailed information on adding, editing users or duplicating users, please see Adding or Editing Users. 
Below is an example of the User Manager.   
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Change Password 

  
The Change Password feature allows you to change your current password. 

1. To access this feature from the Main screen, select Administration > Security > Change Password.   
 

 

2. Enter your old password followed by your new password. Enter your new password again, then click the OK 
button to save the changes. 

Password Rules: 
 Passwords are case sensitive. 
 A Password may contain any of the following characters: 

A - Z (uppercase & lowercase), 
0 - 9 
or any of these special characters:  ` ~ ! @ # $ % ^ & * ( ) _ + - = [ ] { } | < > ? : ; . , 
  
Note: You can also change your password by going to File > Change Password. 
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Login as Different User 

  
The Login as Different User function allows the current user to log out and log back in as a different user. 
  

1. To access this function, from the Main screen click Administration > Security > Login as Different User. The 
login screen appears. 

2. Enter a different User Name and Password to login as a different user. 

Note: You can also login as a different user by going to File > Login as Different User. 
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Active Directory Integration 

Enterprise Edition Only  
  

  
The Windows NT Authentication feature is turned off by default on the Options screen. To turn it on you must 
navigate to Administration > Options > Active Directory and select  the Yes checkbox.  
  
If you are using Windows NT Authentication, you can setup a Group in MobileAsset that matches your group name in 
the Microsoft Active Directory. When users in this Group access MobileAsset for the first time their user account is 
automatically created and added to the Manage Users screen in MobileAsset. If you have turned on the Create 
Employee option on the Options screen (it is ON by default), an Employee record will be create at the same time as 
the User Account. 
Example: You have a group in your Active Directory named My Users and you want everyone in My Users to have 
access to MobileAsset. Create a Group with the name My Users in MobileAsset using the MobileAsset PC application. 
Now when each member of the Group My Users accesses MobileAsset on the PC, MobileAsset will recognize the 
Active Directory Group name as matching the MobileAsset Group name and automatically create a User account for 
that user. After the group is setup, when the user accesses MobileAsset on the PC, MobileAsset will recognize the 
computer is on the network and automatically log the user in using their network login and password.  
 
If you are using Windows NT Authentication and you see the regular MobileAsset login screen when accessing 
MobileAsset, you were not authenticated using your Windows credentials for some reason. Check with your network 
administrator to resolve this issue. 
  
You can then view those User accounts in MobileAsset (Security > Manage Users). Keep in mind that if you change 
the password on a user's MobileAsset user account, she will receive the regular login screen and must enter the new 
password, rather than her network password. 
  
Using Windows NT Authentication with Multiple Companies: If you have multiple companies setup in MobileAsset 
(see Working with Multiple Companies) and you are using Windows NT Authentication, the process works much the 
same as above, except the user will be taken to the Select Company screen to choose the company they want to work 
with before entering MobileAsset.   
  
You can give a group access to all companies or you can give select members of the group access to a company. 
Remember that all members assigned to the Group in the Active Directory will have the rights assigned them in the 
matching MobileAsset Group. If there are some people listed in the Active Directory group that you do not want to have 
the same rights, you will need to edit the Group in the Active Directory or create groups and users manually in 
MobileAsset. Creating the users manually means you will lose the ease of auto-created user accounts.   
  
Note: Keep in mind that Active Directory Integration with MobileAsset is a one-time data exchange. If you update a user 
or a group name in the Active Directory or in MobileAsset, that change will not be transmitted to the other database. If 
an edit is made, you will need to manually make the same edit in the other database or Windows NT Authentication will 
not be able to authenticate the user. 
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2.12.5 Import / Export Wizard 

Import Strategy 

Presented in this topic are recommendations for using Import Wizard to import data from a different application into 
tables(Information you enter into each field in MobileAsset is stored in a database "table" behind the scenes.  You can 
extract this information using the Export Wizard.) in the software database: 
  
• The software database contains 10 tables:  Site, Location, Asset Type, Asset, Depreciation Class, Employee, 

Customer, Vendor, Manufacturer and Department. The Import Wizard can only transfer data into one table at a 
time, so multiple imports must be performed to populate the database. 

• You may not have external data files from which to import all the information you wish to track in the software, but 
importing data which you do have can save a lot of time compared to manually entering the data for each record.  
  

• The software requires that, at a minimum, information must be imported (or manually entered) for Site, Location, 
Asset Type and Asset. These four tables are required for all Asset Management functions (check in, check out, 
etc).   

• Data should be imported (or manually entered) in this sequence: Vendor, Manufacturer, Depreciation Class, Asset 
Type, Department, Site, Location, Asset, Employee, Customer. 

• If you want to Calculate Depreciation for any or all Asset Types, import Depreciation Class data before importing 
Asset Type records.   

• If you want to perform Check-Outs and Check-Ins to employees or customers, import Employee and/or Customer 
data.   

• Data for the three remaining tables is optional: Vendor or Manufacturer (this should be imported prior to importing 
Asset Type records), Department (this should be imported prior to importing Asset and/or Employee records). 

• Manufacturer, Model, Vendor Number, Checkout Length and Lead Time are not available by default for import on 
the Asset import sample. If you want to import this data with the Asset, you will need to manually add these 
columns to the Asset import sample file. 

• Samples of import files are located at Program Files (x86)\Wasp Technologies\MobileAsset\Import Samples.   

The following table lists the pre-requisites for importing data to each table and the functions supported by the data in 
each table: 

Import To 
Table 

Information that must 
be entered prior to 

importing 

Data is 
Required  to 

Perform 
These 

Functions 

Data is 
Optional to 

Perform 
These 

Functions 
Vendor None 

  
  Create or Edit 

Asset Type 
Manufacturer None 

  
  Create or Edit 

Asset Type 
Depreciation 

Class 
None 

  
 Calculate 

Depreciation 
Create or Edit 

Asset Type 
Asset Type  Vendor (if desired), 

Manufacturer (if 
desired), Class (if 

desired) 

All Asset 
Management 

Functions 

  

Department None 
  

  Create or Edit 
Assets and/or 

Employees 
Site None All Asset 

Management 
Functions 

  

Location Site (at least one) 
(this product only 
supports one site) 

All Asset 
Management 

Functions 
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Asset Class (if desired), 
Asset Type, 

Department (if 
desired), Site, 

Location 

All Asset 
Management 

Functions 

  

Employee Department (if 
desired) 

  

  Check-
Out/Check-In 

Customer None 
  

  Check-
Out/Check-In 

 
 * The database can be populated manually by manually entering each new record rather than importing the 
information.   
  

The Pre-Requisites shown in the table above mandate that information be imported in the following sequence: 

1. Vendor (Optional) 

2. Manufacturer (Optional) 

3. Depreciation Class (Optional) 
 
 
If you intend to use them, import the Classes above before importing Asset Types! 

4. Asset Type (Required for all Asset Management functions) 

5. Department (Optional) 

6. Site (Required for all Asset Management functions) 

7. Location (Required for all Asset Management functions) 
 
 
If you intend to use Department for Assets or Employees, import Departments before Assets, Employees or 
Customers! 
 
 
Import Asset Type, Sites (if more than one) and Locations before importing Assets! 

8. Asset (Required for all Asset Management functions) 

9. Employee and/or Customer (Required only for Check-Out and Check-In functions) 

10. Funding 
  
Prior to importing information, external data should be organized in .txt or .csv files as follows: 

Each record in a Vendor.csv file requires a column for Vendor Code.   
The following columns are optional:  Address 1, Address 2, City, Contact Cell No., Contact Ext., Contact Fax, Contact 
Name, Contact Phone, Country, Custom Date 1 (through 5), Custom Number 1 (through 5), Custom Text 1 (through 
10), Email, Extension, Fax, Mail Stop, Name, Notes, Phone, Postal Code, State, and Web Site. 

Each record in a Manufacturer.csv file requires a column for Name.   
The following columns are optional:  Address 1, Address 2, City, Contact Cell No., Contact Fax, Contact Name, Contact 
Phone, Country, Custom Date 1 (through 5), Custom Number 1 (through 5), Custom Text 1 (through 10), Email, 
Extension, Fax, Mail Stop, Notes, Phone, Postal Code, State, and Web Site. 

Each record in a Class.csv file requires columns for Name and Depreciation Method. 
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The following columns are required only when one or more Depreciation Class records will have a Depreciation Method 
other than None:  Asset Life Years (1  - 99) and Asset Life Months (1 - 12). 
Example Class.csv records: 
Name,Depreciation Method,Asset Life Years,Asset Life Months 
DepNone,None,0,0 
DepSL1y,Straight-Line,1,0 
DepSL1y6m,Straight-Line,1,6 
DepSL2y,Straight-Line,2,0 

Each record in an AssetType.csv file requires a column for Asset Type and Class if the software is to Calculate 
Depreciation for one or more Asset Types. 

The following columns are optional:  Category, Check-Out Length, Custom Date 1 (through 5), Custom Number 1 
(through 5), Custom Text 1 (through 10), Description, Height, Length, Manufacturer, Model, Notes, Vendor Code, 
Weight, and Width. 
Example AssetType.csv records: 
AssetType,Description,Class 
Acme 2750,Compression Drill,DepSL1y6m 
Acme 3120,Rt-Angle Adapter,DepNone 
Rorch M5,Std Line Extractor,DepSL1y 
Rorch M7,Dlx Line Extractor,DepSL2y 

Each record in a Department.csv file requires columns for Department Code and Department Name. 

The following columns are optional:  n/a 

Each record in a Site.csv file requires a column for Site. 

The following columns are optional:  Custom Date 1 (through 5), Custom Number 1 (through 5), Custom Text 1 (through 
10), Description and Notes. 
Example Site.csv records: 
Site,Description 
Bldg1,North Warehouse 
Bldg2,South Warehouse 
Bldg3,Satellite Warehouse 
  
Each record in a Location.csv file requires columns for Site and Location. 
  
The following columns are optional:  Custom Date 1 (through 5), Custom Number 1 (through 5), Custom Text 1 (through 
10), Description and Notes. 
Example Location.csv records: 
Location,Site,Description 
101,Bldg1,Room 101 
102,Bldg1,Room 102 
103,Bldg1,Room 103 
104,Bldg1,Room 104 
  
Each record in a Asset.csv file requires columns for Asset Tag, Asset Type, Site and Location.   
The following columns are optional:  Additional Info, Category, Check-Out Length, Class, Condition (Bad, Excellent, 
Fine, or Good), Custom Date 1 (through 5), Custom Number 1 (through 5), Custom Text 1 (through 10), Department 
Code, Depreciate Asset (T or F), Depreciation Begin Date, Manufacturer, Model, Purchase Cost, Purchase Date, 
Purchase Order, Salvage Value, Serial No., Warranty Begin Date, Warranty End Date and Warranty Provider. 
 
Example Asset.csv records: 
Asset Tag,AssetType,Site,Location 
100001,Acme 2750,Bldg1,107 
100002,Acme 2780,Bldg1,107 
100003,Acme 3120,Bldg1,115 
100004,Rorch M5,Bldg1,103 
100005,Acme 2750,Bldg2,209 
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Each record in a Employee.csv file requires a column for Employee No., First Name and Last Name.   
  
The following columns are optional:  Address 1, Address 2, City, Country, Custom Date 1 (through 5), Custom Number 
1 (through 5), Custom Text 1 (through 10), Department, Email, Extension, Mail Stop, Notes, Phone, Phone Type, Postal 
Code, State and Title. 

Each record in a Customer.csv file requires a column for Customer No.   
  
The following columns are optional:  Address 1, Address 2, Cell No., City, Company Name, Country, Custom Date 1 
(through 5), Custom Number 1 (through 5), Custom Text 1 (through 10), Date Added, Department, Email, Extension, 
Fax, Home No., Mail Stop, Name, Notes, Phone, Postal and State. 
  
.CSV files are "comma separated values" files, which many database and spreadsheet applications can create via their 
"File > Save as..." or "File > Export..." functions.   
  
Please refer to the topic Import Wizard for step-by-step instructions on using the Import Wizard. 
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Import Wizard 

The Import Wizard allows you to bring Vendor, Manufacturer, Depreciation Class, Asset Type, Department, Site, 
Location, Asset, Customer and Employee data into the tables(Information you enter into each field in MobileAsset is 
stored in a database "table" behind the scenes.  You can extract this information using the Export Wizard.) in your 
database from external sources you already possess.  This software does not support direct importation of data from 
other databases. It imports data from .CSV or .TXT files only.  As this function is in a wizard form, the screens will guide 
you through each step of the export process. 
  
What is a .csv file? 

This is a type of data format in which each piece of data is separated by a comma. This is a popular format for transferring 
data from one application to another, because most database systems are able to import and export comma-delimited 
data. 
 
For example, data pulled from a database and represented in comma-delimited format looks something like the following. 
Each column value is separated by a comma from the next column’s value and each row starts a new line: 
 
Adams, Jane, 46, female, New York 
Doe, John, 32, male, California 
Jones, Sam, 13, male, Texas 
Smith, Mary, 64, female, Louisiana 
 
When data is represented in comma-delimited format they also are referred to as comma-separated values, abbreviated 
CSV. 

  
Please study the Import Strategy topic before proceeding. 
  

1. To access the Import Wizard, from the Main screen, select Administration > Import/Export > Import Wizard. 
The Import Wizard screen shown below appears: 
 

 
 
It is from this screen that you can start the process of Importing data into MobileAsset's tables.   
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Example of  an Import to the Asset table 

  
As discussed in the Import Strategy topic, data imported to the Asset table must be preceded by the creation of Site, 
Location, and Asset Type data (and, if depreciation is to be calculated for one or more Asset Types, by creation of 
Depreciation Class records - which must be done before importing Asset Type data.)   
  

1. Having previously populated the database with Site, Location, Depreciation Class and Asset Type data, in that 
sequence, proceed with importing information to the Asset table. 

2. Select an import file for the Asset table by browsing to a .csv or .txt file that contains Asset data and selecting 
Asset from the To table drop down list.   
 
You can only import from a text (.txt or .csv file). 
 
What is a .csv file?This is a type of data format, in which each piece of data is separated by a comma. This is 
a popular format for transferring data from one application to another, because most database systems are able 
to import and export comma-delimited data. 
 
For example, data pulled from a database and represented in comma-delimited format looks something like the 
following. Each column value is separated by a comma from the next column’s value and each row starts a new 
line: 
 
Adams, Jane, 46, female, New York 
Doe, John, 32, male, California 
Jones, Sam, 13, male, Texas 
Smith, Mary, 64, female, Louisiana 
 
When data is represented in comma-delimited format they also are referred to as comma-separated values, 
abbreviated CSV. 
 
If your data normally resides in a different data format, you must first use your database software's File > 
Export or File > Save As function to translate the data to a .csv or .txt file. See the Import Strategy topic. 
 
You must strip out all currency symbols, including (but not limited to) these examples:  $, ¢, ¥, £, §, or ¤, if you 
are about to import them into a numeric field, such as Purchase Cost, Salvage Value, etc. They are permissible 
in text fields. 
 
Commas, sometimes used as "thousands" separators, should be removed from numeric fields. Commas are 
permissible in text fields only when residing within a pair of double quotes, which will cause them to be treated 
as normal text, not as field delimiters. 
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3. Step 2 of the wizard allows you to specify how you want your information broken up in the export file. This is 
called the Field Delimiter.  Make your selection from the Field Delimiter drop down list, then select the 
checkbox if you want to include field names in the first row of your export file. Select the First row contains 
column headings option only if the first record of the file you are importing does not contain actual data.  The 
software cannot remove subtotals, section headers, nor any other records within the file that do not match the 
format of the actual data records. These must be removed before you attempt the import.   
 
The Preview of data from table grid displays the information using the selected delimiter, as shown below. If 
all the data is in one column of the preview pane, you have not selected the right Delimiter. 

176 



 
  

Wasp MobileAsset User Manual 

 

 

4. Next, the Field Mapping screen appears. This screen allows you to associate columns in your imported data 
file with corresponding fields in the table into which you are importing the data.  Depending on the contents of 
your original database, not every column in your imported data needs to be mapped to a corresponding field in 
the software. The object is to bring over at least the required fields and any others that may be of use. 
 
Note:  Your .csv or .txt file may have column headers with names that do not exactly match field names the way 
this example data does. By mapping the imported data's columns to each table's columns, any difference in 
field names can be accommodated.   
 
Select the appropriate Map To field names by clicking on a field in the Import Data Column, then selecting 
from the resulting drop down list, then click Next to continue. 
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If you failed to map columns for one or more of the table's required fields, you will receive a prompt like this: 
 

 

5. When all the required fields have been mapped correctly, click Finish. A confirmation message will appear 
when the file has imported correctly. 
 
Click OK and then Close to exit the Import Wizard. 
 
 
You can confirm that the data imported correctly by checking the List screens (From the Main screen, click List 
Forms > < list screen name>. 
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Export Wizard 

The Export Wizard allows you to create text files containing data from one or more fields within each of the software's 
database tables (Information you enter into each field in MobileAsset is stored in a database "table" behind the scenes. 
 You can extract this information using the Export Wizard.). As this function is in a wizard form, the screens will guide 
you through each step of the export process. 
  
Exports can be done from the following tables: Vendor, Manufacturer, Depreciation Class, Asset Type, Department, 
Site, Location, Asset, Customer and Employee. 

  
1. To access the Export Wizard, from the Main screen click Administration > Import/Export > Export Wizard. 

 The Export Wizard screen appears. 
 

 

2. Select what type of information you want to export from the Export Table drop down list.  In the example below, 
Customer is chosen. 
 
You also need to identify the file to which you want to export information. This can be an existing text file or you 
can create a text file now.  Use the ... button to open a Windows Explorer window to search for a file. You can 
only export to a text (.txt or .csv file). 
 
What is a .csv file? This is a type of data format, in which each piece of data is separated by a comma. This is a 
popular format for transferring data from one application to another, because most database systems are able to 
import and export comma-delimited data. 
 
For example, data pulled from a database and represented in comma-delimited format looks something like the 
following. Each column value is separated by a comma from the next column’s value and each row starts a new 
line: 
 
Adams, Jane, 46, female, New York 
Doe, John, 32, male, California 
Jones, Sam, 13, male, Texas 
Smith, Mary, 64, female, Louisiana 
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When data is represented in comma-delimited format they also are referred to as comma-separated values, 
abbreviated CSV. 
 
Click the Next button to continue using the Export Wizard.   
 
 

 

3. The Export Field Selection screen appears next. This screen allows you to select from which of the table fields 
you want to pull information. All fields available in the table you selected on the previous screen appear in the 
Fields Available box. Highlight a listing, then click the Right Arrow button to move it to the Fields Selected box. 
You can move all fields by clicking the Double Right Arrow button. This box does support multiple selections so 
you do not have to move one field at a time. 
 
 

180 



 
  

Wasp MobileAsset User Manual 

 
 
The data that appears in the fields you moved to the Fields Selected box appear in the Data Preview of Table 
grid.   
 

 
 
You can move fields out of the Fields Selected box by highlighting a field in the box, then clicking the Left Arrow 
button as shown below. 
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When you are finished selecting the fields you want to Export, click the Up or Down buttons next to the Fields 
Selected box to reorder how the information will appear in your export file.   
 
Click Next to continue. 

4. The Destination File Format screen allows you to specify how you want your information broken up in the export 
file. This is called the Field Delimiter. Make your selection from the Field Delimiter drop down list, then select the 
checkbox if you want to include field names in the first row of your export file. 
 
The Preview of data from table grid displays the information using the selected delimiter, as shown below: 
 

 
 
If the file name you specified in Step 1 uses the extension .CSV, you must specify <Comma> as your field 
delimiter (this is the default).     
 
If you specified a file name with the extension of .TXT in Step 1, you may use any of the field delimiters available 
in the drop list (as long as the chosen character does not occur within the data itself.) 
 
The available options are shown below: 

 

5. Click the Finish button to Export your selection. A confirmation message will appear when the export is 
completed successfully. 
 
You can confirm the export by opening and reviewing the .csv or .txt file you specified in Step 1. 
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2.12.6 Customize Names 

Reset All Field Names 

The software provides you with the ability to customize the application to fit your business needs. After you have 
changed field/function names, you can quickly return all values to their original, or default, values in one, quick step. 

1. To reset all field names to their default values, from the Main screen click Administration > Customize Names 
> Reset All Field names. (Only users set up with Administrative Privileges in Security can perform this 
function.) 
 
The message shown below will display: 
 

 
 
All fields names and all Dynamic Custom Field names will be reset to their default values. 

2. Click OK to restore label default values or Cancel if you want to keep the existing settings. 
  
Reset All Field Names is displayed in the Customize Names menu even when the Edit Field Names option is 
disabled or the current user lacks administrative privileges. If Reset All Field Names is selected under these 
circumstances, the following message will be displayed: 
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Customize Messages 

This feature is available in the Professional and Enterprise versions only. 
  
This feature can only be accessed by users with the Security Type of Admin. 
  
The Customize Messages function allows you to change the message strings that appear in MobileAsset. This 
function allows you to search all messages, or language strings, throughout MobileAsset and replace them with text of 
your choice. 
  
Replace Text 
Reset Language Strings to Default 
  

 

Replace Text 

  
1. From the Main screen, click Administration > Customize Messages. The Customize Messages screen 

appears: 
 
 

 

2. Enter a full or partial language string in the Find field. You can optionally limit the search to Match Case or 
Match Whole word of your text entry using the check boxes provided. Click the Find button. A list of all 
language strings containing the entered text will appear in the Messages window. 
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Note that the Message Count appears in the bottom, right corner of the screen. In the example above, the 
Message Count is 53. This means that 53 language strings containing the text entered in the Find field were 
found. 
 
This list contains several columns: 
 
 
PC/Mobile - The PC/Mobile column indicates if the listed string appears on the PC application or on the 
Mobile Device application. 
 
New - The New column appears blank at this point. After you make a change to a string, your new text will 
appear here. 
 
Old - The Old column lists the text as it appears prior to this change. 
 
Default - This column displays the text as it appeared by default. 
 
Label - The Label column displays the internal label for this language string.  
 

3. Put a check mark next to the strings you want to change by clicking in the checkbox in the left column. You 
can also Select All or Select None using the buttons at the bottom of the screen. 
 

4. After making your selections, enter the new text in the Replace with field.  
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You can add a tab or add new line to your message by selecting from the drop down box, then click the Insert 
button. You can optionally use the newline and tab characters in the text box to add these attributes. To add a 
new line, enter \n in front of the word before which you want to start the new line. For example, enter "/never" 
to being a new line beginning with the word "ever". For tabs, enter \t before the word or character you want 
the tab. 
 

 
5. Click the Replace button when you are done entering text. 

 

 
 
 
The software will replace the selected language strings with your text.  
 
In the example below, we replaced the language string Asset Type: with the text Example Text:.  
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This means that wherever this language screen appears in the PC application, the customized text "Example 
Text" will appear. 
 
You can alternatively select only one language string, then click the Edit button. The Edit Message screen 
appears. 
 
 

 
 
This screen has the same functionality found on the Customize Messages screen. Use the Parameters drop 
down menu to select the required message parameters for the message string, then click Insert. 

6. If you want the new text to become the default, click the Set Default button. 
7. Click Save to save your changes. 

 
Click Undo to undo your most recent change. You can undo up to the last 5 changes. 

 

  

Reset Strings to Default 

  
1. Click on the Reset Language Strings button to reset all language strings in the database back to their default 

settings. When this button is clicked, the following screen appears: 
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2. Click Yes on this screen to delete the current strings and replace them with the default strings. The following 
screen appears: 
 

 

3. Click OK on this screen. The strings window on the Customize Message screen will show the default messages 
after you close and reopen the screen. 
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Customize Report Names 

The Customize Report Names feature allows you to change the names of the reports in MobileAsset. This enables 
you to have continuity in nomenclature across MobileAsset if you have changed other elements, such as messages 
and field names.  
  
Customize Report Names 
Reset Report Names 
  

 

Customize Report Names 

  
1. From the Main screen, select Administration > Customize Names > Customize Report Names. The 

Change Report Names screen appears. 
 
 

 

2. Double click on a listing in the New column. A text box will appear allowing you to type in a new report name.  
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3. Click out of the field to enable the OK button. Continue changing report names as needed. Click the OK 
button when you are done.  Now the Reports menu will show the new report name. 

  
 

Reset Report Names 

The Reset function resets any changed report names back to their default values. 
  

1. From the Main screen, select Administration > Customize Names > Customize Reports. The Change 
Report Names screen appears. 

2. Click the Reset button at the bottom of the screen. 
  

  

190 



 
  

Wasp MobileAsset User Manual 

Customize Label Names 

The Customize Label Names feature allows you to change the names of certain labels, such as Asset Tags, 
Employee Badges and Location Labels. This enables you to have continuity in nomenclature across MobileAsset if 
you have changed other elements, such as messages and field names. For example, if you have renamed Assets to 
Books, you can use this feature to change the label Asset Tags to Book Tags.  
  
Customize Label Names 
Reset Label Names 
  

 

Customize Label Names 

  
1. From the Main screen, select Administration > Customize Names > Customize Label Names. The 

Change Label Names screen appears. 
 
 

 

2. Double click on a listing in the New column. A text box will appear allowing you to type in a new label name.  
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3. Click out of the field to enable the OK button. Continue changing label names as needed. Click the OK button 
when you are done.  Now any screens/menus that display the label will show the new name. 

  
 

 
Reset Label Names 

The Reset function resets any changed label names back to their default values. 
  

1. From the Main screen, select Administration > Customize Names > Customize Labels. The Change 
Label Names screen appears. 

2. Click the Reset button at the bottom of the screen. 
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Customize Element Names 

  
The Customize Element Names feature allows you to change the names of menu labels in MobileAsset.  
  
Customize Element Names 
Reset Element Names 
  

 

Customize Element Names 

1. From the Main screen, select Administration > Customize Names > Customize Element Names. The 
Change Element Names screen appears. 
 
 

 

2. Double click on a listing in the New column. A text box will appear allowing you to type in a new element 
name.  
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3. Click out of the field to enable the OK button. Continue changing report names as needed. Click the OK 
button when you are done.  Now the new menu labels will be displayed. name. 

  
 

Reset Element  Names 

The Reset function resets any changed elements names back to their default values. 
  

1. From the Main screen, select Administration > Customize Names > Customize Element Names . 
The Change Element Names screen appears. 

2. Click the Reset button at the bottom of the screen. 
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Edit Field Names 

When the Edit Field Names option on the Options screen is enabled (accessed from the Main screen by selecting 
Administration > Options) a user setup in the Admin Group in Security can use the Edit Field Names feature.  
  
This method of customization allows you to change the name of labels on various screens. For example, you can use 
this method to change the label "Asset Type" when it appears on screens such as New/Edit Asset and New/Edit Asset 
Type. Changing the label name using this method will not change the label Asset Type on menus or on Reports. You 
will need to use the Customize Label Name and Customize Report Name functions to make those changes. 
  

1. Make sure you have turned on the Edit Field Names option on the Options screen (Administration > 
Options). Any field names that can be edited will appear as blue hyperlinks on the screen. For example, on the 
New Asset screen, the field names that can be edited appear as shown below: 
 

 

2. To edit a field, click on the label you want to edit. In the example above, if you want to change the field name 
Asset Type, click on it. A screen similar to the following appears: 
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3. Type in the New Name and an optional Tool tip. Tool Tips provide special instructions to your users when they 
hover their mouse over the field. 

4. Some customizable fields do not permit the use of the Visible and Required options - they will be grayed-out. 
This is because these fields must be both visible and required for normal operations.   
 
De-selecting the Visible option completely removes the field from the forms where it occurs. This can be used 
to streamline data input operations by removing the distraction of unused fields.  
 
Selecting the Required option makes data entry mandatory for transactions that use that field. The Visible 
option will be grayed-out when the Required option is selected. 

5. If you want to send the edited field name to the mobile device, select the Send to Mobile Device checkbox. 
The next time you perform a full sync (including downloading data from the PC) the edited name will be sent. 

6. To return the field name/tool tip to the default values, click the Set to Default button. 

7. Click the OK button to save your changes.  Be aware that you are only changing the field name for the current 
screen. Other screens that contain a field with the same label will not be changed. 

The Customize Field screen can be accessed by clicking on hyperlinked customizable fields that can be found in the 
Create New Asset, Create New Asset Class, Create New Customer, Create New Department, Create New Employee, 
Create New Asset Type , Create New Location, Create New Manufacturer, Create New Site, Create New Funding and 
Create New Vendor forms, as well as the Edit Asset, Edit Asset Class, Edit Customer, Edit Department, Edit Employee, 
Edit Asset Type, Edit Location, Edit Manufacturer, Edit Site, Edit Funding and Edit Vendor screens. 
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2.12.7 Set Default Working Site 

You can designate Source and Destination sites (or locations, if your version only allows one site) that appear by default 
on the New Asset, Check Out, Check In, Audit, Dispose and Move screens using the Set Default Working Site screen. 
MobileAsset allows you to work with more than one Site and multiple Locations within each Site.   
  
When MobileAsset's functionality is not restricted to a single site, users must remain mindful of which site they are 
working with as transactions are performed. 
  
Source will determine the default location in the Location field of the New Asset, Check Out, Check In, Audit and 
Dispose screens. It will also determine the default location in the From Location field of the Move function. 
  
Destination will determine the default location in the Move function's To Location field. 
  
By default, all sites are allowed. 
  

1. To set the source and destination sites, from the Main screen, click Administration > Set Default Working 
Site. The Select Site screen appears: 
 

 
  

2. Make your selections from the drop down lists. All sites you have entered into the database will appear in the 
list. 

3. Click OK when you have made your selections. 
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2.12.8 Options 

Options 

The Options screen is where you can turn off and on some automatic processes for asset functions and control how 
the software performs in certain situations.   
  
The following functions are controlled from the Options screen: 
  
Asset Options: 
  
Allow Duplicate Serial Numbers 
Automatic Asset Tags 
Automatic New 
Checkout Duration Uses Week Day Only 
Decimal Places 
Due Date on Next Week Day 
Edit Field Names 
Edit Inherited Asset Type Data 
Last Depreciation Date 
  
  
Support Options: 
  
Archive Processed Mobile Data 
Check for Software Updates 
Close New Form 
Create Employee 
Max Row Count 
Show Warning Messages 
SQL Server Backup Location 
  
Mobile Options: 
  
Maximum Pictures Captured 
Prompt Full Sync 
Prompt Upload 
Require a Signature on Device? 
  
Email Options: 
  
Always Show Email Destination List 
SMTP Password 
SMTP Port 
SMTP Server 
SMTP SSL/TSL 
SMTP User 
  
Alert Options: 
  
Alerts CC Emails 
Alerts Email Body Text 
Alerts Email Subject Text 
Alerts To Emails 
Email Alerts 
Maintenance Alerts 
Time to Check for Alerts 
User Name Used for Email Alerts 
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Reminder Alert Option 
  
Email Reminder Alerts 
Reminder Alerts Email Body Text 
Reminder Alerts Email Subject Text 
User Name Used for Email Reminder Alerts 
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Fix Circular Links 

Occasionally circular links are created when syncing data from a mobile device to the PC. For example, you may have 
Asset A, which is the parent of Asset B. Asset B is the parent of Asset C. When syncing, the application may create a 
third link making Asset C the parent of Asset A, thus creating a circular link. When you view assets from the Asset 
List or on the Edit Asset screen and MobileAsset detects a circular link, the software will attempt to correct the 
problem. If this fails, or if you want to run a check on all assets and correct all circular links  (if there are any) at once, 
you can use the Fix Circular Links tool on the Options screen. 
  
To Fix Circular Links: 
  

1. From the Main screen select Administration > Options. 

2. On the Options screen, select the Tools drop down menu, then select Fix Circular Links. 
 

 
 
The software will review all assets and remove any circular links. 
 
 

 
 
If no circular links are found, the following message appears: 
 

 
 
Click OK to close the message screen. 
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Asset Options 

Allow Duplicate Serial Numbers 

The software allows you to have two assets that have the same Asset Type to also have the same serial number. This 
option is disabled, or turned off, by default. This option covers the possibility that a generic Asset Type that is not make- 
and model-specific might have to support Assets which coincidentally have the same serial number from two different 
manufacturers.   

You can enable this option by following the instructions below: 

1. From the Main screen, click Administration > Options. The Options screen appears. 

2. On the Options screen, highlight Allow Duplicate Serial Numbers. 
 
 

 

3. Enable the option by clicking the Yes check box.   

4. Click OK to save the options you've changed and to close the Options screen. 
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Automatic Asset Tags 

This option automatically assigns Asset Tags when creating new Assets or duplicating an existing Asset. When this 
option is turned on, you will not be able to enter a tag into the Asset Tag field on the New/Edit Asset screens. The tag 
will be automatically generated when you click Save or click the button next to the Asset Tag field on the New/Edit 
Asset screens. 
  
For information on setting the default tag number the system will begin with when assigning asset tags, see the section 
Setting the Automatic Tag Numbers, below. This option is turned off by default. 
  
The following topics are discussed in this section: 
  
Turning on the Automatic Asset Tags Feature 
Setting the Automatic Tag Numbers 

 
  
Turning On the Automatic Asset Tags Feature 
  

1. To turn on this feature (it is turned off by default), from the Main screen, click Administration > Options > 
Automatic Asset Tags. The Options screen appears. 

2. On the Options screen, highlight Automatic Asset Tags and select the Yes check box. 
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3. Select the OK button to implement the features you have chosen and to close the Options screen. 
 

  
Setting the Automatic Asset Tag Numbers 
  
The Asset Tag values created will be incremented by a value of one, beginning with the largest Asset Tag value that 
existed in the database when the option was first enabled. Beginning with an empty database, the first automatically 
assigned Asset Tag will be a value of "1".  You can change the first automatically assigned Asset Tag on the Set Next 
Tag Value screen.   
  

1. To access this screen from the Main screen, select Administration > Set Next Asset Tag Number. The Set 
Next Tag Value screen appears allowing you to select a start number.  Below is an example of the Set Next 
Tag Value screen.   
 

   

2. Enter the number you want to begin with, then click OK. 
  

  

203 



 
  

Wasp MobileAsset User Manual 

Automatic New 

The Automatic New option enables the system to automatically open the Create New screen when you enter an asset, 
site, location, depreciation class, etc. that is not already in the database.  For example, if you are creating a new asset 
and enter a location in the Location field that does not currently exist in the database the New Location screen will 
appear allowing you to finish entering the new location. This option is off by default. 
  
When this option is turned off, a message appears when a new asset, site, etc. is entered asking if you want to create 
the new item. If you select Yes, the New screen appears. 

  
1. To enable this feature, from the Main screen, click Administration > Options. 

2. Highlight the Automatic New listing and select the Yes checkbox. 

3. Click OK to save your changes. 
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Decimal Places 

This option allows you to set the number of decimal places to display in numeric fields (where possible). 
  
All values entered in numeric fields are stored in the database with up to 4 decimal places. You may not want to display 
all four decimal places on your list screens and reports, so you can designate the number of decimal places, from 1 to 4, 
that will display. 
  
The following topics are discussed in this section: 
  
Setting the Decimal Places Option 
Changing the Decimal Places Option 
Searching for Data with Truncated Decimal Places 

 

Setting the Decimal Places Option 

1. From the Main screen, click Administration > Options. The Options screen appears. 

2. Highlight the Decimal Places option: 
 

 

3. In the text field, enter the number of decimal places you want to display. You can enter 0 through 4. The default 
setting is 2 decimal places. 
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4. Click the OK button when you are done entering information. 
 

Changing the Decimal Place Option 

  
If you change the number of allowed decimal places to a great number (1 to 4, for example) any digits stored prior to the 
change will display with trailing zeros. For example, if a value of 25.5 was stored when the Decimal Places option was 
set to 1, it will be displayed as 25.500 if the Decimal Places option is later set to 3. 
  
If you change the number of allowed decimal places to a lesser number (4 to 1, for example) any digits stored prior to 
the change will be rounded. For example, if a value of 25.5 was stored when Decimal Places was set to 1, it will be 
displayed as 26 if Decimal places is later set to 0. (Values rounded for display at the currently specified number of 
Decimal Places will retain their original number of decimal places as stored in the database.) 

 

Searching for Data with Truncated Decimal Places 

  
Keep in mind that your numbers are stored with up to four decimal places. If you set the Decimal Place option to 1, but 
your numbers contain 4 decimal places, it will be helpful to search using all the decimal places. For example, if you are 
searching for the numbers: 4.123, 4.134, 4.148 but the Decimal Places option is set to one decimal place showing, the 
Asset List will displays these numbers as 4.1, 4.1, 4.1. If you are attempting to use the Find feature to search for a 
specific number, you can type in all decimal places, 4.123, for example to make your search easier. However, when 
they go into the Find, they will be able to see all the decimal places. 
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Turning on the Edit Field Names Feature 

This feature allows users setup with Administrative Privileges in Security to change the names of certain fields and 
functions in the software. This topic covers how to turn this feature on. For information on how to change field 
names once the option is active, see the Edit Fields topic. 
  

1. To turn on this feature, from the Main screen click Administration > Options. The Options screen appears. 

2. Highlight Edit Field Names in the list and make sure the Yes check box is selected. 
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Edit Inherited Asset Type Data 

This option allows you to edit the Asset Type information on the New Asset/Edit Asset - General Tab. When you 
create a new Asset and select an Asset Type, you will be asked if you want to incorporate data from that Asset Type 
(manufacturer, check out length, lead time, etc.). For more information on incorporating data from the Asset Type into a 
new Asset, please refer to the topic Creating a New Asset. 
  
This option is disabled by default.   
  
To Enable the Edit Inherited Asset Type Data Option 
  

1. From the Main screen, select Administration > Options. The Options screen appears. 

2. On the Options screen, highlight the Edit Inherited Asset Type Data option. 

3. Make sure the Yes check box is selected. 
 
 

 

4. Click the OK button when you are done making changes. 
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Changing the Last Depreciation Date 

This view only field on the Options screen allows you to view the last date depreciation was calculated on your assets. 
This field is view only. 
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Support Options 

Active Directory 

Enterprise Edition Only 
  
Set this option to Yes to allow MobileAsset to access your Active Directory for user log in information. This allows you 
to take advantage of Windows NT Authentication, meaning your users will be able to access MobileAsset 
automatically, without having to input login information each time. In addition, when you set up your Groups to match 
those in your Active Directory, MobileAsset will automatically create a user account the first time each user logs in. 
  
Example:  You have a group in your Active Directory named My Users and you want everyone in My Users to have 
access to MobileAsset. Create a Group with the name My Users in MobileAsset using the MobileAsset PC 
application. Now when each member of the Group My Users accesses MobileAsset on the PC, MobileAsset will 
recognize the Active Directory Group name as matching the MobileAsset Group name and automatically create a 
User account for that user.  After the group is setup, when the user accesses MobileAsset on the PC, MobileAsset will 
recognize the computer is on the network and automatically log in the user.  
  
This option is turned OFF by default. 
  
Note: This option can be used in conjunction with the Create Employee option. 

  
1. From the Main screen, select Administration > Options. 
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2. On the Options screen, highlight the Active Directory option. 
 

 

3. Leave this option set to Yes to allow users to sign in using their network domain account. 
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Check for Software Updates 

By default, the software will check for updates to the application and notify you if a more recent version is available. You 
can then access the software updates website and download the latest version. This ensures you are always working 
with the most up-to-date version available to you. This feature is turned on by default. 
  
The software must be installed on a machine with Internet access to check for updates. 
  
You can turn off the automatic check and perform periodic manual checks, or leave the option on and perform a manual 
check, if desired. 
  
To Disable the Automatic Version Check Feature 
To Perform a Manual Check 

 
  
To Disable the Automatic Version Check Feature 
  

1. From the Main screen, select Administration > Options. The Options screen appears. 

2. Highlight the Automatic Check for Updates option and deselect the Yes check box.   
 

 

3. Click OK to save your changes and to Close the Options screen. The option is now disabled. You can 
manually check for updates as needed. 
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To Perform a Manual Check 

From the Main screen, click Help > Check for Updates.   
 

 
 
 
The system will automatically check for a newer version and notify you if one is available. This procedure can be 
performed at any time. 
  
  

  

213 



 
  

Wasp MobileAsset User Manual 

Close New Form 

The Close New Form function enables the system to automatically close the New screen each time a new record is 
created. If the feature is turned off (disabled), after you enter a new item and click OK on the New screen, the screen 
will clear of information and remain open allowing you to enter another new record. If it is turned on (enabled), the New 
screen will close each time a new record is saved.  
  
This option can only be enabled/disabled by a user set up in the Admin Group in Security. The Close New Form option 
is turned OFF by default. 
  

1. To enable/disable this feature, from the Main screen click Administration>Options.   

2. On the Options screen, highlight the Close New Form listing and select the Yes check box to enable the 
feature or make sure the check box is not selected to disable it. 
 

 

It might be desirable to turn this option off when first entering data, for speed, then turn it on later to avoid confusion 
when using it infrequently. 
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Create Employee 

Enterprise Edition Only 
  
If you have the Active Directory option set to Yes, meaning you are using Windows NT Authentication, you can turn 
this option ON to allow MobileAsset to automatically create an employee record the first time he/she logs in using Active 
Directory. 
  
This option is ON by default. 
  

1. From the Main screen, select Administration > Options. 

2. On the Options screen, highlight the Create Employee option. 
 
 

 
 

3. If you want MobileAsset to automatically create an employee record the first time the user logs in using Active 
Directory, make sure the Yes checkbox is selected.  If you do not want the employee record automatically 
created, deselect the checkbox. 
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Delete Processed Mobile Data 

The Delete Processed Mobile Data option allows you to set MobileAsset to automatically delete mobile data that was 
processed into the system more than X number of days ago. This keeps your database free from unneeded information. 
The default setting is data older than 180 days. 
  
  
To Delete Processed Mobile Data: 
 

1. From the Main screen click Administration > Options. The Options screen appears. 

2. On the Options screen, highlight the Delete Processed Mobile Data option: 
 
 

 
 
  

3. In the text entry field, enter the number of days after which processed mobile data should be deleted.  In the 
example above, we have entered 180 (the default setting).  This means that processed mobile data older than 
180 days will be deleted. 
 
 
If you do not want to delete processed mobile data, enter 0 in this field. 

4. Click OK when you are done making changes. 
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Max Row Count 

By default MobileAsset displays all records on a List screen. You can change this default number to be lower on the 
Options screen. For example, if you have many records (over 1,000), you can set this number to display fewer rows at 
one time to improve system performance. It will take your system longer to retrieve and display 5,000 asset records on 
the Asset List screen then to display 1,000. Therefore, you may want to set the maximum to display 1,000. 
  

1. To change the default number of rows that display, from the Main screen, select Administration > Options. 
The Options screen appears. 

2. On the Options screen, select Max Row Count. The default number is 0, which displays all rows. You can 
change this to any number between 100 and 1,000. Or, you can enter 0 to display all rows on the List screen.   
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Show Warning Messages 

The software allows you to turn off the warning messages that normally appear. For example, if you try to close a 
screen with unsaved information, by default a warning message will appear alerting you to that fact. If you do not wish to 
see these types of messages, you can turn them off using this function. 
  

1. To turn off the Show Warning Messages option, from the Main screen click Administration > Options. The 
Options screen appears. 

2. On the Options screen, highlight Show Warning Messages and deselect the Yes checkbox (it is selected by 
default). Deselecting the Yes checkbox turns off the warning messages. 
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SQL Server Backup Location 

  
This option is useful if you have your database installed on a different PC/Server than where you are running the 
software. 
  

1. Select Administration > Options > SQL Server Backup Location.   
 

 

2. Enter an existing directory on the PC/Server where the SQL database is installed (this is where you installed the 
database during the initial installation process). Make sure the user who will be performing the backups 
(Administration Menu > Backup) has permission to the database.   
 
If a location is not entered, the Microsoft SQL Server backup directory will be used to store backups. This is 
where the system will look for backup files when you try to restore the database as well. 
 
If you specify a folder and SQL Server does not have rights to write to that folder, you will receive an error 
message and the backup will fail. It is your responsibility to give SQL Server the proper rights to write the 
backup in the specified folder. 
 
For information on how to give permissions to a folder, please refer to Wasp Technical Support, Knowledge 
Base and Downloads on the internet. 
 
By default, if you do not have a remote connection to your database, the backup folder is: C:\Program 
Files\Microsoft SQL Server\MSSQL.1\MSSQL\Backup 
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Mobile 

Maximum Pictures Captured 

This option sets the maximum number of pictures that can be captured on a mobile device per each edit/new asset or 
for select transactions. Keep in mind that allowing too many pictures may slow down processing the device database. 
  

1. To set the maximum allowed captures, from the Main screen click Administration>Options.   

2. On the Options screen, select Mobile > Maximum Pictures Captured.  

3. Enter the number of captures you want to allow on the devices in the data field. The default amount is 5. 
 

 

4. Click OK when you are done entering data. 
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Prompt Full Sync 

  
This option sets the time span in minutes before the mobile device will begin prompting the user to start a full sync 
back to the PC. 

  
1. To set this option, from the Main screen click Administration > Options.   

2. On the Options screen, select Mobile > Prompt Full Sync.  

3. Enter the number of minutes you want to elapse from the beginning of the MobileAsset session before the device 
begins reminding the user to start a full sync in the data field. The default number of minutes is 1440. 
 
 

 

4. Click OK when you are done entering data. 
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Prompt Upload 

  
This option allows you to set the time span in minutes before the mobile device will begin prompting the user to upload 
their data. 

  

1. To set this option, from the Main screen click Administration>Options.   

2. On the Options screen, select Mobile > Prompt Upload.  

3. Enter the number of minutes you want to elapse before the device begins reminding the user to upload data. The 
default time is 60 minutes. 
 

 

4. Click OK when you are done entering data. 
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Require a Signature on Device? 

  
This option allows you to designate whether signatures will be required on select transactions (such as check out and 
check in) on the mobile devices. 
  

1. To set this option, from the Main screen click Administration > Options.   

2. On the Options screen, select Mobile > Require a Signature on Device.  
 
 

 

3. You have three options: 
 
Type "yes" in the text field to require a signature on select transactions. Selecting Yes disables the Quick 
Check Out and Quick Check In functions on the mobile device. 
Type "ask" in the text field to have the device prompt for a signature, though a signature will not be required. 
(This is the default option.) 
Type "no" in the text field to disable the signature feature on the device. This means a signature will not be 
captured on the device. 
 
Note: Case does not matter. For example, you can enter no, NO, or No. 

4. Click OK when you are done entering data. 
  

223 



 
  

Wasp MobileAsset User Manual 

  
  

Email Options 

  
Mobile Asset can send out alerts as emails to selected recipients by setting the options in the Email and Alerts 
sections of the Options screen. 
  
  
Email Options are: 
  
Always Show Email Destination List 
SMTP Password 
SMTP Port 
SMTP Server 
SMTP SSL/TSL 
SMTP User 
  

 
  

Always Show Email Destination List 

This option sets the email destination list to display prior to alerts (maintenance, overdue ,etc.) alerts being emailed 
out by the software. 
  

1. To set this option, from the Main screen click Administration>Options.   

224 



 
  

Wasp MobileAsset User Manual 

2. On the Options screen, select Email > Always Show Email Destination List.  
 

 

3. Select Yes to always have the list of email destinations appear prior to the software sending out alerts emails. 
This list allows you to select the email addresses to which the order will be sent. 

4. If you deselect the Yes checkbox, the list will not appear and the emails will automatically be sent to every 
address you entered in the Alerts to Emails option. 

  
 

  

SMTP Password 

If your SMTP server requires authentication to send outgoing mail, enter the password here.  
  

1. To set this option, from the Main screen click Administration>Options.   
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2. On the Options screen, select Email > SMTP Password 
 

 

3. If your SMTP server requires authentication enter the password. The password will appear masked, as shown 
in the example above.  If it does not require authentication, leave this field blank.  

  
 

SMTP Port 

Enter the SMTP mail server listening port here.  
  

1. To set this option, from the Main screen click Administration>Options.   
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2. On the Options screen, select Email > SMTP Port. 
 

 

3. Enter the port number in the data field. The default port is 25.  
  

 

SMTP Server 

  
Enter the name of an outgoing mail server that supports SMTP for delivering notification emails.  
  

1. To set this option, from the Main screen click Administration>Options.   
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2. On the Options screen, select Email > SMTP Server. 
 

 

3. Enter the name of the same outgoing mail server that is setup in your own email program. If you do not want 
MobileAsset to send alert emails, leave this field blank.  

  
 

SMTP SSL/TSL 

  
Turn this option on for all SMTP servers that require SSL or TSL, including GMail SMTP servers. 
  
Note on using GMail: To use a GMail SMTP server to send out mail from MobileAsset: 
  

1. Go to www.gmail.com and setup your gmail account. 
2. Have your IT department open port 587 and 465 on your computer. 
3. Turn on the SMTP SSL/TSL option, and set up the other SMTP related options on the Options screen. 

The GMail SMTP server address is smtp.gmail.com. The SMTP user should be 'yourgmailname@gmail.com' (don't 
forget @gmail.com). The SMTP Password is your Gmail account password. 
  
Please be aware that you need to turn this option on for all SMTP servers that require SSL or TSL, not just for 
GMail SMTP servers. 
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1. To set this option, from the Main screen click Administration>Options.   

2. On the Options screen, select Email > SMTP SSL/TSL. 
 

 

3. Turn this option on for all SMTP servers that require SSL or TSL, including GMail SMTP servers. 
  

 

SMTP User 

  
If your SMTP server requires authentication to send outgoing mail, enter the user name here. 
  

1. To set this option, from the Main screen click Administration>Options.   
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2. On the Options screen, select Email > SMTP User. 
 

 

3. If your SMTP server requires authentication to send outgoing mail, enter the user name here. If it does not 
require authentication, leave this field blank.  
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Alert Options 

Alert Options are a series of settings related to the Alerts functionality. This section contains options for entering email 
address to which alerts should be sent, the body and subject line of the alerts email and the lead time for maintenance 
alerts. 
  
Alerts are not available in the Standard version. 
  
Alert Options are: 
  
Alerts CC Emails 
Alerts Email Body Text 
Alerts Email Subject Text 
Alerts to Emails 
Email Alerts 
Maintenance Alerts 
Time to Check for Alerts 
User Name Used for Email Alerts 
  

 
  

Alerts CC Emails 

  
You can enter email address here to which the alert will automatically be sent at the time designated in the Time to 
Check for Alerts option. The CC email addresses are in addition to any email addresses entered in the Alerts To 
Emails option. 
  

1. To set this option, from the Main screen click Administration > Options.   
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2. On the Options screen, select Alert > Alerts CC Emails.  
 

 

3. Enter the list of email addresses you want CC'd on the alerts email in the text field. Use a semicolon (;) to 
separate each email address as shown in the example above. 

  
 

  

Alerts Email Body Text 

  
Enter the text you want to appear in the body of the email using this option. 
  

1. To set this option, from the Main screen click Administration > Options.   
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2. On the Options screen, select Alert > Alerts Email Body Text.  
 

 

3. Enter the text you want to appear in the body of the alert email. The default text is "Attached please find mobile 
asset alert reports.". 

  
 

Alerts Email Subject Text 

Enter the subject line for the alert email. 
  

1. To set this option, from the Main screen click Administration > Options.   
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2. On the Options screen, select Alert > Alerts Email Subject Text.  
 

 

3. Enter the subject line you want to appear on the alert email. The default subject line  is "Mobile Asset Alerts". 
  

 

Alerts To Emails 

  
You can enter email address here to which the alert will automatically be sent at the time designated in the Time to 
Check for Alerts option.  
  

1. To set this option, from the Main screen click Administration > Options.   
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2. On the Options screen, select Alert > Alerts To Emails.  
 

 

3. Enter the list of email addresses you want CC'd on the alerts email in the text field. Use a semicolon (;) to 
separate each email address as shown in the example above. 

  
 

Email Alerts 

  
Select this option to tell the software to email any addresses entered in the Alerts To Emails and Alerts CC Emails 
sections if an alert is found a the Time To Check for Alerts. 
  
  

1. To set this option, from the Main screen click Administration > Options.   
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2. On the Options screen, select Alert > Email Alerts.  
 

 

3. Select the Yes checkbox to turn this feature on. Leave the checkbox blank to turn off the email alerts function. 
  

 

Maintenance Alerts 

This option sets the lead days for Maintenance Alerts. 
  

1. To set this option, from the Main screen click Administration > Options.   
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2. On the Options screen, select Alert > Maintenance Alerts.  
 

 

3. Enter the number of lead days in the text field. The default is 10. 
  
  

 

Time To Check for Alerts 

This option allows you to enter the time you want the system to email any existing alerts. 
  

1. To set this option, from the Main screen click Administration > Options.   
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2. On the Options screen, select Alert > Time to Check for Alerts.  
 

 

3. Enter the time to check for alerts in military format. For example, enter 13:30 to send out the email at 1:30 pm. 
  

 

User Name Used for Email Alerts 

  
This option allows you to enter the "From" email that will be used for the Alert Emails. 
  
  

1. To set this option, from the Main screen click Administration > Options.   
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2. On the Options screen, select Alert > User Name Used for Email Alerts.  
 

 

3. Enter the User Name you want to be used to send out email alerts. The software will use the email address 
from that user's Security profile as the "From" address on Alerts Emails. The designated user MUST have an 
email address entered in their Security profile. 
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Reminder Alert Options 

These options control how reminder alerts are handled by MobileAsset. Reminder alerts are emails sent to users who 
have a checked out asset nearing it's due date. 
  
If this option is turned on, MobileAsset will send a reminder email to the employee/customer to whom the asset is 
checked out a set number of days before the due date. The number of days is set in the Reminder Lead Time field 
on the New/Edit Asset Type screen and is viewable on the New/Edit Asset screen. 
  
Reminder Alert Options are: 
  
Email Reminder Alerts 
Reminder Alerts Email Body Text 
Reminder Alerts Email Subject Text 
User Name Used for Email Reminder Alerts 
  

 
Email Reminder Alerts 
  
Use this option to turn on the email reminder alert function. This function is turned off by default. 
  
  

1. From the Main screen, select Administration > Options > Reminder Alerts > Email Reminder Alerts. 
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2. Check the Yes check box to turn on this feature. 
 

 

3. Click OK to save the change and close the Options screen. 
  

 

Reminder Alerts Email Body Text 

  
This option allows you to edit the body of the reminder email.  
  
  

1. From the Main screen, select Administration > Options > Reminder Alerts > Reminder Alerts Email 
Body Text. 

241 



 
  

Wasp MobileAsset User Manual 

2. Click in the text box and make changes as needed. 
 

 
3. Click OK to save the change and close the Options screen. 

  
 

Reminder Alerts Email Subject Text 

  
This option allows you to edit the subject line of the reminder email. 
  
  

1. From the Main screen, select Administration > Options > Reminder Alerts > Reminder Alerts Email 
Subject Text. 
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2. Click in the text box and make changes as needed. 
 

 

3. Click OK to save the change and close the Options screen. 
  
  

 

User Name used for Email Reminder Alerts 

  
This option allows you to enter the "From" email that will be used for the check out reminder emails. 

  
1. From the Main screen, select Administration > Options > Reminder Alerts > User Name used for Email 

Reminder Alerts. 
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2. Click in the text box and enter the user name. 
 

 

3. Click OK to save the change and close the Options screen. 
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Check for Software Updates 

By default, the software will check for updates to the application and notify you if a more recent version is available. You 
can then access the software updates website and download the latest version. This ensures you are always working 
with the most up-to-date version available to you. This feature is turned on by default. 
  
The software must be installed on a machine with Internet access to check for updates. 
  
You can turn off the automatic check and perform periodic manual checks, or leave the option on and perform a manual 
check, if desired. 
  
To Disable the Automatic Version Check Feature 
To Perform a Manual Check 

 
  

To Disable the Automatic Version Check Feature 

  
1. From the Main screen, select Administration > Options. The Options screen appears. 

2. Highlight the Automatic Check for Updates option and deselect the Yes check box.   
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3. Click OK to save your changes and to Close the Options screen. The option is now disabled. You can 
manually check for updates as needed. 

 
  

To Perform a Manual Check 

From the Main screen, click Help > Check for Updates.   
 

 
 
 
The system will automatically check for a newer version and notify you if one is available. This procedure can be 
performed at any time. 
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2.12.9 Setting Next Asset Tag Numbers 

The Asset Tag values created will be incremented by a value of one, beginning with the largest Asset Tag value that 
existed in the database when the option was first enabled. Beginning with an empty database, the first automatically 
assigned Asset Tag will be a value of "1". You can change the first automatically assigned Asset Tag on the Set Next 
Tag Value screen.   
  
Note:  You must have the Use Automatic Asset Tags feature enabled on the Options screen to use this feature. 
  

1. To access this screen from the Main screen, select Administration > Set Next Asset Tag Number. The Set 
Next Tag Value screen appears allowing you to select a start number. Below is an example of the Set Next 
Tag Value screen.   
 

   
2. Enter the number you want to begin with, then click OK. 
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2.12.10 Update License 

This function is used when you need to register the software to end your trial period. Remember that after the trial 
period you MUST register the software and complete this function in order to continue using the product. The login 
screen will remind you of how many days are left in your trial period each time you access the software. 
  

1. From the Main menu by clicking Administration > License Management. The Update License screen 
appears: 
 

 

2. Click on the link provided on the Update License screen and complete the requested information. You will 
need the Serial Number on the Update License screen. After you have completed the information, an 
Activation Code will be provided. You must enter the activation code on the Update License screen. 

3. After you have entered the Activation Code, click the OK button.   

4. A confirmation message will appear when you have successfully registered the product. 

5. You must exit the software and restart it after you have registered. 
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2.12.11 Device List 

  
The Device List displays all mobile devices onto which you have loaded MobileAsset along with the last time you 
uploaded data from each device. You can also view your mobile licenses from this screen or add additional mobile 
licenses. 

  
1. From the Main screen, click Administration > Device List. The Device List appears: 

 

 

2. The top of the screen lists any Wasp Devices, such as the HC1, you have connected. The bottom of the screen 
displays any non-Wasp devices.  
 
Note: Using a non-Wasp device with MobileAsset requires the purchase of an additional mobile license.  

3. To view all licenses associated with the software, click the Show Licenses button. The Show Licenses screen 
appears: 
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Click OK to close the screen. 

4. To add an additional mobile license, click the Add License button.  The Add Mobile License screen appears:

Enter the new mobile license, then click the OK button. You will return to the Device List screen. 

5. To delete a mobile device, highlight it in the list, then click the Delete button.
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2.12.12 Service Configuration 

Only users with Administration privileges will be able to see the Service Configuration option. 

The Service Configuration button on the Administration menu opens the Configuration Settings screen. This 
screen displays the information contained in the MobileAsset service configuration file. Admin users can make 
changes to the data on this screen, which will update the service configuration file and the weblink.x file as needed. 

1. From the Main screen, click Administration > Service Configuration.

The Configuration Settings screen appears:

2. Make changes as necessary on this screen. Below are brief descriptions of the fields available on this screen.

• Download Port - This is the port used to download MobileAsset to a mobile device via WiFi. The
default port is 10006. If you change the download port, the weblink.x file will automatically be updated
with the new port.

• License Manager Port - The port used by the license manager. The default port is 10007.

• License Manager Service Wait - Indicates how many seconds before the license manager attempts to
start the service again, in the event of a failed start. The default is 15 seconds.
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• Data Source - The location of the database. The default is <computer name>\WASPDBEXPRESS. 
• Integrated Security - If you have sufficient security privileges on the machine where the database 

server is located, select the Integrated Security checkbox. This allows you to access the database 
without having to enter your user name and password (your network user name and password will 
automatically be used). if you do not have sufficient security on the machine, leave this box unchecked. 

• User ID - The database user ID. The default user ID is AssetUser. 

• Password - The database password. The default password is Serial#1Serial#1). 

• Database Name - The name of the MobileAsset database. 

• Log File Size - Indicates how large the log file is allowed to get before a new one is created. The log file 
size is measured in bytes. Default log file size is 104857600. 

• Log File Count - Indicates how many past log files are kept before the oldest is deleted. The default 
number is 10. 

• Log Level - Indicates how much information is logged (1-10). The default level is 0 - no logging. A 
higher number will result in more information being logged. 

• User Logon Time Out - The period of inactivity before the user is logged out. 

• Base Address - The location of the service, including the listening port. the default location is 
http://<computer name>.<domain name>:10008/. 

3. Optionally click the Print button to print a barcode containing the Base Address. 

4. Click Save to save any changes. Click Exit to close the screen. 
  

252 



 
  

Wasp MobileAsset User Manual 

2.13 Creating/Editing/Printing Labels 

2.13.1 Selecting a Label Printer 

Before printing labels from the List screens or from the Labels menu, you must select a Label printer. 
  
To Select a Label Printer: 
  

1. To do this, click File > Setup Label Printer. The Select Label Printer screen appears: 
 

 

2. All printers currently connected to this computer will appear. Highlight the printer you want to use, then click the 
OK button. You can now begin printing labels. 
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The software allows you to select from several pre-built labels that can be printed the list screens or edited from the 
Labels menu. You can also create your own unique labels from the Labels menu. 
  
The following topics are covered in this section: 
  
Editing Labels 
Creating Custom Labels 
Browsing to Label File 

 
   

2.13.2 Editing Labels 

  
1. To edit labels, from the Main screen, click Labels. A list of available labels will appear. If you do not see all the 

label files shown here upon accessing the list, expand the menu by clicking the + in front of the Labels field. 
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2. Click on the label you would like to edit. The following screen will appear: 
 

 

3. Click Edit. Wasp Labeler will open with the selected label displayed. You can make changes as needed. Please 
see the Wasp Labeler online help for detailed instructions on editing labels.  To access the help, select Help > 
Contents from the Wasp Labeler toolbar. 
 
Click Save Changes to save any changes you have made to the label. These changes will be saved to the 
database. 
 
Click Discard Changes to discard your most recent changes (all changes since the last save). 
 
Click Reset to Default to revert the label back to its default settings. 
 
Note: When editing Mobile labels (Mobile Asset Tags, Mobile Check In Receipt, Mobile Check Out Receipt), the 
label will appear in a text editor in the ZPL language. The print script must be edited in ZPL. For information on 
the ZPL language, please refer to: 
http://www.zebra.com/id/zebra/na/en/documentlibrary/manuals/en/zpl_ii_programming2.File.tmp/45541L-
002_RA.pdf  

4. Click Close to close the Edit screen. 
 

2.13.3 Create Custom Labels 

1. To create custom labels, from the Main screen, click Labels. A list of available labels will appear.   

2. Select Launch Labeler to open Wasp Labeler without opening an existing .LABX file.   

3. Create your label as desired. Please see the Wasp Labeler online help for detailed instructions on creating 
labels. To access the help, select Help > Contents from the Wasp Labeler toolbar. 

  
Note: Save new labels created with Wasp Labeler, to the following folder: .\Labels under the folder where you installed 
Asset. If you are unsure where this is, just use the Windows Find (or Search) command to locate the folder containing 
the file Asset.exe, then save your .LAB files in the .\Labels folder beneath it. 
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2.13.4 Browse to  Label File 

  
You may have custom labels you have already created that you want to access. To do this: 
  

1. To browse to an existing label file (.LABX file), from the Main screen, click Labels. A list of available labels will 
appear.   

2. Select Browse to Label File. A browser window will open to C:\ProgramData\Wasp Barcode 
Technologies\MobileAsset\7.0.0.0\Labels where labels are stored. 

3. Navigate to the desired .LABX file and select it. The label will open in Wasp Labeler allowing you to edit or print 
it. 
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2.13.5 Printing Labels/Asset Tags from the List Screens 

MobileAsset allows you to print labels and asset tags directly from the List screens. The following List screens have 
label printing functionality: 
  
Asset List - Print Asset Tags 
  
Employee List - Print Employee Badges 
  
Location List - Print Location Labels 
  
Note:  You must select a label printer prior to printing tags from the List screens. To do this, see the topic Selecting a 
Label Printer. 
  
To Print Tags/Labels/Badges: 
  

1. With the desired List screen open (Asset, Employee or Location), highlight the listing you want to print. You can 
select multiple listings by holding down the Ctrl key on your keyboard while clicking on listings.   

2. Click the Print Tags/Labels button on the toolbar.   
 

 
 
 
The following screen appears: 
 

 

3. Enter the number of labels you want to print for each selected item. 

4. Click the OK button. 
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2.14 Reports 

2.14.1 Report Viewer 

The Report Viewer presents reports in an interactive environment that permits keyword searches, printing and export to 
Adobe Acrobat® Reader™ (.pdf), Microsoft® Excel (.xls), Microsoft® Word (.doc) or Rich Text Format (.rtf) files. 
  

1. Reports are accessed from the Main screen by clicking the Reports icon. A list of all reports will appear. 

2. Click on the desired report. The report will open in the Report Viewer. 

 

The Status Bar in the example above, displays the Current Page being viewed, the Total number of pages and the 
current Zoom Factor. 
  
In the example above, The Group Tree (shown below) displays Asset Tags. Clicking on an Asset Tag will display that 
Asset in the Report area to the right. 
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The Report Viewer Tool Bar (shown below) provides a variety of functions. These are described below in order. 
 

 
  
  
Export - allows you to save the report as your choice of any of the following formats: 
Adobe Acrobat® Reader™ (.pdf file) 
Microsoft® Excel (.xls file) 
Microsoft® Word (.doc file) 
or Rich Text Format (.rtf file) 
Print - launches the Print form. 
Refresh - updates the report with current data. 
Copy - allows you to save a copy of the report. 
Toggle Group Tree - Adds or removes the Group Tree panel. 
Arrow Buttons - allow you to navigate through pages of the reports: go to page 1, advance 1 page, go back one page, 
go to last page. 
Search - allows you to find all occurrences of a specified keyword with the displayed report. 
Zoom allows you to scale the Report display via a drop list of percentages. 
 
Filter opens the Report Filter Setup form. 

Depending on the number of transactions in your database, the Report you have selected, and the performance of your 
PC, The Report Viewer can remain blank for quite some time while it accesses the database and dynamically builds the 
report for display.   

  

259 



 
  

Wasp MobileAsset User Manual 

2.14.2 Report Filter 

You can filter reports in the software to only display selected information. This allows you to tailor reports to your 
specific needs. 
  

1. To filter a report, after you have generated the report, click the Filter   button on the Report Viewer's 
toolbar. A screen similar to the following will appear: 
 

 

2. Begin by removing the checkmark from the Do not filter this report checkbox. The fields on the screen will be 
enabled. 
 
Make selections from the drop down lists. You can select specific Fields, such as Asset Tag, Operators, such 
as equals, less than or greater than, and Value, the information contained in the fields. Then use the Add>> 
button to add filters to the Filter List. 
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One or more filters can be added before clicking the OK button to return to the Report Viewer where the data 
will now be limited by the filters in the Filter List. 

Once a Filter has been defined for a report, it will remain in effect for subsequent executions of that report. Each report 
can retain the last Filter Setup applied. Open the filter dialog and check the Do not filter this report checkbox if you 
want to see an unfiltered report. 
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2.15 Working with Multiple Companies 

Enterprise Version Only 
  
The Enterprise versions of MobileAsset allow you to create databases for multiple companies. This means that if you 
have two separate entities for which you want to maintain assets, you can install one instance of MobileAsset, then 
create two databases - one for each company. Remember that a database is the repository for all information about 
your company. Everything from your company's name and address, to your employee information, to your asset 
information is stored in the database. If you need to track asset information for two separate companies, you wouldn't 
want to group that information into one database, as it would be impossible to know to which company the asset 
belongs. Creating a database for each company allows you to enter sites, locations, customers, employees, assets, etc. 
that are specific to one company. In addition, each company has its own security so you can control who has access to 
a specific company. 
  
Below are the steps to setting up and working with multiple companies: 
  

1. Create Your Databases: To work with multiple companies, you will need to first create your databases using 
the Wasp Database Manager. You will need a database for each company.  For more information on the 
Wasp Database Manager, please refer to the Database Manager online help. To open the Database 
Manager, click on Start > All Programs > Wasp > MobileAsset > Database Manager. 

2. Log In to MobileAsset: After you setup your databases, when you log in to MobileAsset, the Select Company 
screen will appear first. Select which company you want work in. If you have access to more than one 
database, this screen will appear each time you open MobileAsset so you can specify which company you want 
to access. 

3. Set Up Your Databases: Create Sites, Locations, Asset Types, etc. for each company. Basically, you will need 
to follow the steps in Getting Started for each company you create. 
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2.15.1 Using the Select Company Screen 

This screen applies to the Enterprise version only. 
  
The Select Company screen appears after you log on to MobileAsset if you have created multiple databases and you 
have access to more than one database. 
Selecting a Company: 
  

1. After logging in to MobileAsset, you will see a screen similar to the following (if you have created multiple 
databases and you have access to more than one database).   
 
 
You will only see those companies to which you have been given access in Security. The first time you log in 
using the Admin login, you will see all companies. 
 

 
 
Highlight the company that you want to access. 

2. Click the Select button. MobileAsset will open with the desired company's information displayed. Note that the 
title bar at the top of the window indicates which company you currently have open. 
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2.16 Notes 

You can add notes to several fields in the software in order to associate any comments you may have with the record 
you are creating or editing.   
  

1. To add notes to a screen, click on the Add Notes button (not all screens/fields have this capability). The Add 
Note screen appears: 
 
 

 

2. Enter your notes in the text box, then click OK to save and exit. 
 Notes are appended to any notes previously added the record you are editing. 
  
 Notes cannot be edited or removed once posted.   
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2.17 Simple Find 

Find allows you to easily search for information within the database. 
  

1. To access the Find screen, from the Main screen, click Asset Management > Find > Simple Find. The Find 
screen appears: 
 

 

2. The Find screen contains three fields by which you can search for information: 

• Table is used to select the table(Information you enter into each field in MobileAsset is stored in a database 
"table" behind the scenes.  You can extract this information using the Export Wizard.) in the database you want 
to search. Make a selection from the drop down list. 

• Field is used to select the field in the listed table to be searched. All fields found in the selected table will 
appear in the drop down list. Make a selection from the drop down list. 

• Value is the information contained in the field (For example, Printer might be the value in the Asset Type field). 
Type in the information for which you are looking, or click the Magnifying Glass button to the right of the field to 
search all values contained in the selected Field. You can also scan a value into this field. 
 
For example, if you want to search for an asset description but cannot remember the exact description, select 
Asset in the Table field and Asset Description in the Field field, then select the Magnifying Glass button. A 
screen will appear displaying all values in the Description field (see example below): 
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Highlight the desired listing and click Select. The Find screen will populate with your selection as shown below: 
 

 
 
 
Enabling the Whole Word Only option will search the selected table based upon the entire string in the value 
field excluding partial matches. If this checkbox is not selected, the system will return partial matches, meaning if 
you enter Printer in the Value field, the search would return Printer, Print, Printers, Printed, etc. 
 
Enabling the Find All option disables the Field and Value fields and will return all of the records from the table 
selected in Search. 
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3. Click the Find button to start the search process. When complete, a list will be displayed showing all the 
records that match your criteria. 

• All searches are case insensitive. 
• Your last Find criteria are saved and will automatically be loaded the next time you access Find. 

  
  
Examples: 
  
For these examples, assume that the Customer table is made up of three records containing one field, called 
FirstName. The values in this field are Fred, Frederick, and Sam. 
  
Example Table Field Value Whole 

Word Only 
Option 

Find 
All 

Option 

Search 
Result 

1 Customer FirstName Fred Off Off 2 records: 
Fred; 

Frederick 
2 Customer FirstName Fred On Off 1 record:   

Fred 
3 Customer FirstName Mike Off On 3 records: 

Fred; 
Frederick; 

Sam 
  
Notes: 
  

• Advanced Find can be selected from the Asset Management tree also. It allows you to use complex search 
criteria. 

• Keep in mind that your numbers are stored with up to four decimal places. If you set the Decimal Places option 
to 1, but your numbers contain 4 decimal places, it will be helpful to search using all the decimal places. For 
example, if you are searching for the numbers: 4.123, 4.134, 4.148 but the Decimal Places option is set to one 
decimal place showing, the Asset List will displays these numbers as 4.1, 4.1, 4.1.  If you are attempting to use 
the Find feature to search for a specific number, you can type in all decimal places, 4.123, for example to make 
your search easier. However, when they go into the Find, they will be able to see all the decimal places. 
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2.18 Advanced Find 

The Advanced Find screen allows you to search for information in the database using a variety of criteria. You can use 
these criteria options to narrow your search. 
 

1. Access the Advanced Find screen from the Main screen by selecting Asset Management > Find > 
Advanced Find. Below is an example of the Advanced Find screen. 
 

 

2. The Advanced Find screen consists of seven fields that allow you to select criteria to narrow your search. The 
Filter Expression panel displays the "filter" as you enter information in the criteria fields. The filter is simply the 
criteria you have selected. For example, if you select the following information: 
 
Table: Asset 
Field: Asset Tag 
Operator: = 
Value: 198 
 
then the Filter Expression field will display this information and the system will search for Assets with the asset 
tag number 198. 
 
Below are descriptions of each of the criteria fields: 

Table - used to select the table(Information you enter into each field in MobileAsset is stored in a database 
"table" behind the scenes.  You can extract this information using the Export Wizard.) you want to search within 
the database. 
Parenthesis - (open and close) used to control the order in which criteria will be processed. The inner most pair 
of parentheses in any filter expression are evaluated first.   
Field - used to select the field you want to search within the specified table. 
Operator - a comparison operator used to evaluate an expression. 

Comparison 
Operator 

Meaning 

= equal 
<> not equal 
>= greater than or 

equal 
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> greater than 
<= less than or equal 
< less than 

Like is similar to value 
Not Like is not similar to 

value 
Is Null no value 

Is Not Null any value 
 
Like and Not Like are used for text pattern matching. They can only be used with plain text fields, not with dates. 
The following characters, used within the text value, have a special meaning for the Like and Not Like operators: 
  

LIKE 
Operator 

Meaning Examples 

_ 
 (underscore) 

matches 
any single 
character 

LIKE '_-
inch' 
   matches 
'2-inch', '3-
inch', etc. 

% matches 
zero or 
more 

characters 
of any 
value 

LIKE 'Eric 
W%' 
matches 
'Eric 
White', 
'Eric 
Williams', 
etc. 

\ Escapes 
the 

special 
characters 

(gives 
them their 

normal 
meaning) 

LIKE '\%' 
  matches 
'%' 
 LIKE '\\' 
matches a 
single '\' 

 
Value - the information for which you are searching. (This can include special characters for the Like or Not Like 
operators). 
Logical - a Boolean operator that combines one or more filter expressions into a single logical group: 

Boolean 
Operator 

Meaning 

AND gives you the 
intersection of two 

conditions 
OR gives you the union of 

two conditions 
  

3. Enter the desired values for the seven Advanced Find fields to construct a filter fragment, or part of the Filter 
Expression. 

4. Click the Add button after building each filter expression to add it to the Filter Expression list. 
 
The Move Up and Move Down buttons allow you to move a filter fragment toward the top or toward the bottom 
of the list, respectively. To reposition a filter fragment in the Filter Expression panel, click on it, then click either 
the Move Up or Move Down button. 
 

269 



 
  

Wasp MobileAsset User Manual 

You can edit a filter fragment by first selecting the fragment in the Filter Expression list. The values of the filter 
fragment populate the seven input fields. Update any of these fields, then click Replace to update the selected 
filter fragment in the Filter Expression list. 
 
Click the Check button to check the syntax of the Filter Expression. 

5. Click the Find button to start the search process. When complete, a list will be displayed showing all the 
records that match your criteria. 

Notes: 
• Searches are not case sensitive. 
• To search for a specific date, build your filter expression to include a time range of 12:00am to 11:59pm for the 

given date. For example, the filter expression Date >= 12/25/02 12:00am to 12/25/02 11:59pm will return all 
records that have the date 12/25/02. 

• Keep in mind that your numbers are stored with up to four decimal places. If you set the Decimal Places option 
to 1, but your numbers contain 4 decimal places, it will be helpful to search using all the decimal places.  For 
example, if you are searching for the numbers: 4.123, 4.134, 4.148 but the Decimal Places option is set to one 
decimal place showing, the Asset List will displays these numbers as 4.1, 4.1, 4.1.  If you are attempting to use 
the Find feature to search for a specific number, you can type in all decimal places, 4.123, for example to make 
your search easier. However, when they go into the Find, they will be able to see all the decimal places. 

• A Simplified search can be conducted using the Simple Find screen. 
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2.19 Working with Alerts 

Alerts are not available in the Standard edition of MobileAsset. 
  
MobileAsset will alert you if there are overdue checked-out assets, contracts/licenses that have expired and/or 
maintenance that is past due.   
  
  
You can quickly check if any of these items are past due by following the instructions below: 
  

1. From the Main screen, click Alerts. A drop down list will notify you of any overdue items as shown below: 
 

 
2. Click on a listing to be taken to a list of the items that are past due. For example, to see what asset is checked-

out and past due, click Assets Past Due. The Asset List will appear displaying the overdue asset. You can 
then follow up as needed to make sure the asset is not lost, etc.  
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Chapter 3 - Mobile Device Operation 

3.1 Troubleshooting your Wireless Connection 

  
Depending on how your network is configured, you may receive a "Page not found" message when trying to access the 
MobileAsset download page. This can occur if: 
  

• the PC name is not correct,  
• there is an issue with the DNS servers returning the correct IP address, or 
• the network is not routing the DNS request correctly.  

Please check with your IT department for a resolution. If the issue cannot be resolved you can try to update the 
weblink.x file with the computer's IP address (instructions are provided below). If the computer is on DHCP please have 
your IT department reserve the address so that it will not change in the future. 
  

3.1.1 Update the weblink.x File 

  
1. Verify your computer's IP address using the method described in the section Verify IP Address. 

2. From Windows Explorer, navigate to the location where you installed MobileAsset (the default location is 
C:\Program Files (x86)\Wasp Technologies\MobileAsset). 

3. In the MobileAsset folder, select Services > Downloads. You will see a file named weblink.x. 
 
 

 

4. Right click on the file weblink.x, then select Open With. 

5. From the Open With menu, choose WordPad or another word processing software. The weblink.x file will 
open displaying your FQDN entered during installation followed by the port number. 
 

273 



 
  

Wasp MobileAsset User Manual 

 

 

6. Edit the FQDN to be the IP address.  
 
It should read: http://<IPADDRESS>:10006/Downloads/ 
 
So, for example, if your IP address is 10.1.1.10, it would read as follows: http://10.1.1.10:10006/Downloads/, 
as shown below: 
 
 

 
 

3.1.2 Verify IP Address 

  
1. Select the Start (Windows icon) key on your keyboard, then enter CMD in the search field. CMD.exe will 

appear in the Programs section. (In Win8, select the CMD icon from the toolbar.) 
2. Select cmd.exe from the Programs section of the Start menu. The CMD screen appears. 
3. On the CMD screen, enter IPCONFIG/all at the prompt. Configuration information for your machine will 

appear on the screen as shown below: 
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3.2 Mobile Error 

The Mobile Error option opens the Pending Additions screen. Pending Additions allows you to select data for 
acceptance into the MobileAsset database (on the PC) and to correct errors on data before it is entered into the 
database. This data has previously been collected from one or more mobile devices via synchronization. 

  
1. To access this function, from the Main screen, click Mobility > Mobile Errors. 

2. The Pending Additions screen appears.  
 

 

3. Any new records that have errors which need to be addressed are listed on the screen.  
 
You can accept or reject each of the new additions by clicking the check box or double-clicking the record itself to 
toggle its selection status (between  accepted and  not accepted). If the new data was created in error, you 
can also assign an existing value to take its place: 
 
The New Records toolbar contains the following functions: 

 Select all transactions in the list for Acceptance. 

 De-Select transactions in the list. 

 Assign an existing value instead of creating a new record 
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4. Click Next > to continue to the Transactions screen. This screen displays all transactions (moves, check-ins, 
check-outs, audits) 
 

 

5. Just as with the New Records screen, mark the transactions you wish to accept by clicking the checkbox or 
double-clicking the record itself.  Each transaction completed on the mobile device is listed. Any  errors or  
warnings are marked and you are allowed to accept or reject transactions or make changes to fix errors. 
 
The Transactions toolbar has the following functions: 

 Select all transactions in the list for Acceptance. 

 De-select transactions in the list. 

 Display Error (or Warning) associated with the highlighted record. 
The Error   or Warning   message associated with the selected transaction will be displayed. Click 
Close to return to the Pending Transaction screen. 

 Records that have been previously processed will be marked with an Error   flag.   

 The Display Error toolbar button will be   grayed-out when no record with an Error  or Warning  
symbol is highlighted. 
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 Edit Transactions allows you to make changes to the values specified at the mobile device. The following 
example shows an Edit for the above Move transaction: 

 

 Click OK to save any changes or Cancel to return to the Pending Transactions screen without saving 
changes. 

7. Click Next > after you have selected which transactions to accept. The system will post the accepted transactions 
to the MobileAsset database: 
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8. Click Finish to close the Process Mobile Device Data screen. 
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3.3 Specify Mobile Device Data Filters 

The Specify Mobile Device Data Filters screen allows you to specify filter options that determine which database 
records will be used when the database is downloaded to the mobile device (WMD, iOS or Android) during a Full Sync. 
  
Filtering your data can make the time it takes to transfer data to the mobile device considerably less. 

New Filter 
Duplicate Filter 
Delete Filter 
  

 

3.3.1 New Filter 

  
1. To access this screen, from the Main screen select Mobility > Specify Mobile Device Data Filters. The 

following screen appears: 
 
 

 

279 



 
  

Wasp MobileAsset User Manual 

2. Click the New button in the bottom,right corner of the screen. The fields become enabled: 
 

 

3. Enter a name for this filter in the Filter Name field. 
 
To filter any of the record types listed, make a selection from the Site, Location, Asset Type, Category and/or 
Department drop down lists. You can make multiple selections for each record type. Click the down arrow in 
the list, then select Multiple Selections to access the List screen. 
 

 
 
 
The List screen for the record type appears. In this example, the Site List screen would appear: 
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Choose one or more Sites from the list by highlighting them and clicking the Select button. The Mobile Data 
Filters screen will display Multiple Selections in the field if you choose more than one item from the list. The 
number of assets matching your filter criteria will display to the right of the selection fields. You can preview the 
assets by clicking the Preview button.  The Asset List appears displaying the filtered assets 
 

 
 

4. Continuing making selections as needed in the asset section. Make your selections from the drop down lists. 

5. When Minimally Required is selected for Departments or Vendors, only those Departments or Vendors that 
are associated with the selected Assets are added to the database you are creating. 

6. When you are satisfied with the filter selections, click Save. The new filter will be added to the Filters list. 
 
 

 

5. Click Close to close the Mobile Data Filters screen when you are done.   
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3.3.2 Duplicate a Filter 

  
To duplicate a filter, highlight a filter in the Filters list, then click the Duplicate button. 

 
  
Another filter listing will appear in the list with the name <filter name> - copy. 
 

 
  
Make any changes as needed, then click the Save button. 
  

 

3.3.3 Delete Filter 

  
To delete a filter, highlight a filter in the Filters list, then click the Delete button. 
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A confirmation screen will appear. 
  

 
  
Click Yes on the confirmation screen to delete the filter. 
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3.4 Windows Mobile/CE Operation 

3.4.1 Windows Mobile / CE Similarity 

If you are using a Windows CE device, please refer to the Windows Mobile/CE help topics. 
  
MobileAsset functions identically on devices using Microsoft's Mobile 2003® or Windows CE® (Compact Edition) 
Operating Systems. There is one cosmetic difference to note: The Menu Bar is located at the top of the screen on 
Windows CE devices. Many of  the images shown in this Help file were taken from an emulation of the HC1, where the 
Menu Bar is located at the bottom of the screen.   
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3.4.2 Professional and Enterprise Editions - Installing MobileAsset on Windows Mobile/CE 

Note: Pro and Enterprise users can also install using the method described in the topic Standard Edition - Installing 
MobileAsset on the Mobile Device. Keep in mind that downloading and installing using the method for the Standard 
edition requires the mobile device to be physically connected to the computer. 

  
The instructions below pertain to the Professional and Enterprise Editions of MobileAsset. Standard Edition users 
should refer to the topic Standard Edition - Installing MobileAsset on the Mobile Device. 
  
  
  
Downloading and Installing MobileAsset (Wireless): 
  

1. Download the MobileAsset Install Files - To download the files, follow the instructions below: 

a. On the mobile device, access Internet Explorer. In the URL field, type in http://<your IP 
address>:10006. The download screen will appear providing instructions and link to the 
Configuration Files and the Installation Program.  
 
 
The Configuration File and the Installer must be downloaded to the same folder on the mobile 
device. By default these are downloaded to My Documents. If you change the default download 
location make sure you are still downloading to the same folder. 
 
 
 
Below is an example of the download screen: 
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Instructions on obtaining your server's IP address: 
  

1. On the server machine, select the Start (Windows icon) key on your keyboard. CMD.exe will 
appear in the Programs section. (In Win8 select the CMD icon from the toolbar. 
 
2. Select cmd.exe from the Programs section of the Start menu. The CMD screen appears. 
 
3. On the CMD screen, enter IPCONFIG/all at the prompt. Configuration information for the 
machine will appear on the screen. 
 
The IP address is the Host Name. 

b. Tap on the Configuration Files link to download the files. After you click the link, a screen may appear 
indicating the file will be opened after download. Make sure the Open file after download checkbox is 
UNCHECKED (you do not want to automatically open the file after download). 
 
 

 
 
 
Tap the Yes button at the bottom of the screen to download the files. 
 
 
 
You will be returned to the download page seen in step 2. 
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c. Tap the Download Installer link. The following screen appears: 

 
 
 

 
 
 
 
Tap the Yes button at the bottom of the screen. You will be returned to the Download screen seen in 
Step 1. 
 
 
Tap the circle icon in the bottom, left corner of the screen to close the Download screen. 
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2. Install Programs - After downloading to the mobile device, you can install the MobileAsset program. 

a. The Installer may automatically start. If it does not, browse to My Documents and click 
WaspMobileAppInstaller.exe to run it. 
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b. After the installer opens, click Start. 
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c. A screen will appear asking if you want to install to the device or Flash Storage. Do not install to 
Flash storage. Select Device, then tap the Install button. 
 
 

 
 

d. A confirmation screen will appear as the files are successfully installed. 
 
 
 

 
 
 
Click OK to continue. 
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e. Repeat steps c and d as needed to complete the install. Watch your mobile device screen for 
prompts. 
 

f. MobileAsset will automatically open at the Log in screen. 
 

3. Log in to MobileAsset -  
 
 
Professional and Enterprise Edition: The first time you log in to MobileAsset you will need to make sure the 
Service URL is correct, enter your device name, user name and password. Below is an example of the Log in 
screen. When you are done entering information, tap OK. 
 
 

 

• Service URL - This field auto populates based on the IP or FQDN (Fully Qualified Domain Name) 
detected when you installed MobileAsset on your PC. The Service URL is the IP or FQDN followed by 
the port number for MobileAsset, usually 10008. The Service URL is pinned by default. If you need to 
modify the Service URL, you can unpin it by tapping on the grey field name. This will unpin the field 
allowing you to edit the URL information. 

• Device Name - Enter a unique name here for this mobile device. 
 
 
If this device has previously been setup on MobileAsset with a different Device Name, a message will 
appear. Click Yes to use the previous name, click No to change the device name. 

• User Name - Enter your MobileAsset user name. 

• Password - Enter your MobileAsset password. 
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4. Next the following message appears. 
 
 

 
 
 
This message allows you to change the default pathway for the database, if needed. The default pathway is 
Program Files/MobileAsset/database. Tap Yes to accept the default path. If you need to change it, because 
there is not enough room on your mobile device, for example, tap No. The following Browse screen appears: 
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Browse to a new location, then tap Select. 

5. Specify Filters - You can filter the data that is sent from the MobileAsset database on this screen. Select the 
filter, or no filter, then tap Download. You can change the filter later, if needed, on the Tools screen.  
 
 
Note: Filters are setup from Mobility > Specify Mobile Device Data Filters screen on the PC. 

6. Time Discrepancy - This screen may appear if MobileAsset detects a discrepancy between the time set on the 
MobileAsset server and the time set on this device. You should adjust the time on your device to match the 
server before you start performing transactions on your device. Click OK on this screen to close it. 
 
 
The Mobile Asset Main Menu will appear. 

7.  Upload Mobile Device to PC -  
 
 
Professional and Enterprise Edition with a Wireless Connection:  
 
 
The mobile device transmits data to the database in almost real time whenever you are connected wirelessly 
and have the Auto Upload option turned on. When you leave a transaction and return to the Main Menu, any 
new data will be uploaded to the database. 
 
 
Professional and Enterprise Edition with No Wireless Connection: 
 
 
If your device does not have wifi capabilities, you can perform transactions as usual on the mobile device, then 
connect your device to your computer (the computer must have ActiveSync installed on it) and initiate a Manual 
Upload to the database. 
 
 

Notes: If you need to download the MobileAsset database from the PC again, you can do so from the Tools menu. 

If at any time you accidentally close MobileAsset on the mobile device, wait 5-10 seconds before trying to reopen 
it to avoid getting an error message. 
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3.4.3 Standard Edition - Installing MobileAsset on the Mobile Device 

  
1. Connect your MobileDevice to the PC which has MobileAsset installed on it. (Microsoft ActiveSync must be 

installed on this PC.) 

2. In MobileAsset, select Mobility > Windows Mobile/CE Setup. 
 
 

 
 

3. If this application detects that MobileAsset is not yet installed on the mobile device, the following message 
appears: 
 
 
 

 
 
Click OK on this screen to proceed. 
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4. When the installer file is copied to your mobile device, the following screen appears: 
 
 
 

 
 
Click OK on this screen to close it. 

5. On your mobile device, you should see this screen: 
 
 

 
 
 
Click the Start button. 
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6. A screen will appear asking if you want to install to the device or Flash Storage. Do not install to Flash 
storage. Select Device, then tap the Install button. 
 
 

 
 

7. A confirmation screen will appear as the files are successfully installed. 
 
 
 

 
 
 
Click OK to continue. 
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8. Repeat steps 6 and 7 as needed to complete the install. Watch your mobile device screen for prompts. 
 
 
Log in to MobileAsset -  
 
 
The first time you log in to MobileAsset the Service URL will appear. You should not change this address. Enter 
your device name and your MobileAsset user name and password. Below is an example of the Log in screen. 
When you are done entering information, tap OK. 
 
 

 

• Service URL - This field auto populates based on the IP or FQDN (Fully Qualified Domain Name) 
detected when you installed MobileAsset on your PC. The Service URL is the IP or FQDN followed by 
the port number for MobileAsset, usually 10008. The Service URL is pinned by default. If you need to 
modify the Service URL, you can unpin it by tapping on the grey field name. This will unpin the field 
allowing you to edit the URL information. Editing the URL is not recommended unless told to do so by 
Wasp Support. 

• Device Name - Enter a unique name here for this mobile device. 
 
 
If this device has previously been setup on MobileAsset with a different Device Name, a message will 
appear. Click Yes to use the previous name, click No to change the device name. 

• User Name - Enter your MobileAsset user name. 

• Password - Enter your MobileAsset password. 
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9. Next the following message appears. 
 
 

 
 
 
This message allows you to change the default pathway for the database, if needed. The default pathway is 
Program Files/MobileAsset/database. Tap Yes to accept the default path. If you need to change it, because 
there is not enough room on your mobile device, for example, tap No. The following Browse screen appears: 
 
 

 
 
 
Browse to a new location, then tap Select. 

10. Time Discrepancy - This screen may appear if MobileAsset detects a discrepancy between the time set on the 
MobileAsset server and the time set on this device. You should adjust the time on your device to match the 
server before you start performing transactions on your device. Click OK on this screen to close it. 
 
 
The Mobile Asset Main Menu will appear. 
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11. Upload Mobile Device to PC -  
 
 
Perform transactions as usual on the mobile device, then connect your device to your computer (your computer 
must have ActiveSync installed on it) and initiate a Manual Upload to the database. 
 

12. Notes: If you need to download the MobileAsset database from the PC again, you can do so from the Tools 
menu. 

13. If at any time you accidentally close MobileAsset on the mobile device, wait 5-10 seconds before trying to 
reopen it to avoid getting an error message. 
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3.4.4 Using the Windows Mobile/CE Device 

Windows Mobile CE/Interface 

Once Setup has been completed, the device will be ready for conducting asset management operations: 
  

Tap the Windows Mobile/CE icon or use Start > Programs > Asset to start the application. 
  
  
When the Asset application has finished loading, you will be presented with the Log On prompt.   
  
Both fields must be supplied with valid values before tapping OK. 
  
The User Name field is not case sensitive. The Password field is case sensitive.   
 

• Asterisks will be displayed as you type the Password. 
• MobileAsset opens with the following default settings on the PC. These same values will be valid on the 

Windows Mobile/CE device if you have not yet created any additional users on the PC: 
• User Name:  Admin   
• Password:    (blank) 
• The Asset Admin account, or any other account with the Administration Privilege, can use the Manage Users 

screen (on the PC) to add Users and set their privileges, and reset their passwords. 
  
Tap OK after entering this information. The MobileAsset main menu will be displayed: 
 
Professional and Enterprise Editions: 
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Standard Edition: 
 
 

 
  
  

• References will be made in this document to the Windows Mobile/CE device's built-in bar code scanner. Not all 
devices have an integrated bar code scanner and although a scanner can significantly increase data entry 
speed and accuracy, it is not required. 
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3.4.5 Windows Mobile/CE New Asset 

The New Asset transaction is used to create a new asset. 
  
Adding New Assets 
Searching for Sites, Locations and/or Asset Types 
Creating New Asset Types 
  

Adding New Assets 

1. To create a new asset, from the Main menu, tap New Asset. The New Asset screen appears: 
 
 

 
 
 
The Linking tab will only appear if you are using the Professional or Enterprise editions of MobileAsset. 
 
 
Note: If you are using the HC1 device and want to show the keyboard for data entry, tap the very bottom of the 
screen. 

2. Enter the Site, Location, Asset Tag and Asset Type and, optionally, a Serial #, then tap OK to save the 
transaction and reset the screen. The Description field will display the description for the selected asset. 
 
 
Asset Tag: Asset Tags must be unique across all Sites and Locations. A particular value can occur only once 
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in the MobileAsset database. 
 
 
Sites: You must enter an exiting site in the Site field.  New Sites cannot be created on the mobile device. They 
must be created on the PC prior to creating the Windows Mobile/CE device database.    
 
 
A Note on Sites: If only one site exists in the Windows Mobile/CE device's database, the Site field will default 
to that site. If the database contains multiple sites, the Site field will be blank for the first transaction after 
starting MobileAsset and all subsequent transactions will default to the last Site used. 
 
 
If the Site you need is not in the Windows Mobile/CE device's Asset database, tap Cancel (and then Close) to 
exit the New Asset function completely. To add a new site to the database, you will have to first create the new 
site on the PC. 
 
 
When you select an Asset Type, the following screen will display: 
 
 

 
 
 
Select Yes to populate fields with information from the Asset Type. For example, if Check Out Length 
information is entered for the Asset Type, it will appear on the Type tab. 
 
 
If you have enabled the Edit Inherited Asset Type Data option on the Options screen, you can make changes 
to the information that is populated from the Asset Type. If this option is not enabled, these fields will be 
disabled and you will not be able to make changes. These fields include the Manufacturer, Model, Vendor 
Number, Check Out Length, Check Out Lead Time and Reminder Lead Time. Any changes made to these 
fields apply to the current asset only. 
 
 
If you do not want to incorporate information from the Asset Type, other than the Asset Type number and 
Description, click No. 
 
 
Pinning allows you to lock the value entered in a field for use as a constant in subsequent iterations of the 
same transaction. In the following example, values for Site and Location were selected, then both fields were 
pinned by tapping their labels. Note that they now appear in gray boxes and the search symbol is no longer 
displayed to the right of the input field.  
 
 
 
To pin a field, click on the field label. Pinned fields appear grey. In the example below, the Asset Type and 
Description fields are pinned. 
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Input for the pinned fields is now locked and multiple Add New Asset transactions can be performed by 
supplying only the Asset Tag, Asset Type, and Serial # if necessary. Any input field can be pinned to suit the 
data entry task at hand (where permitted). 
 
 
 
See the Definitions topic for further descriptions of Site, Location, Asset Tag, Asset Type and Serial Number. 
 
 
New Locations or Asset Types can be created at will by entering the new value directly on the screen shown 
above.  A popup will ask if you want to create the new value.  Tap Yes to confirm.  Tap No if you do not want to 
create the new Location or Asset Type.  See Creating New Asset Types later in this topic for further 
information on adding Asset Types.   
 
 
  

3. If you are using the Professional or Enterprise editions of MobileAsset you can create links to other assets 
by tapping the Linking tab at the bottom of the screen. 
 
 
Asset Linking allows you to link two or more assets together to form one new asset. For example, the asset 
Mary's Computer may consist of 4 separate assets - CPU, Keyboard, Mouse and Monitor.  These four individual 
assets are linked together to form one new asset, Mary's Computer. For a complete definition of Asset Linking 
and an example, please refer to the Definitions topic. 
 
 
Below is an example of the Linking tab: 
 

304 



 
  

Wasp MobileAsset User Manual 

 

 
 
 
The Asset Tag field will display the tag you entered on the General tab. 
 
 
Click the Transact as Whole checkbox if you want functions (check in, check out, move, audit,etc.) to be 
performed on this group as a whole on the PC.    
 
 
 
Parent Asset: If this asset is to be the Parent, or top-level asset, of this group, you can leave the Parent field 
blank. If you want to give this asset a parent (for instance, if this asset is a monitor and you want to link it to the 
asset Mary's Computer), enter an asset here or click the magnifying glass icon button to search for an asset. 
 
 
The asset can have a parent assigned to it and be a parent (have child assets assigned to it). 
 
 
Child Assets: To associate child assets with this asset (the current asset will be the "parent" of these assets), tap 
the Link button. A screen similar to the one below will appear: 
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Highlight an asset and tap Link, or type in a value and tap Find to search for an asset. After you tap Link, the 
selected asset will appear on the Linking tab as shown below: 
 
 

 
 
 
In this example, Asset 4001 is a child of the current asset. 
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You can unlink an asset by highlighting it in the Child Assets window and tapping Unlink. 
 
A Note about the Transact as Whole Flag: In the example above, the Transact as whole flag is checked; 
therefore, any functions (check-in, check-out, audit, move, etc.) will be performed as a whole for the group.  This 
flag is driven from the top down, meaning the selection made for the parent asset will override the selection for a 
child asset.  If you want to move only one asset that is a child of this asset, you will need to deselect this 
checkbox.  Deselecting it on the Edit Asset > Asset Linking tab for the child asset will not override the selection 
made for this asset, and this group would still be moved as a whole..  Similarly,  if the Transact as whole flag 
was NOT selected on this tab, but it IS selected for the parent of this asset, the group would still be transacted as 
a whole because the selections made for the parent of this asset would take precedence.   

4. You can optionally take a picture of this asset using the Picture tab. To do this, tap Picture at the bottom of the 
screen. The Picture tab appears. 
 
 

 
 
 
Tap on the Camera icon in the center of the screen, then select Camera or Browse. 
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To take a new picture, tap Camera. This will activate your mobile device's camera feature. Follow the usual 
procedure for capturing an image using your device. Please refer to your device manual for information specific 
to the device. Keep in mind that after you select the ENTER key to take the picture, you must tap OK on the 
device screen to accept it. Images captured via MobileAsset are not saved to your mobile device. 
 
 
To browse for an existing picture, tap Browse. Navigate to the image on your camera and select it. If your 
device is connected to the PC, you can browse all images that are already in MobileAsset on the PC as well. 
The selected image will appear on the Picture tab. 
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Click the Camera icon again to take or retrieve another picture. You can capture as many images as allowed in 
Options > Maximum Pictures Captured. 
 
 
If you have captured more than one image for an asset, you can scroll through the images using the arrow 
icons. 
 
 

 
 
 
You can delete the image by clicking the Trash icon. 

5. The Custom tab contains any Custom fields create for the asset on the PC. These fields may be required, 
depending on the settings on the PC.  
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6. Below is an example of a Custom tab: 
 
 

 
 
 
To add custom text, highlight a field in the list, then type in a value. For dates, you can click the down arrow and 
choose a date from the calendar. 
 
There may be dynamic custom fields that appear here as well. These are create on the Asset Type using the 
PC application. For more information on Dynamic Custom fields, please refer to the help topic Using Dynamic 
Custom Fields. 
 

7. The Type tab contains information about the Asset Type such as depreciation and check out length. If the Edit 
Inherited Asset Type Data option is turned on, some of these fields may not be editable. This tab is divided 
into two sections: Type and Check Out. 
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8. The Type section is shown below: 
 

 
 
 
You can search for or add new Manufacturers or Vendors if needed. 
 
 
The Check Out section is shown below: 
 
 

 
 
 
You can optionally enter a Check Out Length and Lead Time for this asset. 
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9. To complete the new asset, tap the green arrow icon at the bottom of the screen button.

Note: While you are creating new assets, you can view/print a list of the new assets you have created this session. To 
do this, click the Summary button at the bottom of the screen. 

The Summary screen appears: 

To print any labels appearing on the Summary screen, click the Print icon at the bottom, left of the screen.  

Searching for Sites, Locations and/or Asset Types 

1. If you want to search for an existing Site, Location, Asset Type, Department, etc., tap the Magnifying Glass icon
next to the field you want to search. If the field does not have a Magnifying Glass icon next to it, it is not a
searchable field.

A list of Sites, Locations, Asset Types, etc. appears from which you can select a value. The following screen 
displays a search for an Asset Type: 
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2. Select an Asset Type from the drop down list or enter a value for Asset Type and tap the Magnifying Glass 
button to search for an existing Asset Type. You can enter a partial value and the system will return all Asset 
Types that begin with those characters. 
 
 
You can also search for an Asset Type by serial number. This is useful if your company uses full or partial serial 
numbers as Asset Tags.   

3. Highlight the desired listing, then tap OK to return to the New Asset screen. Click New to create a new Asset 
Type. 

The Search Asset Type and Search Site screens behave identically to the Search Location screen with the exception 
of the New button.  You cannot create new sites on the mobile device. 

 

Creating a New Asset Type 

You can create a new Asset Type by typing in an unknown value in the Asset Type field or by tapping Green Plus 
icon on the Search Asset Type screen.   
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Below is an example of the New Asset Type screen: 
 
 

 

The following fields can be completed on this screen: 

• Asset Type  - The asset type is a category for assets and is required to create new asset types. Assets are 
assigned to a specific asset type. For instance, you may have an Asset Type of Label Printers that defines the 
manufacturer, size specs, etc. of this particular type of printer. Then specific printers of the same type are 
assigned to the Label Printers asset type.  

• Asset Type Description - Enter a description for this Asset Type. 

• Depr Class and Category are optional fields. A selection can be made from any previously defined values 
found in the drop down lists or you can create a new Class or Category by tapping <New> in the drop down 
menu.   
 
 
MobileAsset can perform depreciation calculations at the PC for any Depreciation Class assigned to asset types 
for which that option has been enabled. The Windows Mobile/CE device does not distinguish those 
Depreciation Classes for which depreciation has been enabled from those where it has not. If you define a new 
Depreciation Class on the Windows Mobile/CE for which depreciation should be calculated, the option will have 
to be enabled for that Depreciation Class. Click here for information on enabling depreciation. 
 

• Manufacturer - Scan a manufacturer or tap the Magnifying Glass icon to search manufacturers. You can create 
a new manufacturer by clicking the green plus sign icon at the bottom of the search screen. 
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• Vendor - Scan a manufacturer or tap the Magnifying Glass icon to search manufacturers. You can create a new 
manufacturer by clicking the green plus sign icon at the bottom of the search screen. 

• CO Length  - The check out default number of Days the asset type may remain checked out before it is 
overdue. When a specific Asset Tag (having this Asset Type) is actually Checked Out , a specific Due Date and 
Due Time can be specified (overriding the default duration you specified here.) 

• Lead Time - Indicates how long after an asset is received, checked in, etc. before it is available. The lead time 
allows time for recalibration, cleaning, etc. 

Click the green check mark icon to save the new Asset Type. 
  
  

  

315 



 
  

Wasp MobileAsset User Manual 

3.4.6 Windows Mobile/CE Edit 

The Edit Asset transaction is used to modify an existing Asset. 

1. To edit an asset, from the Main menu, tap Edit.  The Edit screen appears: 
 
 
 

 

2. You can select an asset to edit by locating it by Asset Tag or by Site and Location. If you already know the 
Asset Tag value or want to scan it, tap the Asset Tag check box. If you don't know the Asset Tag and want to 
specify a Site and Location to search, tap the Site and Location check box. By default, the screen will open 
with Asset Tag selected.  
 
 
Click the Magnifying Glass icon to access the Asset Tag search screen, shown below: 
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You can search by full or partial Asset Tag or Serial Number. 
 
 
After you see the asset you want to edit in the list (or have manually entered the Asset Tag or scanned it), 
highlight it, then click the Pencil icon. The Edit Asset screen will appear populated with the selected asset's 
information. 
 
 

 
 

3. Only the Asset Tag, Asset Type, Site, Location, Serial #, Department and Condition can be edited on the 
General tab. Tap an Magnifying Glass icon to search for an Asset Type, Site, or Location. 
 
 
Tap any of the tabs to edit information on those tabs. For detailed information about each tab, please refer to 
the topic Windows Mobile/CE Add New. 
 
 
Note: If you are using the HC1 device and want to show the keyboard for data entry, click the very bottom of 
the screen. 
 

4. Tap the green check mark icon when you have made your changes. 
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3.4.7 Windows Mobile/CE Move 

The Move Asset transaction is used to change the location of an Asset. 
  

1. To move an asset, from the Main menu, tap Move. The Move screen will appear: 
 
 

 

2. The Move function requires entry of a To Site, To Location, and Asset Tag: 
 
 
Select a To Site first. You can scan or type in a To Site, or you can click the Magnifying Glass icon to access 
the Site Search screen. 
 

3. Select a To Location, to indicate where the Asset will be relocated. You can scan or type in a To Location, or 
you can click the Magnifying Glass icon to access the Location Search screen. 
 

4. Select an Asset Tag, by entering it manually or scanning it, or you can click the Magnifying Glass icon to 
access the Asset Tag Search screen. 
 
 
The Description, From Site and From Location fields will be displayed when a value is entered for the Asset 
Tag that is being moved.   
 

5. Tap the green check mark icon to record the Move transaction. 

Note for MobileAsset Professional and Enterprise edition users: If you have installed the Professional or 
Enterprise edition of MobileAsset and are using asset linking, the system will check for the Transact as Whole 
flag. If the flag is turned on for this asset (or the parent of this asset), a message will appear notifying you. You 
can either leave the flag on to perform the transaction on the entire group of linked assets, or select to turn the 
flag off to perform the transaction only on this asset. 
 
 
What is Transact as Whole? When an asset is set to "Transact as whole" (on the New/Edit Asset screen > 

318 



 
  

Wasp MobileAsset User Manual 

Linking tab) any functions (check in, check out, audit, move, etc.) will be performed as a whole for the group. 
This flag is driven from the top down, meaning the selection made for the parent asset will override the selection 
for a child asset. If you want to move only one asset that is a child of this asset, you will need to deselect this 
checkbox. Deselecting it on the Edit Asset > Asset Linking tab for the child asset will not override the 
selection made for this asset, and this group would still be moved as a whole. Similarly, if the Transact as 
whole flag was NOT selected on this tab, but it IS selected for the parent of this asset, the group would still be 
transacted as a whole because the selections made for the parent of this asset would take precedence.   
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3.4.8 Windows Mobile/CE Check Out 

The Check Out Asset transaction provides the ability to check-out assets to a customer or employee, specifying a Due 
Date and Due Time by which the asset should be checked-in. 
  
You have two options for checking out assets, Advanced and Quick.  
  
Advanced check out allows you to check out a number assets to an employee or customer, then view the Summary 
screen where you can collect a signature and/or print a receipt. 
  
Quick check out can be used when you have many assets you want to check out to different customers/employees 
without worrying about gathering signatures on each one. This mode allows you to select a customer or employee and 
check out the asset without having to collect signatures or view the summary screen for each transaction. 
 
Note: Quick check out is not available if the Require a Signature on Device is set to Yes on the Options screen. 
  
Advanced Check Out 
Quick Check Out 
  

 

 
Advanced Check Out 

  
  

1. To check-out assets, from the Main menu, tap Check Out.  If this is the first time you have accessed the Check 
Out function, a pop up menu will appear asking if you want Advanced or Quick check out. Select Advanced. 
The Advanced Check Out screen appears: 
 
 

 
 
Note: The popup menu does not automatically appear on subsequent taps. To change from Quick 
check out to Advanced check out or vice-versa, press and hold the Check Out menu option. The pop up 
menu will appear asking if you want Advanced or Quick check out. 
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2. You can check the asset out to a customer or an employee by scanning in an id number or selecting from the 
drop down menu. The drop down menu defaults to Customer   Click on the drop down list if you would prefer to 
use an Employee # instead. You can search for a Customer or Employee by selecting from the drop down, 
then clicking the Magnifying Glass icon to access the appropriate search screen. 
 
 

 
 
You can search for a customer or employee by selecting from the drop down, then clicking the Magnifying 
Glass icon to access the appropriate search screen. Below is an example of the Customer Search screen. 
 
 

 
 
 
Tap on a customer/employee to select him or her. 
 
 
Keep in mind that you can create a new customer or employee from the Customer and Employee Search 
screens by clicking the green plus sign from the bottom of the screen. 
 
Tap the green check mark icon to return to the check out function when a customer or employee has been 
selected. 
 
  

3. Enter an Asset Tag or search for one using the Magnifying Glass icon. The screen will populate with the asset's 
information. 
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Note for MobileAsset Professional and Enterprise edition users: If you have installed the Professional or 
Enterprise edition of MobileAsset and are using asset linking, the system will check for the Transact as Whole 
flag. If the flag is turned on for this asset (or the parent of this asset), a message will appear notifying you. You 
can either leave the flag on to perform the transaction on the entire group of linked assets, or select to turn the 
flag off to perform the transaction only on this asset. 
 
 
What is Transact as Whole? When an asset is set to "Transact as whole" (on the New/Edit Asset screen > 
Linking tab) any functions (check in, check out, audit, move, etc.) will be performed as a whole for the group. 
This flag is driven from the top down, meaning the selection made for the parent asset will override the selection 
for a child asset. If you want to move only one asset that is a child of this asset, you will need to deselect this 
checkbox. Deselecting it on the Edit Asset > Asset Linking tab for the child asset will not override the 
selection made for this asset, and this group would still be moved as a whole. Similarly, if the Transact as 
whole flag was NOT selected on this tab, but it IS selected for the parent of this asset, the group would still be 
transacted as a whole because the selections made for the parent of this asset would take precedence.   

 
4. The Due Date will default to Use CO Length, if a check out length was set for this asset type. The default can 

be accepted or overwritten if necessary. To change the Due Date, use the drop down menu to change the 
setting. 
 
 

  
 
 
Due Date options are: 
 
 
Use CO Length - This uses the check out duration set for the asset type. The Date and Time will be calculated 
and displayed. 
No Due Date - This means the asset will not have a due date set. 
Custom - Use this option to set a new due date and time. When this option is selected, the Date and Time 
fields appear: 
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Click the down arrow button to access the calendar to select a new due date. The default date is today. 
 
 
Use the up and down arrows to modify the time. The default time is the current time. 
 

5. The Site and Location default to the Site and Location assigned to this asset. You can change these if 
needed. Make sure that if you change the site, you also change the location to one within that site. 
 

6. (MobileAsset Web Users Only) If a Reservation has been created for this asset on MobileAsset Web, the 
Reservation field (shown below) will appear on the Check Out screen.   
 
 

 
 
The Reservation field displays a drop down list of reservations to which the current asset is tied. Select the 
reservation from the drop down list for which you want to check out this asset. If you are creating a reservation 
for the same period for a customer other than the one listed in the reservation, you will receive a warning 
message. 
 
 
Tap OK on the warning message to continue checking out the asset despite the overlapping period, or click No 
to cancel the check out process. 
 
 
When you sync the data back to the PC, MobileAsset Web will be updated with the new check out information. 
The status of the selected reservation will be updated to completed. 

7. Tap the green plus sign icon to check the asset out to the customer or employee. Non-pinned fields will clear 
allowing you to check out another asset; however, the Customer/Employee field will remain pinned until you are 
finished checking out assets for this session and click the green checkmark icon (see step 8). Please note that 
at this point, the transaction is still in a "pending" state. The transaction is not finalized until you complete step 
8. 

8. When you are finished checking out assets for this session, click the green checkmark icon. The Summary 
screen appears. 
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This screen lists all assets checked out during this session and allows you to collect a signature and/or print a 
receipt of the transaction(s). 
 
If you want to print the summary screen, make sure the checkboxes in front of the transaction and in front of the 
Print option are selected on the Summary screen. 
 
If you want to collect a signature for all or some of these transactions, make sure the checkboxes in front of the 
transaction and in front of the Signature option are selected on the Summary screen. 
 
Note: Depending on the MobileAsset PC options, you may be prompted to obtain a signature or a signature 
may be required. 
 
 
Tap the green checkmark icon.  
 
 
The Signature Capture screen appears.  
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Whoever is signing in this asset(s) can use the stylus to sign in the Capture window. The thick black line 
indicates the orientation of the capture page. 
 
 
 

 
 
 
You can change the orientation of the Capture window using the circle icon at the bottom of the screen. 
 
 

 
 
 
If you want to delete the signature after the user signs, tap the trash can icon. To save the signature, tap the 
green check mark icon. Saving a signature ends the check in session.  
 
 
 
The signature is saved on the mobile device until the next data upload to the PC. Once it is uploaded to the PC, 
you can view it by going to the Transactions List (Main > List Forms > Transactions) highlighting the desired 
transaction and clicking the Signature button. Only those transactions with a Pen icon next to them contain 
signature captures. 
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When the Signature button is clicked, the View Signature screen appears. 
 
 

 
 
 
Click the Red X in the upper, right corner to close the View Signature screen. 
 
You can re-print the check out receipt by highlighting the check out transaction, then clicking the Reprint Receipt button. 
 

 

Quick Check Out 

1. From the Main menu, tap Check Out.  If this is the first time you have accessed the Check Out function, a pop 
up menu will appear asking if you want Advanced or Quick check out.  Select Quick. The Check Out screen 
appears: 
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Note: The popup menu does not automatically appear on subsequent taps. To change from Quick 
check out to Advanced check out or vice-versa, press and hold the Check Out menu option. The pop up 
menu will appear asking if you want Advanced or Quick check out. 

2. You can check the asset out to a customer or an employee by scanning in an id number or selecting from the 
drop down menu. The drop down menu defaults to Customer   Click on the drop down list if you would prefer to 
use an Employee # instead. You can search for a Customer or Employee by selecting from the drop down, 
then clicking the Magnifying Glass icon to access the appropriate search screen. 
 
 

 
 
You can search for a customer or employee by selecting from the drop down, then clicking the Magnifying 
Glass icon to access the appropriate search screen. Below is an example of the Customer Search screen. 
 
 

 
 
 
Tap on a customer/employee to select him or her. 
 
 
Keep in mind that you can create a new customer or employee from the Customer and Employee Search 
screens by clicking the green plus sign from the bottom of the screen. 
 
Tap the green check mark icon to return to the check out function when a customer or employee has been 
selected. 
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3. Enter an Asset Tag or search for one using the Magnifying Glass icon. The screen will populate with the asset's 

information. 
 
 

 

4. The Due Date will default to Use CO Length, if a check out length was set for this asset type. The default can 
be accepted or overwritten if necessary. To change the Due Date, use the drop down menu to change the 
setting. 
 
 

  
 
 
Due Date options are: 
 
 
Use CO Length - This uses the check out duration set for the asset type. The Date and Time will be calculated 
and displayed. 
No Due Date - This means the asset will not have a due date set. 
Custom - Use this option to set a new due date and time. When this option is selected, the Date and Time 
fields appear: 
 
 

 
 
 
Click the down arrow button to access the calendar to select a new due date. The default date is today. 
 
 
Us the up and down arrows to modify the time. The default time is the current time. 
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5. The Site and Location default to the Site and Location assigned to this asset. These values cannot be 
changed  while in Quick Check Out mode. 

6. Tap the green checkmark when all information has been entered. The fields will clear allowing you to check out 
another asset. 
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3.4.9Windows Mobile/CE Check In 

The Check In Asset transaction provides the ability to check in assets currently checked out to a customer or 
employee. 
  
You have two options for checking in assets, Advanced and Quick.  
  
Advanced check in allows you to check in a number assets from an employee or customer, then view the Summary 
screen where you can collect a signature and/or print a receipt. 
  
Quick check in can be used when you have many assets you want to check in from different customers or employees 
without worrying about gathering signatures on each one. This mode allows you to select a customer or employee and 
check in the asset without having to collect signatures or view the summary screen for each transaction. 
  
Advanced Check In 
Quick Check In 
  

 

 
Advanced Check In 

  
1. To check in assets, from the Main menu, tap Check In.  If this is the first time you have accessed the Check In 

function, a pop up menu will appear asking if you want Advanced or Quick check in. Select Advanced. The 
Advanced Check In screen appears: 
 
 

 
 
 
Note: To change from Advanced check in to Quick check in, press and hold the Check In menu option. The 
pop up menu will appear asking if you want Advanced or Quick check in. 

2. Entry of an Asset Tag is required. The value can be scanned in, searched for by tapping the Magnifying Glass 
icon or entered manually.    

Note for MobileAsset Professional and Enterprise edition users: If you have installed the Professional or 
Enterprise edition of MobileAsset and are using asset linking, the system will check for the Transact as Whole 
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flag. If the flag is turned on for this asset (or the parent of this asset), a message will appear notifying you. You 
can either leave the flag on to perform the transaction on the entire group of linked assets, or select to turn the 
flag off to perform the transaction only on this asset. 
 
 
What is Transact as Whole? When an asset is set to "Transact as whole" (on the New/Edit Asset screen > 
Linking tab) any functions (check in, check out, audit, move, etc.) will be performed as a whole for the group. 
This flag is driven from the top down, meaning the selection made for the parent asset will override the selection 
for a child asset. If you want to move only one asset that is a child of this asset, you will need to deselect this 
checkbox. Deselecting it on the Edit Asset > Asset Linking tab for the child asset will not override the 
selection made for this asset, and this group would still be moved as a whole. Similarly, if the Transact as 
whole flag was NOT selected on this tab, but it IS selected for the parent of this asset, the group would still be 
transacted as a whole because the selections made for the parent of this asset would take precedence.   

 
3. The Site and Location values will default to the location from which the asset was checked-out, but they can be 

changed if you want to move the asset to a different Location at the same time you are checking it in. Select 
Magnifying Glass icon to access the Search screens for Site or Location. 
 
 

 

4. Tap the green check mark icon at the bottom of the screen to check in the asset. The asset will appear in the 
Assets checked in list as shown below: 
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Continue checking in assets as needed. 
 

5. After you are done checking in assets, you can add a signature capture. Depending on the MobileAsset PC 
options, you may be prompted to obtain a signature or a signature may be required.  
 
 
If you want to print a receipt, make sure the checkboxes in front of the transaction and the Print checkbox are 
selected, then tab the green checkmark icon. 
 
 
To add a signature to all or some of the assets in the checked in list, make sure the checkbox in front of the 
assets are selected (or the Select All checkbox is selected, if you want to collect a signature for all assets in the 
list) and select the Signature checkbox. Tap the green checkmark icon. 
 

 
 
 
The Signature Capture screen appears.  
 
 

 
 
 
 
 
Whomever is signing in this asset(s) can use the stylus to sign in the Capture window. The thick black line 
indicates the orientation of the capture page. 
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You can change the orientation of the Capture window using the circle icon at the bottom of the screen. 
 
 

 
 
 
If you want to delete the signature after the user signs, tap the trash can icon. To save the signature, tap the 
green check mark icon. Saving a signature ends the check in session.  
 
 
 
The signature is saved on the mobile device until the next data upload to the PC. Once it is uploaded to the PC, 
you can view it by going to the Transactions List (Main > List Forms > Transactions) highlighting the desired 
transaction and clicking the Signature button. Only those transactions with a Pen icon next to them contain 
signature captures. 
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When the Signature button is clicked, the View Signature screen appears. 
 

 
 
Click the Red X in the upper, right corner to close the View Signature screen. 
 
You can re-print the check in receipt by highlighting the check in transaction, then clicking the Reprint Receipt button. 
 

6.   Tap Print to print the list of Checked In assets to a supported mobile printer or Close to exit the Check In 
function. 

MobileAsset allows mobile devices to check in assets that were not checked out at the time the database was created 
for the mobile device.  Later, when Process Mobile Device Data is performed, any discrepancies can be reconciled. 
  

 

Quick Check In 

1. From the Main menu, tap Check In.  If this is the first time you have accessed the Check In function, a pop up 
menu will appear asking if you want Advanced or Quick check in.  Select Quick. The Quick Check In screen 
appears: 
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Note: To change from Quick check in to Advanced check in, press and hold the Check In menu option. The 
pop up menu will appear asking if you want Advanced or Quick check in. 

2. Entry of an Asset Tag is required. The value can be scanned in, searched for by tapping the Magnifying Glass 
icon or entered manually.    

Note for MobileAsset Professional and Enterprise edition users: If you have installed the Professional or 
Enterprise edition of MobileAsset and are using asset linking, the system will check for the Transact as Whole 
flag. If the flag is turned on for this asset (or the parent of this asset), a message will appear notifying you. You 
can either leave the flag on to perform the transaction on the entire group of linked assets, or select to turn the 
flag off to perform the transaction only on this asset. 
 
 
What is Transact as Whole? When an asset is set to "Transact as whole" (on the New/Edit Asset screen > 
Linking tab) any functions (check in, check out, audit, move, etc.) will be performed as a whole for the group. This 
flag is driven from the top down, meaning the selection made for the parent asset will override the selection for a 
child asset. If you want to move only one asset that is a child of this asset, you will need to deselect this 
checkbox. Deselecting it on the Edit Asset > Asset Linking tab for the child asset will not override the selection 
made for this asset, and this group would still be moved as a whole. Similarly, if the Transact as whole flag was 
NOT selected on this tab, but it IS selected for the parent of this asset, the group would still be transacted as a 
whole because the selections made for the parent of this asset would take precedence.   

  
  

3. The Site and Location values will default to the location from which the asset was checked-out. These values 
cannot be changed while in Quick Check In mode. 

4. Tap the green checkmark when all information has been entered. The fields will clear allowing you to check in 
another asset. 
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3.4.10 Windows Mobile/CE Audit 

The Audit Assets transaction is used to update the Location of one or more Assets. 
  

1. To audit assets, from the Main menu, tap Audit.  The Audit screen appears: 
 
 

 

2. Each Audit transaction begins by entering the Site and Location you are currently auditing. Site and Location 
values can be scanned in or entered manually. Click the Magnifying Glass icon to access the Search screen. 
 

3. You can note the time the audit started by tapping the Audit Start Time button. This feature allows you to stop 
and restart an audit without auditing the same inventory twice by telling MobileAsset to only include those 
assets that were not audited prior to the entered start date and time. For example, if you begin an audit on April 
8th, but had to stop at midnight and the audit was not completed, you can enter 4/9/2014 at 12am to being the 
new audit. This means that only items that have not been audited as of 12am on April 9th will be included in this 
audit. 
 
 
The following screen will appear: 
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Click the down arrow next to the date to access the calendar. 
 
 
Use the up and down arrows to set the time. 

4. When a Site and Location have been provided, MobileAsset displays the assets at that Location: 
 
 

 

5. One at a time, audit each asset in the list by confirming its presence at that Location, then highlighting it in the 
list, and tapping the green check mark icon. You can manually input an Asset Tag value or scan it with the 
mobile device's barcode scanner. As each Asset is Audited, the number of Assets not audited at location will 
be reduced. 

Note for MobileAsset Professional and Enterprise edition users: If you have installed the Professional or 
Enterprise edition of MobileAsset and are using asset linking, the system will check for the Transact as Whole 
flag. If the flag is turned on for this asset (or the parent of this asset), a message will appear notifying you. You 
can either leave the flag on to perform the transaction on the entire group of linked assets, or select to turn the 
flag off to perform the transaction only on this asset. 
 
 
What is Transact as Whole? When an asset is set to "Transact as whole" (on the New/Edit Asset screen > 
Linking tab) any functions (check in, check out, audit, move, etc.) will be performed as a whole for the group. 
This flag is driven from the top down, meaning the selection made for the parent asset will override the selection 
for a child asset. If you want to move only one asset that is a child of this asset, you will need to deselect this 
checkbox. Deselecting it on the Edit Asset > Asset Linking tab for the child asset will not override the 
selection made for this asset, and this group would still be moved as a whole. Similarly, if the Transact as 
whole flag was NOT selected on this tab, but it IS selected for the parent of this asset, the group would still be 
transacted as a whole because the selections made for the parent of this asset would take precedence.   
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6. When 0 Assets not audited at location is displayed, you can begin Auditing any Assets you have found at that 

Location which Asset did not list. 
 
 
For each Asset that Asset did not list, Search for it using the Magnifying Glass icon, scan it in, or directly enter 
the Asset Tag, then tap the green check mark icon.  A message will appear notifying you that the asset is not at 
the specified location. You can either move the asset to this location and audit it, or mark it as audited in the 
location it is assigned to in MobileAsset. Keep in mind that whichever option you choose, the asset will be 
audited. 
 
 
If you know that an Asset you have found should not reside at that Location, do not perform any transactions to 
rectify the misplacement. Just use the Edit asset screen to look up the Asset Tag's correct Location, then 
cancel out of the Edit transaction, and physically relocate the Asset to its correct Location - so that reality is 
made to conform with the database. 

If an Asset is missing at the Location being Audited, you must perform a Dispose transaction to declare it missing. 
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3.4.11 Windows Mobile/CE Funding Audit 

Professional and Enterprise Editions Only 
  
The Funding Audit function allows you to audit those assets associated with a funding source. 
  

1. From the Main screen, tap Funding Audit. The Funding Audit screen appears: 
 
 

 

2. You can enter the Audit Time or accept the default date/time (the default is the current date/time). 
 
 
This feature allows you to stop and restart an audit without auditing the same inventory twice by telling 
MobileAsset to only include those assets that were not audited prior to the entered start date and time. For 
example, if you begin an audit on November 6, but had to stop at midnight and the audit was not completed, 
you can enter 11/7/2014 at 12am to being the new audit. This means that only items that have not been 
audited as of 12am on November 7 will be included in this audit. 
 
 
Click the Magnifying Glass icon to see a full list of recent Audit Start times. 
 

3. Enter a Funding source to audit by scanning or entering a fund or by clicking the Magnifying Glass to access 
the Search screen. 
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Enter a full or partial name/code in the search field, or leave it blank and click the Search icon. Results will 
appear in the Funding list. 
 
 
Highlight a Funding source in the list, then click the green check mark icon. 
 
 
The selected Funding source will populate the Funding Audit screen. 
 
 

 
 
 
After you select a Funding source, the screen will display a list of the sites and locations containing assets 
associated with the selected Funding. 

4. Highlight a listing, then click the Start Audit button. The Audit screen will appear populated with your 
selection. 
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One at a time, audit each asset in the list by confirming its presence at that Location, then highlighting it in the 
list, and tapping the green check mark icon. You can manually input an Asset Tag value or scan it with the 
mobile device's barcode scanner. As each Asset is Audited, the number of Assets not audited at location 
will be reduced. 

Note for MobileAsset Professional and Enterprise edition users: If you have installed the Professional or 
Enterprise edition of MobileAsset and are using asset linking, the system will check for the Transact as Whole 
flag. If the flag is turned on for this asset (or the parent of this asset), a message will appear notifying you. You 
can either leave the flag on to perform the transaction on the entire group of linked assets, or select to turn the 
flag off to perform the transaction only on this asset. 
 
 
What is Transact as Whole? When an asset is set to "Transact as whole" (on the New/Edit Asset screen > 
Linking tab) any functions (check in, check out, audit, move, etc.) will be performed as a whole for the group. 
This flag is driven from the top down, meaning the selection made for the parent asset will override the selection 
for a child asset. If you want to move only one asset that is a child of this asset, you will need to deselect this 
checkbox. Deselecting it on the Edit Asset > Asset Linking tab for the child asset will not override the 
selection made for this asset, and this group would still be moved as a whole. Similarly, if the Transact as 
whole flag was NOT selected on this tab, but it IS selected for the parent of this asset, the group would still be 
transacted as a whole because the selections made for the parent of this asset would take precedence.   

 
5. When 0 Assets not audited at location is displayed, you can begin Auditing any Assets you have found at that 

Location which Asset did not list. 
 
 
For each Asset that Asset did not list, Search for it using the Magnifying Glass icon, scan it in, or directly enter 
the Asset Tag, then tap the green check mark icon. A message will appear notifying you that the asset is not at 
the specified location.  You can either move the asset to this location and audit it, or mark it as audited in the 
location it is assigned to in MobileAsset. Keep in mind that whichever option you choose, the asset will be 
audited. 
 
 
If you know that an Asset you have found should not reside at that Location, do not perform any transactions to 
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rectify the misplacement. Just use the Edit asset screen to look up the Asset Tag's correct Location, then 
cancel out of the Edit transaction, and physically relocate the Asset to its correct Location - so that reality is 
made to conform with the database. 

6. If an Asset is missing at the Location being Audited, you must perform a Dispose transaction to declare it 
missing. 
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3.4.12 Windows Mobile/CE Dispose 

The Dispose transaction is used to remove an Asset from the database. 
  

1. To dispose of an assets, from the Main menu, tap Dispose. The Dispose screen appears: 
 
 

 

2. Begin by scanning in, searching (via the Magnifying Glass icon ), or manually entering the Asset Tag you want 
to Dispose. 
 
 

 
 
 
The selected Asset's Description, Site and Location will be displayed.   
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Note for MobileAsset Professional and Enterprise edition users: If you have installed the Professional or 
Enterprise edition of MobileAsset and are using asset linking, the system will check for the Transact as Whole 
flag. If the flag is turned on for this asset (or the parent of this asset), a message will appear notifying you. You 
can either leave the flag on to perform the transaction on the entire group of linked assets, or select to turn the 
flag off to perform the transaction only on this asset. 
 
 
What is Transact as Whole? When an asset is set to "Transact as whole" (on the New/Edit Asset screen > 
Linking tab) any functions (check in, check out, audit, move, etc.) will be performed as a whole for the group. 
This flag is driven from the top down, meaning the selection made for the parent asset will override the selection 
for a child asset. If you want to move only one asset that is a child of this asset, you will need to deselect this 
checkbox. Deselecting it on the Edit Asset > Asset Linking tab for the child asset will not override the 
selection made for this asset, and this group would still be moved as a whole. Similarly, if the Transact as 
whole flag was NOT selected on this tab, but it IS selected for the parent of this asset, the group would still be 
transacted as a whole because the selections made for the parent of this asset would take precedence.   

 
3. Select a Reason from the drop down list: 

 
 

 

4. Tap the green check mark icon to complete the Dispose transaction for that asset, or tap the red X icon to exit 
the screen without disposing of the asset. 
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3.4.13 Windows Mobile/CE Maintenance 

You can mark maintenance as complete for an asset directly on the mobile device. 
  

1. To mark maintenance as completed for an asset, from the Main menu, tap Maintenance. The Maintenance 
screen appears: 
 
 

 

2. Begin by scanning in, searching (via Magnifying Glass icon), or manually entering the Asset Tag for which you 
want to mark maintenance completed. 
 
 

 
 
 
The selected Asset's Description will be displayed.   
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3. You can optionally click the Camera icon in the bottom, left corner of the screen to include pictures of 
the asset in this maintenance record. Pictures can be viewed on the Transaction List. 

4. You can enter a Completed On date, Condition and enter Notes for this maintenance entry as needed. If the 
maintenance is completed, select the Completed checkbox. 
 
 
You can choose from a previously created Maintenance note by tapping the Magnifying Glass icon. The 
Maintenance Type Search screen appears: 
 
 

 
 
 
Any existing Maintenance Types will appear in the list. You can select a listing and tap the green check mark 
icon, or tap the green plus sign icon to create a new Maintenance Type.   
 
 

 
 
 
The following screen will appear: 
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Enter a name and description for this maintenance, then tap the green check mark icon. 
 
 
  

5. Tap the green check mark icon on the Maintenance screen to complete the Maintenance Entry or tap the red 
X icon to exit the screen without completing the maintenance. 
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3.4.14 Windows Mobile/CE Tools 

  
The Tools menu allows you to perform a manual Upload, Full Sync or to switch to a different database or a different 
filter. You can also turn on/off the Auto Upload feature from this menu. 
 
 

 
  
The features available on the Tools menu are: 
  
Auto Upload 
Manual Upload 
Full Sync 
Switch Database 
Switch Filter 
  

 

Auto Upload 

Professional and Enterprise Editions only 
  

Turn the Auto Upload feature on to enable auto upload of data from the MobileAsset app to the MobileAsset database. 
The upload will take place each time you return to the Main Menu and select a function. This feature is turned ON by 
default. To turn it off, tap on the Auto Upload option. The menu will close. Reopen it and notice that the checkmark in 
front of the option as been removed. 
  
  

 
  

Manual Upload 

  
Tap the Start button in the Upload row to immediately begin a data upload from the MobileAsset app to the 
MobileAsset database.  
  
If the Upload option is not accessible (greyed out), as in the example screen shown above, there is no new data to be 
uploaded. 
 
Note: Standard Edition users must first connect the device to the PC before beginning the Manual Upload process. 
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Full Sync 

  
Full Sync uploads data from the MobileAsset App to the MobileAsset database followed by a download of the 
MobileAsset database. This ensures that any changes/new data uploaded from other devices will appear on the current 
device. 
 
Note: Standard Edition users must first connect the device to the PC before beginning the Full Sync process. 

 
  
  

Switch Database 

Professional and Enterprise Editions Only 
If your company uses more than one database, the Switch Database function allows you to switch between them.  
 
 
If you have transactions on the device that have not yet been uploaded to the database, you will not be able to switch 
databases until the upload is completed. 
  
To change the database, tap the Switch Database option. The Log in screen will appear: 
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Tap the grey Service URL field to unpin it, then enter the IP or FQDN of the new database server. Tap OK when you 
are done. 
  

 
  

Switch Filter 

  
The Switch Filter feature allows you to switch the filter on the database.  
  
Note: Filters are setup from Mobility > Specify Mobile Device Data Filters screen on the PC. 
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3.4.15 Windows Mobile/CE Help About 

On the Windows Mobile/CE device MobileAsset Main menu, select Help > About to display the version and build 
number of the MobileAsset program currently running on the Windows Mobile/CE device. 
  

 
 
 
The About screen appears similar to the example shown below: 
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3.5 Android Devices 

3.5.1 Downloading and Installing MobileAsset on Android Devices 

Professional and Enterprise Editions Only 
  

1. Download and install the Wasp MobileAsset App from the App Store to your mobile device. 

2. Click the MobileAsset icon to open the app. 

3. The first time you open MobileAsset, the following screen will appear: 
 
 

 
  
  

• Service URL - This field auto populates based on the IP or FQDN (Fully Qualified Domain Name) detected 
when you installed MobileAsset on your PC. The Service URL is the IP or FQDN followed by the port number 
for MobileAsset, usually 10008. The Service URL is pinned by default. If you need to modify the Service URL, 
you can unpin it by tapping on the grey field name. This will unpin the field allowing you to edit the URL 
information. 
 
 
Example URL: http://<your IP address>:10008 

• Device Name - Enter a unique name for this mobile device. 
 
 
If this device has previously been setup on MobileAsset with a different device name, a message will appear. 
Click Yes to use the previous name, click No to change the device name. 

• User Name - Enter your MobileAsset user name. 
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• Password - Enter your MobileAsset password. 
  
For more information on logging in to MobileAsset, please refer to the topic, Logging In to MobileAsset on Android. 
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3.5.2 Logging In to MobileAsset on Android 

Professional and Enterprise Editions Only 
  

When you tap on the MobileAsset icon on your device, the log in screen appears: 
  

 
  
Enter your MobileAsset Username and Password, then tap Login. 
  
If you need access to the Server URL and Device Name fields (seen on the Log In screen the first time it is 
accessed after installation, or when the user selects Switch Database from the Settings screen), "pinch" 
anywhere on the Log In screen. To pinch the screen, press two fingers to the screen, then move them together in a 
pinching motion. You will be asked if you want to switch to a different database or a different server. Tap OK to 
access the screen. 
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3.5.3 Printing from the MobileAsset App in Android 

Professional and Enterprise Editions Only 
  

Printing Labels 
  
To print labels from the New and Edit asset screens in the MobileAsset app, you will need to have your ZPL printer 
set up on your network. You will need to select the printer IP and a port. 
  
  
Printing Receipts 
  
To print receipts from the Check Out and Check In screens, you will need an airprint compatible printer. Make sure 
the device is logged into wifi and is on the same subnet with the printer itself.  
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3.5.4 Android Main Menu 

Professional and Enterprise Editions Only 
  

After logging in to MobileAsset the Main Menu appears. 
 

 
 
All of the functions available in MobileAsset are available from the Main Menu. To open a feature, click on a listing in 
the menu. 
 
 

You can display or hide the Main Menu by clicking the  icon located in the top, left of most screen. 
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3.5.5 Android Add New 

Professional and Enterprise Editions Only 
  

You can create new Assets, Asset Tags, Locations, Departments, Manufacturers and Vendors in the MobileAsset app. 
This new data will be transmitted to the MobileAsset database in real time where it will become available to all devices 
and on the PC. 
  
The only "Add New" screen that is accessed directly is the New Asset screen (accessed from the Main Menu). For 
other new information, you can enter the data in the appropriate field. MobileAsset will recognize the data as new and 
ask you if you want to add it to the database. 
  
New Asset 
New Asset Type 
New Location 
New Department 
New Manufacturer 
New Vendor 
  
Sites and Locations must be created on the PC. 
  
Other topics that are related to Adding New information are: 
  
Search 
Pinning Data 
  

 

New Asset 

1. From the Main Menu, tap the New Asset option. The New Asset screen appears. 
 
 

 
 
Note: Fields that are preceded by an asterisk (*) are required. 
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2. Tap in the field into which you want to enter data. The keyboard will appear at the bottom of the screen. 
 
 

 
 
Tap Done at anytime to hide the keyboard. 
 
If you want to scan a barcode, tap the barcode icon. 
 

 
 
The scanner feature will open. Hold your device over the barcode. When MobileAsset has successfully read the 
barcode, the data will appear in the Asset field. 
 
You can use the right and left arrow keys at the top of the keyboard to scroll through the fields.  

3. Enter an Asset Type for this asset. This is a required field. You can enter a tag into the field using the 
keyboard, tap the Scan icon to scan a barcode, or click the Magnifying Glass icon to access the Search screen. 
 
You can also add a new Asset Type by entering new information in the field. MobileAsset will recognize the 
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data as new and prompt you to create the new Asset Type. For detailed instructions, please refer to the section 
New Asset Type later in this topic. 

4. After you select an Asset Type, the following screen will appear: 
 

 
 
Select Yes to populate the fields that appear on the Type tab with information from the Asset Type. 
 
Select No to leave those fields blank. 

5. Next enter the Site and Location for this asset following the instructions in step 2. Keep in mind that you cannot 
create new Sites on the mobile device. These will need to be created on the PC. 

6. You can optionally enter a Description, Serial #, Department and Condition for the asset as well. 

7. If you are using the Professional or Enterprise edition of MobileAsset, the Linking tab will be displayed. Tap on 
the tab label to open it. 
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Asset Linking allows you to link two or more assets together to form one new asset. For example, the asset 
Mary's Computer may consist of 4 separate assets - CPU, Keyboard, Mouse and Monitor. These four individual 
assets are linked together to form one new asset, Mary's Computer. For a complete definition of Asset 
Linking and an example, please refer to the Definitions topic. 
 
If this asset is to be the Parent, or top-level asset, of this group, you can leave the "Parent Asset" field blank. If 
you want to give this asset a parent (for instance, if this asset is a monitor and you want to link to the asset 
Mary's Computer), enter or scan an asset or tap the Magnifying Glass icon to search for an asset. 
 
The asset can have a parent assigned to it and be a parent (have child assets assigned to it). 
 
To associate child assets with this asset (the current asset will be the "parent" of these assets), click the yellow 
+ sign. The Search Asset screen will appear displaying all assets in the database. You can search for an asset 
by entering a full or partial asset tag or description in the search field and clicking the Magnifying Glass icon. 
Tap on an asset in the list to link it to the new asset. 
 
Highlight the desired asset in the Asset List, then click the Select button. The selected asset will appear in the 
"Child Asset(s)" window as shown below: 
 
 

 
 
You can unlink the asset by tapping the Unlink icon. 
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A Note about the Transact as Whole Flag: In the example above, the Transact as whole flag is checked; 
therefore, any functions (check in, check out, audit, move, etc.) will be performed as a whole for the group. This 
flag is driven from the top down, meaning the selection made for the parent asset will override the selection for 
a child asset. If you want to move only one asset that is a child of this asset, you will need to deselect this check 
box. Deselecting it on the Edit Asset > Asset Linking tab for the child asset will not override the selection 
made for this asset, and this group would still be moved as a whole. Similarly, if the Transact as whole flag 
was NOT selected on this tab, but it IS selected for the parent of this asset, the group would still be transacted 
as a whole because the selections made for the parent of this asset would take precedence.   
 
Also keep in mind that when you check out an asset that has Transact as whole turned on and you select to 
use the Default Due Date (on the Check Out screen) MobileAsset will search all assets linked to the selected 
asset to find the maximum checkout duration. The software will use this maximum length to calculate the due 
dates for all the linked assets. This ensures that all the assets in the transaction have the same due date even if 
some of the linked assets have different checkout durations. 

8. Click the Picture tab to view any image files that have been Attached to either the Asset Type Attachments 
folder or the Asset Attachments folder or to add a new picture to this asset. 
 

 
 
Click the Camera icon. A screen will appear asking if you want to take a new picture or browse for a picture on 
your device. 
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Camera - Select this option to access the camera feature on your device. Take the picture as you normally 
would on your device, then select Save, or Discard to discard the current picture and take another. When you 
select Save the image will be displayed on the Picture tab. Images taken via the camera through the 
MobileAsset app are saved to your device and to the MobileAsset database. 
 
Note: If you take a picture from the MobileAsset app, the picture will be saved to your picture gallery. Be aware 
that the picture will be rotated 90 degrees in the gallery view. 
 
Gallery - Select this option to browse for a picture on your device. 
 
When you select or take a photo, it will appear in the Picture tab. 
 

 
 
 
Click the Trash can icon to delete the image. 
 
The number of pictures you can attach to an asset is limited by the number set in Options > Maximum 
Pictures Captured. The default number of captures is 5. 
 
Note: After uploading data to the PC, any pictures taken via the Android app will appear as attachments on the 
Edit Asset screen > Attachment tab. Pictures taken via the Android app will not appear on the Edit Asset 
screen > Picture tab by default. You can set an image as default to have it appear on the Picture tab by 
following the instructions provided in the topic New Asset screen > Picture tab. 

9. The Custom tab displays any custom fields, either static or dynamic, set up on the PC.  
 
Dynamic custom fields are only available for the Professional and Enterprise editions. For more 
information on these fields, please refer to the topics Using Custom Fields and Using Dynamic Custom 
Fields. 
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An example of the Custom tab displaying Dynamic custom fields is shown below: 
 

 
 
If any of the fields are set to be required, they will appear with an asterisk (*) in front of them. You must 
complete all required custom fields before you can save the asset.   
 
Click the Magnifying icon next to each field to view any Predefined values as well as recently used values. 

10. The Type tab contains information related to the Asset Type such as depreciation and Asset Length. If you 
selected to set common asset fields in Step 4, the fields on this tab will be populated with data from the asset 
type. In addition, if the Edit Inherited Asset Type data option is turned off, any of the fields that are in 
common with the Asset Type will not be editable, even if they are blank.   
 
If Depreciation is not set for the Asset Type associated with the asset, you will no be able to select a Depr. 
Class here. Depreciation can be set for an Asset Type on the PC only. 
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Enter information on this screen as needed. Keep in mind that if you enter a new manufacturer or vendor here, 
you will be given the opportunity to add them to your database. For more information see Add New 
Manufacturer and Add New Vendor later in this topic. 

11. When you are finished entering information for this asset, tap the Save button at the bottom of the screen. 
 
Notice that after you select Save, a number appears next to the Summary button. 
 

 
 
This indicates how many assets you have created during this session. Tap the Summary button to view the 
summary information. Details of each asset you have added this session will display: 
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Tap the Print icon to print labels for these assets. The labels will print to your ZPL printer that is on your 
network. For information on printing from Android, please refer to the topic Printing from the MobileAsset App 
in Android.  

 

New Asset Type 

  
1. When you enter new data into the Asset Type field MobileAsset will recognize it as new and the following 

prompt will appear: 
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2. Tap Yes to access the New Asset Type screen. 
 

 
 
Enter information in the following fields: 
 
Asset Type - This field is required. The asset type is a category for assets and is required to create new asset 
types. Assets are assigned to a specific asset type. For instance, you may have an Asset Type of Label Printers 
that defines the manufacturer, size specs, etc. of this particular type of printer. Then specific printers of the 
same type are assigned to the Label Printers asset type. Asset Tags must be unique across all Sites and 
Locations. A particular value can occur only once in the Asset database. 
 
Asset Type Description - Enter a description for this Asset Type. 
 
Depr Class and Category are optional fields. A selection can be made from any previously defined values 
found on the search screen or you can create a new Class or Category by entering new information in the field.. 
  
 
MobileAsset can perform depreciation calculations at the PC for any Depreciation Class assigned to asset types 
for which that option has been enabled. The mobile device does not distinguish those Depreciation Classes for 
which depreciation has been enabled from those where it has not. If you define a new Depreciation Class on 
the mobile device for which depreciation should be calculated, the option will have to be enabled for that 
Depreciation Class. Click here for information on enabling depreciation. 
 
 
Manufacturer - Scan a manufacturer or tap the Magnifying Glass icon to search manufacturers. You can create 
a new manufacturer by entering new information in the field. 
 
Vendor - Scan a manufacturer or tap the Magnifying Glass icon to search manufacturers. You can create a new 
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manufacturer by entering information in the field. 
 
CO Length - The default number of Days, Hours or Minutes the asset type may remain checked out before it is 
overdue.   
 
Lead Time - Indicates how long after an asset is received, checked in, etc. before it is available. The lead time 
allows time for recalibration, cleaning, etc. 
 
Tap the Save button when you are done. You will be returned to the screen you were previously working on. 

 

New Location 

When you enter new data into the Location field MobileAsset will recognize it as new and the following prompt will 
appear: 
 

 
 
Click Yes on the prompt to access the New Location screen.  
 

 

Make sure the Location is entered correctly, then tap the Save button. You will returned to the screen you were 
previously working on. 
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New Department 

When you enter new data into the Department field MobileAsset will recognize it as new and the following prompt will 
appear: 
 

 
 
Click Yes to access the New Department screen. 
 

 
 
Enter the Department Code and Department Name, then click the Save button. 

 

New Manufacturer 

  
When you enter new data into the Manufacturer field MobileAsset will recognize it as new and the following prompt will 
appear: 
 

 

Click Yes on this prompt to save the new manufacturer. If you need to add additional data to this manufacturer, such as 
address and phone information, you will need to do so on the PC. 
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New Vendor 

  
When you enter new data into the Vendor field MobileAsset will recognize it as new and the following prompt will 
appear: 
 

 

Click Yes on the prompt to access the New Vendor screen. 
 

 
 
Enter the Vendor code and the Vendor Name (optional), then click the Save button. 
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3.5.6 Android Pinning Data 

Professional and Enterprise Editions Only 
  

Many fields can be "Pinned" in MobileAsset, allowing for faster data entry. For instance, if you are adding multiple new 
assets to one Asset Type at a specific Site and Location, you can select information  in those fields once, then "pin" the 
fields. This allows you to quickly create new assets without having to re-enter the Asset Type, Site and Location each 
 time. 
  

To Pin a Field 

  
Press and hold the label of the field you want to pin. The field label will turn bold and the Search icon will disappear, 
indicating it is pinned. 
  
In the example below we have pinned the Asset Type, Site and Location fields. 
  

 
  

To Unpin a Field 

  
Press and hold the field label until the label returns to normal type and the search icon reappears. 
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3.5.7 Android Search 

Professional and Enterprise Editions Only 
  

You can search for a variety of information in MobileAsset using the Search screens. Anywhere you see a Magnifying 
Glass icon next to a field, you can click on the icon to access the search screen. The searchable data is limited to 
field. For instance, if you click the Magnifying Glass icon next to the Asset Type field, the search screen will only 
search for Asset Types. 
  
Click the Magnifying Glass next to a field. 
 

 
Note: The Asset Search function is available from the toolbar at the top of most screens. 
 

 
 
The appropriate search screen appears. In this example, we have accessed the Asset Search. 
 

 
 
Tap in the text field at the top of the screen to access the keyboard, then type in a full or partial name, asset tag, etc. 
Click the Magnifying glass icon when you are done entering information. Search results will appear on the screen. 
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Tap on a listing in the search results to select it. 
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3.5.8 Android Edit Asset 

Professional and Enterprise Editions Only 
  

This feature allows you to edit an existing asset. 
  

1. From the Main Menu, tap Edit Asset. The Edit Asset search screen appears. 
 

 
2. This screen is divided into two sections containing search options. Select how you want to search for the asset 

you need to edit.   
 
Your options are: 
 
Search by Tag - Scan, enter using the keyboard or Search for an existing asset tag. On the Search screen, 
enter a full or partial tag, then tap the Magnifying Glass icon. Tap the asset you want to edit in the Search 
results. The Edit screen will appear (see example in Step 3). 
 
For information on entering or scanning information in MobileAsset, please refer to the topic Entering or 
Scanning Information. 
 
Search by Site and Location - Scan, enter using the keyboard or Search for a Site and/or a Location. A list of 
assets located at the specified Site/Location will appear. 
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3. Tap on the asset you want to edit. The Edit screen will appear: 
 

 
4. Make changes as necessary to the asset. 

374 



 
  

Wasp MobileAsset User Manual 

5. If you want to print a label for this asset, tap the Print button. 

6. When you are finished, tap the Update button. 
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3.5.9 Android Move Asset 

Professional and Enterprise Editions Only 
  

The Move Asset function is used to relocate an asset from one location to another. 
  

1. From the Main Menu tap Move. The Move screen appears. 
 
 

 
2. Scan, enter using the keyboard or Search for a To Site. This is the site to which you are moving the asset. 

3. Scan, enter using the keyboard or Search for a To Location. This is the location to which you are moving the 
asset. The results on the search screen will be limited to locations within the selected site. 

4. Scan, enter using the keyboard or Search for an Asset Tag. The Description, From Site and From Location 
will populate with information from the selected Asset Tag. 
 
For information on entering or scanning information in MobileAsset, please refer to the topic Entering or Scanning 
Information. 
 
Keep in mind that you can "pin" fields on this screen. For more information on pinning, please refer to the topic 
Android Pinning Data. 

Note for MobileAsset Professional and Enterprise edition users: If you have installed the Professional or 
Enterprise edition of MobileAsset and are using asset linking, the system will check for the Transact as Whole 
flag. If the flag is turned on for this asset (or the parent of this asset), a message will appear notifying you. You 
can either leave the flag on to perform the transaction on the entire group of linked assets, or select to turn the 
flag off to perform the transaction only on this asset. 
 
 
What is Transact as Whole? When an asset is set to "Transact as whole" (on the New/Edit Asset screen > 
Linking tab) any functions (check in, check out, audit, move, etc.) will be performed as a whole for the group. This 
flag is driven from the top down, meaning the selection made for the parent asset will override the selection for a 
child asset. If you want to move only one asset that is a child of this asset, you will need to deselect this 
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checkbox. Deselecting it on the Edit Asset > Asset Linking tab for the child asset will not override the selection 
made for this asset, and this group would still be moved as a whole. Similarly, if the Transact as whole flag was 
NOT selected on this tab, but it IS selected for the parent of this asset, the group would still be transacted as a 
whole because the selections made for the parent of this asset would take precedence.   
 

5. When you have entered your selections, tap the Move button.  

  
  

377 



 
  

Wasp MobileAsset User Manual 

3.5.10 Android Check Out 

Professional and Enterprise Editions Only 
  

  
The Check Out Asset transaction provides the ability to check-out assets to a customer or employee, specifying a Due 
Date and Due Time by which the asset should be checked-in. 
  
You have two options for checking out assets, Advanced and Quick.  
  
Advanced check out allows you to check out a number assets to an employee or customer, then view the Summary 
screen where you can collect a signature and/or print a receipt. 
  
Quick check out can be used when you have many assets you want to check out to different customers/employees 
without worrying about gathering signatures on each one. This mode allows you to select a customer or employee and 
check out the asset without having to collect signatures or view the summary screen for each transaction. 
 
Note: Quick check out is not available if the Require a Signature on Device is set to Yes on the Options screen. 
  
Advanced Check Out 
Quick Check Out 
  

 

Advanced Check Out 

  
1. From the Main Menu tap Check Out. If this is the first time you have accessed this feature the Check Out 

popup menu will appear: 
 
 

 
 
Click Advanced Check Out on the popup menu.  The Advanced Check Out screen appears: 
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Note: The popup menu does not automatically appear on subsequent taps. To change from Quick check out to 
Advanced check out or vice-versa, press and hold the Check Out menu option. The pop up menu will appear 
asking if you want Advanced or Quick check out. 

2. Assets can be checked out to customers or to employees. By default, the Check Out screen is set to Customer 

#. You can switch to Employee # by tapping on the   icon next to the Customer # label. A screen will 
appear allowing you to select Customer # or Employee #. 
 

 
 
 
The Check Out screen will show your change. 
 

 

3. Scan, enter using the keyboard or Search for an Employee or Customer.  
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For information on entering or scanning information in MobileAsset, please refer to the topic Entering or 
Scanning Information. 
 
Keep in mind that you can "pin" fields on this screen. For more information on pinning, please refer to the topic 
Android Pinning Data. 

4. Scan, enter using the keyboard or Search for an Asset Tag.  
 
 
 
The Description, Site and Location fields will populate when you select the Asset Tag. 

Note for MobileAsset Professional and Enterprise edition users: If you have installed the Professional or 
Enterprise edition of MobileAsset and are using asset linking, the system will check for the Transact as Whole 
flag. If the flag is turned on for this asset (or the parent of this asset), a message will appear notifying you. You can 
either leave the flag on to perform the transaction on the entire group of linked assets, or select to turn the flag off 
to perform the transaction only on this asset. 
 
 
What is Transact as Whole? When an asset is set to "Transact as whole" (on the New/Edit Asset screen > 
Linking tab) any functions (check in, check out, audit, move, etc.) will be performed as a whole for the group. This 
flag is driven from the top down, meaning the selection made for the parent asset will override the selection for a 
child asset. If you want to move only one asset that is a child of this asset, you will need to deselect this checkbox. 
Deselecting it on the Edit Asset > Asset Linking tab for the child asset will not override the selection made for this 
asset, and this group would still be moved as a whole. Similarly, if the Transact as whole flag was NOT selected 
on this tab, but it IS selected for the parent of this asset, the group would still be transacted as a whole because the 
selections made for the parent of this asset would take precedence.   

  
5. The Due Date will default to Use CO Length, if a check out length was set for this asset type. The default can 

be accepted or overwritten if necessary. To change the Due Date, tap in the field. The options will appear at the 
bottom of the screen. Tap on an option to select it. 
 

 
 
Due Date options are: 
 
Use CO Length - This uses the check out duration set for the asset type. The Date and Time will be calculated 
and displayed. 
No Due Date - This means the asset will not have a due date set. 
Custom - Use this option to set a new due date and time. When this option is selected, the Date and Time 
fields appear: 
 

380 



 
  

Wasp MobileAsset User Manual 

 
 
Tap on the Date field to display the calendar: 
 

 

6. (MobileAsset Web Users Only) If you have created a Reservation on MobileAsset Web, you will see the 
Reservation field.  
 
The Reservation field displays a drop down list of reservations to which the current asset is tied. Select the 
reservation from the drop down list for which you want to check out this asset. If you are creating a reservation 
for the same period for a customer other than the one listed in the reservation, you will receive a warning 
message. 
 
Tap OK on the warning message to continue checking out the asset despite the overlapping period, or click No 
to cancel the check out process. 
 
When you sync the data back to the PC, MobileAsset Web will be updated with the new check out information. 
The status of the selected reservation will be updated to completed. 

7. When you are finished entering information for this asset, tap the Check Out button at the bottom of the screen. 
 
Notice that after you select Check Out, a number appears next to the Finish button. 
 

 
 
This indicates how many assets you have checked out to the customer/employee during this session. Tap the 
Finish button to view the summary information. Details of each asset you have checked out will display: 
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8. Depending on the MobileAsset PC options, you may be prompted to obtain a signature or a signature may be 
required. 
 
If you are prompted to obtain a signature, tap Yes on the prompt screen. 
 
If you are not prompted but want to add a signature or print a receipt, select the Signature and/or Print 
checkboxes at the bottom of the summary screen.  

9. Click the Commit button. If you selected Signature, the Signature screen appears: 
 

 
 
Have the employee or customer sign on the line using their fingertip. 
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If you are satisfied with the signature, tap Save. If you want to erase the current signature and try again, tap 
Reset. To close the Signature screen without saving the signature, tap Dismiss. 
 
The signature is saved on the device until the next data upload to the PC. Once it is uploaded to the PC, you 
can view it by going to the Transactions List (Main > List Forms > Transactions) highlighting the desired 
transaction and clicking the Signature button. Only those transactions with a Pen icon next to them contain 
signature captures. 
 

 
 
When the Signature button is clicked, the View Signature screen appears. 
 

 
 
Click the Red X in the upper, right corner to close the View Signature screen. 
 

10. If you selected the Print checkbox, the Print screen appears. Note: You can re-print the check out receipt by 
highlighting the check out transaction, then clicking the Reprint Receipt button. 
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Tap Bluetooth or Network depending on how your printer is set up. For more information on printing, refer to the 
topic Printing from the MobileAsset App in Android. 
 
After collecting a signature and printing a receipt the session is closed and you will be returned to the blank 
check out screen. 

  
 

 
Quick Check Out 

1. From the Main menu, tap Check Out.  If this is the first time you have accessed the Check Out function, a pop 
up menu will appear asking if you want Advanced or Quick check out.   
 
 
Note: The popup menu does not automatically appear on subsequent taps. To change from Quick check out to 
Advanced check out or vice-versa, press and hold the Check Out menu option. The pop up menu will appear 
asking if you want Advanced or Quick check out. 
 
 
Select Quick Check Out.  
 

 
 
The Check Out screen appears: 
 

384 



 
  

Wasp MobileAsset User Manual 

 

 

2. Assets can be checked out to customers or to employees. By default, the Check Out screen is set to 

Customer #. You can switch to Employee # by tapping on the   icon next to the Customer # label. A 
screen will appear allowing you to select Customer # or Employee #. 
 

 
 
 
The Check Out screen will show your change. 
 

 

3. Scan, enter using the keyboard or Search for an Employee or Customer.  
 
For information on entering or scanning information in MobileAsset, please refer to the topic Entering or 
Scanning Information. 
 
Keep in mind that you can "pin" fields on this screen. For more information on pinning, please refer to the topic 
Android Pinning Data. 
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4. Scan, enter using the keyboard or Search for an Asset Tag.  
 
 
 
The Description, Site and Location fields will populate when you select the Asset Tag. 

Note for MobileAsset Professional and Enterprise edition users: If you have installed the Professional or 
Enterprise edition of MobileAsset and are using asset linking, the system will check for the Transact as Whole 
flag. If the flag is turned on for this asset (or the parent of this asset), a message will appear notifying you. You can 
either leave the flag on to perform the transaction on the entire group of linked assets, or select to turn the flag off 
to perform the transaction only on this asset. 
 
 
What is Transact as Whole? When an asset is set to "Transact as whole" (on the New/Edit Asset screen > 
Linking tab) any functions (check in, check out, audit, move, etc.) will be performed as a whole for the group. This 
flag is driven from the top down, meaning the selection made for the parent asset will override the selection for a 
child asset. If you want to move only one asset that is a child of this asset, you will need to deselect this checkbox. 
Deselecting it on the Edit Asset > Asset Linking tab for the child asset will not override the selection made for this 
asset, and this group would still be moved as a whole. Similarly, if the Transact as whole flag was NOT selected 
on this tab, but it IS selected for the parent of this asset, the group would still be transacted as a whole because the 
selections made for the parent of this asset would take precedence.   

  
5. The Due Date will default to Use CO Length, if a check out length was set for this asset type. The default can 

be accepted or overwritten if necessary. To change the Due Date, tap in the field. The options will appear at the 
bottom of the screen. Tap on an option to select it. 
 

 
 
Due Date options are: 
 
Use CO Length - This uses the check out duration set for the asset type. The Date and Time will be calculated 
and displayed. 
No Due Date - This means the asset will not have a due date set. 
Custom - Use this option to set a new due date and time. When this option is selected, the Date and Time 
fields appear: 
 

 
 
Tap on the Date field to display the calendar: 
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6. (MobileAsset Web Users Only) If you have created a Reservation on MobileAsset Web, you will see the 
Reservation field.  
 
The Reservation field displays a drop down list of reservations to which the current asset is tied. Select the 
reservation from the drop down list for which you want to check out this asset. If you are creating a reservation 
for the same period for a customer other than the one listed in the reservation, you will receive a warning 
message. 
 
Tap OK on the warning message to continue checking out the asset despite the overlapping period, or click No 
to cancel the check out process. 
 
When you sync the data back to the PC, MobileAsset Web will be updated with the new check out information. 
The status of the selected reservation will be updated to completed. 

7. When you are finished entering information for this asset, tap the Check Out button at the bottom of the screen. 
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3.5.11 Android Check In 

Professional and Enterprise Editions Only 
  

The Check In Asset transaction provides the ability to check in assets currently checked out to a customer or 
employee. 
  
You have two options for checking in assets, Advanced and Quick.  
  
Advanced check in allows you to check in a number assets from an employee or customer, then view the Summary 
screen where you can collect a signature and/or print a receipt. 
  
Quick check in can be used when you have many assets you want to check in from different customers or employees 
without worrying about gathering signatures on each one. This mode allows you to select a customer or employee and 
check in the asset without having to collect signatures or view the summary screen for each transaction. 
  
Advanced Check In 
Quick Check In 
  
Keep in mind that you can "pin" fields on this screen. For more information on pinning, please refer to the topic Android 
Pinning Data. 
  

 

Advanced Check In 

  
1. From the Main Menu tap Check In . If this is the first time you have accessed this feature the Check In popup 

menu will appear: 
 
 

 
 
 
Click Advanced Check In on the popup menu.  The Check In screen appears: 
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Note: The popup menu does not automatically appear on subsequent taps. To change from Quick check out to 
Advanced check in or vice-versa, press and hold the Check In menu option. The pop up menu will appear 
asking if you want Advanced or Quick check in. 

2. Scan, enter using the keyboard or Search for an Asset Tag.  
 
For information on entering or scanning information in MobileAsset, please refer to the topic Entering or 
Scanning Information. The Description, Site and Location will populate based on the Asset Tag entered. You 
can also scan, enter or search for a Site and Location. 

Note for MobileAsset Professional and Enterprise edition users: If you have installed the Professional or 
Enterprise edition of MobileAsset and are using asset linking, the system will check for the Transact as Whole 
flag. If the flag is turned on for this asset (or the parent of this asset), a message will appear notifying you. You 
can either leave the flag on to perform the transaction on the entire group of linked assets, or select to turn the 
flag off to perform the transaction only on this asset. 
 
 
What is Transact as Whole? When an asset is set to "Transact as whole" (on the New/Edit Asset screen > 
Linking tab) any functions (check in, check out, audit, move, etc.) will be performed as a whole for the group. 
This flag is driven from the top down, meaning the selection made for the parent asset will override the selection 
for a child asset. If you want to move only one asset that is a child of this asset, you will need to deselect this 
checkbox. Deselecting it on the Edit Asset > Asset Linking tab for the child asset will not override the 
selection made for this asset, and this group would still be moved as a whole. Similarly, if the Transact as 
whole flag was NOT selected on this tab, but it IS selected for the parent of this asset, the group would still be 
transacted as a whole because the selections made for the parent of this asset would take precedence.   

 
3. When you are done entering information tap the Check In button. 

 
Notice that after you select Check In, a number appears next to the Summary button. 
 

 
 
This indicates how many assets you have checked in during this session. Tap the Summary button to view the 
summary information. Details of each asset you have checked in will display: 
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4. Depending on the MobileAsset PC options, you may be prompted to obtain a signature or a signature may be 
required. 
 
If you are prompted to obtain a signature, tap Yes on the prompt screen. 
 
If you are not prompted but want to add a signature or print a receipt, select the Signature and/or Print 
checkboxes at the bottom of the summary screen.  

5. Click the Commit button. If you selected Signature, the Signature screen appears: 
 

 
 
Have the employee or customer sign on the line using their fingertip. 
 

 
 
If you are satisfied with the signature, tap Save. If you want to erase the current signature and try again, tap 
Reset. To close the Signature screen without saving the signature, tap Dismiss. 
 
The signature is saved on the device until the next data upload to the PC. Once it is uploaded to the PC, you 
can view it by going to the Transactions List (Main > List Forms > Transactions) highlighting the desired 
transaction and clicking the Signature button. Only those transactions with a Pen icon next to them contain 
signature captures. 
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When the Signature button is clicked, the View Signature screen appears. 
 

 
 
Click the Red X in the upper, right corner to close the View Signature screen. 
 
 
If you selected the Print checkbox, the Print screen appears: 
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Tap Bluetooth or Network depending on how your printer is set up. For more information on printing, refer to the 
topic Printing from the MobileAsset App in Android. You can re-print the check in receipt by highlighting the 
check in transaction, then clicking the Reprint Receipt button. 
 
After collecting a signature and printing a receipt the session is closed and you will be returned to the blank 
check out screen. 

 

Quick Check In 

  
1. From the Main menu, tap Check Out.  If this is the first time you have accessed the Check Out function, a pop up 

menu will appear asking if you want Advanced or Quick check out.   
 
 
Note: The popup menu does not automatically appear on subsequent taps. To change from Quick check in to 
Advanced check in or vice-versa, press and hold the Check In menu option. The pop up menu will appear asking 
if you want Advanced or Quick check in. 
 
Select Quick Check In: 
 

 
 
The Check In screen appears: 
 

 

2. Scan, enter using the keyboard or Search for an Asset Tag.  
 
For information on entering or scanning information in MobileAsset, please refer to the topic Entering or 
Scanning Information. The Description, Site and Location will populate based on the Asset Tag entered. You 
can also scan, enter or search for a Site and Location. 
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Note for MobileAsset Professional and Enterprise edition users: If you have installed the Professional or 
Enterprise edition of MobileAsset and are using asset linking, the system will check for the Transact as Whole 
flag. If the flag is turned on for this asset (or the parent of this asset), a message will appear notifying you. You 
can either leave the flag on to perform the transaction on the entire group of linked assets, or select to turn the 
flag off to perform the transaction only on this asset. 
 
 
What is Transact as Whole? When an asset is set to "Transact as whole" (on the New/Edit Asset screen > 
Linking tab) any functions (check in, check out, audit, move, etc.) will be performed as a whole for the group. 
This flag is driven from the top down, meaning the selection made for the parent asset will override the selection 
for a child asset. If you want to move only one asset that is a child of this asset, you will need to deselect this 
checkbox. Deselecting it on the Edit Asset > Asset Linking tab for the child asset will not override the 
selection made for this asset, and this group would still be moved as a whole. Similarly, if the Transact as 
whole flag was NOT selected on this tab, but it IS selected for the parent of this asset, the group would still be 
transacted as a whole because the selections made for the parent of this asset would take precedence.   

 
3. When you are done entering information tap the Check In button. 
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3.5.12 Android Dispose 

Professional and Enterprise Editions Only 
  

The Dispose transaction is used to remove an asset from the database. You will use this function when you no longer 
have an asset. 
  
Keep in mind that once disposed, assets cannot be "un-disposed", meaning there is no way to reactivate the asset. You 
would need to create a new asset if the asset is found. There may be situations where you will want to move an asset to 
a temporary location, rather than disposing of it, if the asset is misplaced. For example, if you regularly have items that 
are not found during an audit, but are found later, you may not want to dispose of them. Moving them to a temporary 
location you set up in MobileAsset enables you to move them back to their regular location when they are found. 
 Disposing of these assets requires you to create a new asset later if they are found. 
  
1. From the Main Menu tap Dispose. The Dispose screen appears: 

 

 
2. Scan, enter using the keyboard or Search for an Asset Tag.  

 
For information on entering or scanning information in MobileAsset, please refer to the topic Entering or Scanning 
Information. 
 
The Description, Site and Location fields will populate after you select an Asset Tag. 

3. Enter a Reason for this Dispose transaction by clicking in the Reason field. A menu will appear listing the options. 
Reasons are: Sale, Lost, Damaged, Trade In, Stolen or Other. 

4. When you are finished entering information, tap the Dispose button. 
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3.5.13 Android Audit 

Professional and Enterprise Editions Only 
  

The Audit Assets transaction is used to verify or update the location of one or more assets. 
  
  
  

1. From the Main Menu tap Audit. The Audit screen appears. 
 

 

2. Select a Site and Location for this audit by scanning, enter using the keyboard or Searching.   
 
For information on entering or scanning information in MobileAsset, please refer to the topic Entering or 
Scanning Information. 
 
Keep in mind that you can "pin" fields on this screen. For more information on pinning, please refer to the topic 
Android Pinning Data. 

3. Set an Audit Start Time. This feature allows you to stop and restart an audit without auditing the same 
inventory twice by telling MobileAsset to only include those assets that were not audited prior to the entered 
start date and time. For example, if you begin an audit on November 6, but had to stop at midnight and the audit 
was not completed, you can enter 11/7/2014 at 12am to being the new audit. This means that only items that 
have not been audited as of 12am on November 7 will be included in this audit. 

4. Tap the Find Assets button. The Audit screen will appear listing all assets not yet audited at the selected 
location. 
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5. When you have verified the assets are at the location, tap on one or more assets in the list, then tap the Start 
Audit button. Those items will be removed from the list. Keep auditing until your list indicates you have 0 assets 
not audited at the location.  
 
When 0 Assets not audited at location is displayed, you can begin Auditing any assets you have found at that 
Location which asset did not list. 
 
For each asset that MobileAsset did not list, enter a specific Asset Tag by scanning, entering using the 
keyboard or Searching, then tap the Start Audit button. A message will appear notifying you that the asset is 
not at the specified location. You can either move the asset to this location and audit it, or mark it as audited in 
the location it is assigned to in MobileAsset. Keep in mind that whichever option you choose, the asset will be 
audited. 
 
If you know that an asset you have found should not reside at that Location, do not perform any transactions to 
rectify the misplacement. Use the Edit screen to look up the Asset Tag's correct Location, then exit the Edit 
screen, and physically relocate the asset to its correct Location. 
 
If an asset is missing at the location being audited, you must perform a Dispose transaction to declare it 
missing. 
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3.5.14 Android Funding Audit 

Professional and Enterprise Editions Only 
  

The Funding Audit function allows you to audit those assets associated with a funding source. 
  

  
  

1. From the Main Menu tap Funding Audit. The Funding Audit screen appears. 
 

 

2. Select a Funding source by scanning, enter using the keyboard or Searching.   
 
For information on entering or scanning information in MobileAsset, please refer to the topic Entering or 
Scanning Information. 
 
Keep in mind that you can "pin" fields on this screen. For more information on pinning, please refer to the topic 
Android Pinning Data. 
 
When you select a Funding source, a list of Sites and Locations containing assets associated with that source 
will appear: 
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3. Enter the Audit Time or use the Magnifying Glass icon to search for a recent Audit. 
 
This feature allows you to stop and restart an audit without auditing the same inventory twice by telling 
MobileAsset to only include those assets that were not audited prior to the entered start date and time.  For 
example, if you begin an audit on November 6, but had to stop at midnight and the audit was not completed, 
you can enter 11/7/2014 at 12am to being the new audit.  This means that only items that have not been 
audited as of 12am on November 7 will be included in this audit. 

4. Highlight a Site in the list and tap the Start Audit button. 
 

 

5. The Audit screen appears with a list of assets not yet audited at the selected Site/Location: 
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When you have verified the assets are at the location, tap on one or more assets in the list, then tap the Start 
Audit button. Those items will be removed from the list. Keep auditing until your list indicates you have 0 assets 
not audited at the location.  
 
When 0 Assets not audited at location is displayed, you can begin Auditing any assets you have found at that 
Location which asset did not list. 
 
For each asset that MobileAsset did not list, enter a specific Asset Tag by scanning, entering using the 
keyboard or Searching, then tap the Start Audit button.  A message will appear notifying you that the asset is 
not at the specified location.   You can either move the asset to this location and audit it, or mark it as audited in 
the location it is assigned to in MobileAsset.  Keep in mind that whichever option you choose, the asset will be 
audited. 
 
If you know that an asset you have found should not reside at that Location, do not perform any transactions to 
rectify the misplacement. Use the Edit screen to look up the Asset Tag's correct Location, then exit the Edit 
screen, and physically relocate the asset to its correct Location. 
 
If an asset is missing at the location being audited, you must perform a Dispose transaction to declare it 
missing. 
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Android Maintenance 

Professional and Enterprise Editions Only 
  

You can mark maintenance as complete for an asset directly on the mobile device. 
  
  

1. From the Main Menu tap the Maintenance icon. The Maintenance screen appears: 
 

 

2. Scan, enter using the keyboard or Search for an Asset Tag. The Description field will populate. 
 
For information on entering or scanning information in MobileAsset, please refer to the topic Entering or 
Scanning Information. 
 
Keep in mind that you can "pin" fields on this screen. For more information on pinning, please refer to the topic 
Android Pinning Data. 

3. Tap the Schedule field to view a list of any scheduled maintenance for this asset.   
 
If scheduled maintenance exists for this asset, select it from the list or you can choose Unscheduled 
Maintenance. Tap the Magnifying Glass icon to view the details of the scheduled maintenance on the Schedule 
screen. 
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Tap the arrow icon at the top of the screen to return to the Maintenance screen. 

4. Mark this Maintenance as completed by tapping the Completed circle. 

5. Enter a condition for the asset by tapping in the Condition field, then selecting from the list. Options are Bad, 
Excellent, Fine and Good. 

6. Enter notes in the Notes field as needed. You can search for previously used Maintenance Types to add to the 
Notes field by tapping the Magnifying Glass icon. The Select Maintenance Type screen appears: 
 

 
 
You can create a new Maintenance Type by tapping the yellow + icon. 
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7. The New Maintenance Type screen appears. 
 

 
 
Enter a Short Name and a Full Description for this Maintenance Type, then tap the OK button. The new 
Maintenance Type will be added to the Select Maintenance Type screen. 
 
 
Tap the Maintenance Type you want to use, then tap the Save button. The Maintenance Type will be added 
to the Notes section. 
 

 
8. If you want to add a picture of the asset to this Maintenance, tap the Picture button. 
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9. The Picture screen appears. 
 

 
 
Click the Camera icon. A screen will appear asking if you want to take a new picture or browse for a picture on 
your device. 
 

 
 
Camera - Select this option to access the camera feature on your device. Take the picture as you normally 
would on your device, then select Save, or Discard to discard the current picture and take another. When you 
select Save the image will be displayed on the Picture tab. Images taken via the camera through the 
MobileAsset app are saved to your device and to the MobileAsset database. 
 
Note: If you take a picture from the MobileAsset app, the picture will be saved to your picture gallery. Be aware 
that the picture will be rotated 90 degrees in the gallery view. 
 
Gallery - Select this option to browse for a picture on your device. 
 
When you select or take a photo, it will appear in the Picture tab. 
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Click the Trash can icon to delete the image. 
 
The number of pictures you can attach to an asset is limited by the number set in Options > Maximum 
Pictures Captured. The default captures is 5. 
 
Pictures can be viewed on the Transaction List. 

10. When you are finished adding information, tap the Submit button. 
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3.5.15 Android Settings 

Professional and Enterprise Editions Only 
  

The Settings menu allows you to log out of the MobileAsset app, the upload/sync the data on the device with the 
MobileAsset database.  
  
To access the Settings menu, tap the  icon from the top of most screens in MobileAsset. 
 

 
 
 
Select Settings from the drop down menu.  
 
 

 

 The Settings screen appears. 
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The features contained in the Settings screen are: 
  
  
Sync  
  
Auto Upload 
Upload 
Full Sync 
  
Account 
  
<Username> 
Switch Database 
Switch Filter 
View Server Settings 
  
Info 
  
About 
View Log 
View Crash List 
View Printer Settings 
  

 

Auto Upload 

Turn the Auto Upload feature on to enable auto upload of data from the MobileAsset app to the MobileAsset database. 
The upload will take place each time you return to the Main Menu and select a function. 
  

 

Upload 

Tap the Start button in the Upload row to immediately begin a data upload from the MobileAsset app to the 
MobileAsset database. When the upload begins a progress screen will appear: 
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Full Sync 

  
Full Sync uploads data from the MobileAsset App to the MobileAsset database followed by a download of the 
MobileAsset database. This ensures that any changes/new data uploaded from other devices will appear on the current 
device. 
  

 

<Username> 

  
Tap the Logout icon next to your user name to log out of the MobileAsset app. 
  

 

Switch Database 

If your company uses more than one database, the Switch Database function allows you to switch between them. The 
currently connected database will appear here. 
 
If you have transactions on the device that have not yet been uploaded to the database, you will not be able to switch 
databases until the upload is completed. 
  
To change the database, tap the arrow to access the database settings screen: 
 

 
  
Enter the Server URL, Device Name, your Username and Password, then select Login. 
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Switch Filter 

The Switch Filter feature allows you to switch the filter on the database.  
  
Note: Filters are setup from Mobility > Specify Mobile Device Data Filters screen on the PC. 
  

 

View Server Settings 

  
This option allows you to view the current server settings.  
 

 
  
  

 

About 

  
Tap the About section to view information about the current Database, Filter selection as well as the current version 
of the MobileAsset app. 
  

 
  
Tap Done to close the About screen. 
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View Log 

  
Tap View Log to view the MobileAsset log page. 
  

 

View Crash List 

  
Tap View Crash List to view a list of any MobileAsset app crashes. 
  

 

View Printer Settings 

  
Tap this option to view, setup or change the current label printer settings.  

 
On the Configure Printer screen enter the following information: 
  
IP/DNS - Enter the IP address of the label printer. 
  
Port - Enter the port the label printer is using. 
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3.6 iOS Devices 

3.6.1 Downloading and Installing MobileAsset on your iOS Device 

Professional and Enterprise Editions Only 
  

1. Download and install  the Wasp MobileAsset App from the App Store to your mobile device. 

2. Click the MobileAsset icon to open the app. 

3. The first time you open MobileAsset, the following screen will appear: 
 

 

• Service URL - This field auto populates based on the IP or FQDN (Fully Qualified Domain Name) detected 
when you installed MobileAsset on your PC. The Service URL is the IP or FQDN followed by the port number 
for MobileAsset, usually 10008. The Service URL is pinned by default. If you need to modify the Service URL, 
you can unpin it by tapping on the grey field name. This will unpin the field allowing you to edit the URL 
information. 
 
Example URL: http://<your IP address>:10008 

• Device Name - Enter a unique name here for this mobile device. 
 
If this device has previously been setup on MobileAsset with a different Device Name, a message will appear. 
Click Yes to use the previous name, click No to change the device name. 
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• User Name - Enter your MobileAsset user name. 

• Password - Enter your MobileAsset password. 
  
For more information on logging in to MobileAsset, please refer to the topic Logging in to MobileAsset on iOS. 
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3.6.2 Logging In to MobileAsset on iOS 

Professional and Enterprise Editions Only 
  
When you tap on the MobileAsset icon on your device, the log in screen appears: 
  

 
  
Enter your MobileAsset Username and Password, then tap Login. 
 
If you need access to the Server URL and Device Name fields (seen on the Log In screen the first time it is 
accessed after installation, or when the user selects Switch Database from the Settings screen.), "pinch" 
anywhere on the Log In screen. To pinch the screen, press two fingers to the screen, then move them together in a 
pinching motion. You will be asked if you want to switch to a different database or a different server. Tap OK to 
access the screen. 
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3.6.3 Entering or Scanning Information 

Professional and Enterprise Editions Only 
  

Using the Keyboard 
Scanning a Barcode 
 
Note: On any field in MobileAsset, you can "pinch" the field to reset it. To pinch the field press two fingers on the field, 
then move them together in a pinching motion. The value in the field will clear. 
  

 

Using the Keyboard 

  
Tap in the field into which you want to enter data. The keyboard will appear at the bottom of the screen. 
 
iPhone: 
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You can close the keyboard at any time by tapping the keyboard icon: 
 

iPhone 
 

 

iPad  
    

 

 

Scanning a Barcode 

If you want to scan a barcode, tap the barcode icon. 
  

  
iPhone 
 

 

iPad  
     

 

 
 
The scanner feature will open. Hold your device over the barcode. When MobileAsset has successfully read the 
barcode, the data will appear in the Asset field. 
 
You can use the right and left arrow keys at the top of the keyboard to scroll through the fields.  
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3.6.4 Printing from the MobileAsset App 

Professional and Enterprise Editions Only 
  
To print labels from the New and Edit asset screens in the MobileAsset app, you will need to have your ZPL printer 
set up on your network. You will need to select the printer IP and a port. 
  
  
Printing Receipts 
  
To print receipts from the Check Out and Check In screens, you will need an airprint compatible printer. Make sure 
the device is logged into wifi and is on the same subnet with the printer itself. ] 
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3.6.5 iOS Main Menu 

Professional and Enterprise Editions Only 
  

After logging in to MobileAsset, Main Menu screen appears: 
 
 
iPhone  
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iPad - Note that on the iPad display the search area is already visible when you access the Main Menu. Please refer to 
the topic iOS Search feature for instructions on using this feature. 
 

 
All of the functions available in MobileAsset are available from the Main Menu. To open a feature, click on a listing in 
the menu. 
 
 

You can display or hide the Main Menu by clicking the  icon located in the top, left of most screen. 
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3.6.6 iOS Add New 

Professional and Enterprise Editions Only 
  

You can create new Assets, Asset Tags, Locations, Departments, Manufacturers and Vendors in the MobileAsset 
app. This new data will be transmitted to the MobileAsset database in real time where it will become available to all 
devices and on the PC. 
  
The only "Add New" screen that is accessed directly is the New Asset screen (accessed from the Main Menu). For 
other new information, you can enter the data in the appropriate field. MobileAsset will recognize the data as new and 
ask you if you want to add it to the database. 
  
New Asset 
New Asset Type 
New Location 
New Department 
New Manufacturer 
New Vendor 
  
Sites and Locations must be created on the PC. 
  
Other topics that are related to Adding New information are: 
  
Search 
Pinning Data 
  
  
Note: Most of the screen examples shown in this topic were taken from an iphone. Examples of screens taken from 
an ipad are provided when they differ from the iphone layout. 

 

New Asset 

  
1. From the Main Menu, tap the New Asset option. The Add New screen appears. 

 
iPhone: 
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iPad: 
 
 

 
 
Note: Fields that are preceded by an asterisk (*) are required. 
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2. Tap in the field into which you want to enter data. The keyboard will appear at the bottom of the screen. 

 
iPhone: 
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You can close the keyboard at any time by tapping the keyboard icon: 
 

iPhone 
 

 

iPad  
   

 

 
 
 
 
If you want to scan a barcode, tap the barcode icon. 

  
  

iPhone 
 

 

iPad  
    

 

 
 
The scanner feature will open. Hold your device over the barcode. When MobileAsset has successfully read 
the barcode, the data will appear in the Asset field. 
 
You can use the right and left arrow keys at the top of the keyboard to scroll through the fields.  

3. Enter an Asset Type for this asset. This is a required field. You can enter a tag into the field using the 
keyboard, tap the Scan icon to scan a barcode, or click the Magnifying Glass icon to access the Search 
screen. 
 
You can also add a new Asset Type by entering new information in the field. MobileAsset will recognize the 
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data as new and prompt you to create the new Asset Type. For detailed instructions, please refer to the 
section New Asset Type later in this topic. 

4. After you select an Asset Type, the following screen will appear: 
 

 
 
Select Yes to populate the fields that appear on the Type tab with information from the Asset Type. 
 
Select No to leave those fields blank. 

5. Next enter the Site and Location for this asset following the instructions in step 2. Keep in mind that you 
cannot create new Sites on the mobile device. These will need to be created on the PC. 

6. You can optionally enter a Description, Serial #, Department and Condition for the asset as well. 

7. The Linking tab will be displayed. Tap on the tab label to open it. 
 

 
Asset Linking allows you to link two or more assets together to form one new asset. For example, the asset 
Mary's Computer may consist of 4 separate assets - CPU, Keyboard, Mouse and Monitor.  These four 
individual assets are linked together to form one new asset, Mary's Computer. For a complete definition 
of Asset Linking and an example, please refer to the Definitions topic. 
 
If this asset is to be the Parent, or top-level asset, of this group, you can leave the "Parent Asset" field 
blank. If you want to give this asset a parent (for instance, if this asset is a monitor and you want to link to 
the asset Mary's Computer), enter or scan an asset or tap the Magnifying Glass icon to search for an asset. 
 
The asset can have a parent assigned to it and be a parent (have child assets assigned to it). 
 
To associate child assets with this asset (the current asset will be the "parent" of these assets), click the 
yellow + sign. The Search Asset screen will appear displaying all assets in the database. You can search 
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for an asset by entering a full or partial asset tag or description in the search field and clicking the 
Magnifying Glass icon. Tap on an asset in the list to link it to the new asset. 
 
Highlight the desired asset in the Asset List, then click the Select button.  The selected asset will appear in 
the "Child Asset(s)" window as shown below: 
 
 

 
 
You can unlink the asset by tapping the Unlink button. 
 
A Note about the Transact as Whole Flag: In the example above, the Transact as whole flag is checked; 
therefore, any functions (check in, check out, audit, move, etc.) will be performed as a whole for the group. 
 This flag is driven from the top down, meaning the selection made for the parent asset will override the 
selection for a child asset.  If you want to move only one asset that is a child of this asset, you will need to 
deselect this check box. Deselecting it on the Edit Asset > Asset Linking tab for the child asset will not 
override the selection made for this asset, and this group would still be moved as a whole. Similarly, if the 
Transact as whole flag was NOT selected on this tab, but it IS selected for the parent of this asset, the 
group would still be transacted as a whole because the selections made for the parent of this asset would 
take precedence.   
 
Also keep in mind that when you check out an asset that has Transact as whole turned on and you select 
to use the Default Due Date (on the Check Out screen) MobileAsset will search all assets linked to the 
selected asset to find the maximum checkout duration. The software will use this maximum length to 
calculate the due dates for all the linked assets. This ensures that all the assets in the transaction have the 
same due date even if some of the linked assets have different checkout durations. 

8. Click the Picture tab to view any image files that have been Attached to either the Asset Type Attachments 
folder or the Asset Attachments folder or to add a new picture to this asset. 
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Click the Camera icon. A screen will appear asking if you want to take a new picture or browse for a picture 
on your device. 
 

 
 
Open Camera - Select this option to access the camera feature on your device. Take the picture as you 
normally would on your device, then select Use this image, or Retake to discard the current picture and 
take another. When you select Use this Image the image will be displayed on the Picture tab. Images 
taken via the camera through the MobileAsset app are not saved to your device. They are transmitted to the 
MobileAsset database. 
 
Choose from Photos - Select this option to browse for a picture on your device. 
 
When you select or take a photo, it will appear in the Picture tab. 
 

 
 
Click the Trash can icon to delete the image. 
 
The number of pictures you can attach to an asset is limited by the number set in Options > Maximum 
Pictures Captured. The default number of captures is 5. 
 
Note: After uploading data to the PC, any pictures taken via the iOS app will appear as attachments on the 
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Edit Asset screen > Attachment tab. Pictures taken via the iOS app will not appear on the Edit Asset 
screen > Picture tab by default. You can set an image as default to have it appear on the Picture tab by 
following the instructions provided in the topic New Asset screen > Picture tab. 

9. The Custom tab displays any custom fields, either static or dynamic, set up on the PC.  
 
For more information on these fields, please refer to the topics Using Custom Fields and Using Dynamic 
Custom Fields. 
 
An example of the Custom tab displaying both types of custom fields is shown below: 
 

 
 
If any of the fields are set to be required, they will appear with an asterisk (*) in front of them. You must 
complete all required custom fields before you can save the asset.   
 
Click the Magnifying icon next to each field to view any Predefined values as well as recently used values. 

10. The Type tab contains information related to the Asset Type such as depreciation and Asset Length. If you 
selected to set common asset fields in Step 4, the fields on this tab will be populated with data from the 
asset type. In addition, if the Edit Inherited Asset Type data option is turned off, any of the fields that are 
in common with the Asset Type will not be editable, even if they are blank.   
 
If Depreciation is not set for the Asset Type associated with the asset, you will not be able to select a 
Depr. Class here. Depreciation can be set for an Asset Type on the PC only. 
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Enter information on this screen as needed. Keep in mind that if you enter a new manufacturer and/or 
vendor here, you will be given the opportunity to add them to your database. For more information see Add 
New Manufacturer and Add New Vendor later in this topic. 

11. When you are finished entering information for this asset, tap the Save button at the bottom of the screen. 
 
iPhone Summary Screen: 
 
Notice that after you select Save, a number appears next to the Summary button. 
 

 
 
This indicates how many assets you have created during this session. Tap the Summary button to view the 
summary information. Details of each asset you have added this session will display: 
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Tap the Print icon to print labels for these assets. The labels will print to your ZPL printer that is on your 
network. For information on printing from iOS, please refer to the topic Printing from the MobileAsset 
App.  
 
iPad Summary Screen: 
 
After you select Save, the Summary will appear at the bottom of the screen as shown below: 
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Tap the up arrow at the top of the Summary to expand it.  
 
Tap the Print icon to print labels for these assets. The labels will print to your ZPL printer that is on your 
network. For information on printing from iOS, please refer to the topic Printing from the MobileAsset App 
in iOS.  

 

  

New Asset Type 

  
1. When you enter new data into the Asset Type field MobileAsset will recognize it as new and the following 

prompt will appear: 
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2. Tap Yes to access the New Asset Type screen. 
 

 
3. Enter information in the following fields: 
• Asset Type - This field is required. The asset type is a category for assets and is required to create new 

asset types. Assets are assigned to a specific asset type.  For instance, you may have an Asset Type of 
Label Printers that defines the manufacturer, size specs, etc. of this particular type of printer. Then specific 
printers of the same type are assigned to the Label Printers asset type. Asset Tags must be unique across all 
Sites and Locations. A particular value can occur only once in the Asset database. 

• Asset Type Description - Enter a description for this Asset Type. 
• Depr Class and Category are optional fields. A selection can be made from any previously defined values 

found on the search screen or you can create a new Class or Category by entering new information in the 
field..   
 
MobileAsset can perform depreciation calculations at the PC for any Depreciation Class assigned to asset 
types for which that option has been enabled. The mobile device does not distinguish those Depreciation 
Classes for which depreciation has been enabled from those where it has not. If you define a new 
Depreciation Class on the mobile device for which depreciation should be calculated, the option will have to 
be enabled for that Depreciation Class. Click here for information on enabling depreciation. 

• Manufacturer - Scan a manufacturer or tap the Magnifying Glass icon to search manufacturers. You can 
create a new manufacturer by entering new information in the field. 

• Vendor - Scan a manufacturer or tap the Magnifying Glass icon to search manufacturers. You can create a 
new manufacturer by entering new information in the field. 

• CO Length - The default number of Days, Hours or Minutes the asset type may remain checked out before it 
is overdue.   

• Lead Time - Indicates how long after an asset is checked in before it is available. The lead time allows time 
for recalibration, cleaning, etc. 
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4. Tap the Save button when you are done. You will be returned to the screen on which you were previously 

working. 
 

New Location 

1. When you enter new data into the Location field MobileAsset will recognize it as new and the following prompt 
will appear: 
 

 

2. Click Yes on the prompt to access the New Location screen.  
 

 

3. Make sure the Location is entered correctly, then tap the Save button. You will returned to the screen you were 
previously working on. 

 

New Department 

1. When you enter new data into the Department field MobileAsset will recognize it as new and the following 
prompt will appear: 
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2. Click Yes to access the New Department screen. 
 

 

3. Enter the Department Code and Department Name, then click the Save button. 
 

New Manufacturer 

  
1. When you enter new data into the Manufacturer field MobileAsset will recognize it as new and the following 

prompt will appear: 
 

 

2. Click Yes on this prompt to save the new manufacturer. If you need to add additional data to this manufacturer, 
such as address and phone information, you will need to do so on the PC. 

  
 

New Vendor 

  

1. When you enter new data into the Vendor field MobileAsset will recognize it as new and the following prompt will 
appear: 
 

 

2. Click Yes on the prompt to access the New Vendor screen. 
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Enter the Vendor code and the Vendor Name (optional), then click the Save button. 
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3.6.7 iOS Pinning  

Professional and Enterprise Editions Only 
  

Many fields can be "Pinned" in MobileAsset, allowing for faster data entry. For instance, if you are adding multiple new 
assets to one Asset Type at a specific Site and Location, you can select information in those fields once, then "pin" 
the fields. This allows you to quickly create new assets without having to re-enter the Asset Type, Site and Location 
each  time. 
  

To Pin a Field 

  
Press and hold the label of the field you want to pin. The field label will turn yellow and the Search icon will disappear, 
indicating it is pinned. 
  
In the example below we have pinned the Asset Type, Site and Location fields. 
  

 
  

To Unpin a Field 

  
Press and hold the field label until the label returns to black and the search icon reappears. 
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3.6.8 iOS Search 

Professional and Enterprise Editions Only 
  

You can search for a variety of information in MobileAsset using the Search screens. Anywhere you see a Magnifying 
Glass icon next to a field, you can click on the icon to access the search screen. The searchable data is limited to 
field. For instance, if you click the Magnifying Glass icon next to the Asset Type field, the search screen will only 
search for Asset Types. 

  
1. Click the Magnifying Glass icon next to a field. 

 

 
 
Note: The Asset Search option is available from the Main Menu: 
 
iPhone: 
 

 
 
iPad: 
 

 
 
The appropriate Search screen appears. In this example we have accessed the Asset Search: 
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Tap in the text field at the  top of the screen to access the keyboard, then type in a full or partial name, asset 
tag, etc. Click the Magnifying glass icon when you are done entering information. Search results will appear on 
the screen. 
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2. Tap on a listing in the search results to select it. 
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3.6.9 iOS Edit Asset 

Professional and Enterprise Editions Only 
  

This feature allows you to edit an existing asset. 
 
Note: The screen examples shown in this topic were taken from an iphone. The Edit screen on the ipad is identical in 
look and functionality. 
  
  

1. From the Main Menu tap Edit Asset. The Edit screen appears. 
 

 

2. This screen is divided into two sections containing search options. Select how you want to search for the 
asset you need to edit.   
 
Your options are: 
 
Search by Tag - Scan, enter using the keyboard or Search for an existing asset tag. On the Search screen, 
enter a full or partial tag, then tap the Magnifying Glass icon. Tap the asset you want to edit in the Search 
results. The Edit screen will appear (see example in Step 3). 
 
For information on entering or scanning information in MobileAsset, please refer to the topic Entering or 
Scanning Information. 
 
Search by Site and Location - Scan, enter using the keyboard or Search for a Site and/or a Location. A list 
of assets located at the specified Site/Location will appear. 
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3. Tap on the asset you want to edit. The Edit screen will appear: 
 

 

4. Make changes as necessary to the asset. 

5. If you want to print a label for this asset, tap the Print button. 

6. When you are finished, tap the Update button. 
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3.6.10 iOS Move Asset 

Professional and Enterprise Editions Only 
  

The Move Asset function is used to relocate an asset from one location to another. 
  
Note: The screen examples shown in this topic were taken from an iphone. The Move screen on the ipad is identical in 
look and functionality. 
  

1. From the Main Menu, tap Move Asset. The Move screen appears: 
 

 

2. Scan, enter using the keyboard or Search for a To Site. This is the site to which you are moving the asset. 

3. Scan, enter using the keyboard or Search for a To Location. This is the location to which you are moving the 
asset. The results on the search screen will be limited to locations within the selected site. 

4. Scan, enter using the keyboard or Search for an Asset Tag. The Description, From Site and From Location 
will populate with information from the selected Asset Tag. 
 
For information on entering or scanning information in MobileAsset, please refer to the topic Entering or 
Scanning Information. 
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Keep in mind that you can "pin" fields on this screen. For more information on pinning, please refer to the topic 
iOS Pinning Data. 

Note for MobileAsset Professional and Enterprise edition users: If you have installed the Professional or 
Enterprise edition of MobileAsset and are using asset linking, the system will check for the Transact as Whole 
flag. If the flag is turned on for this asset (or the parent of this asset), a message will appear notifying you. You 
can either leave the flag on to perform the transaction on the entire group of linked assets, or select to turn the 
flag off to perform the transaction only on this asset. 
 
 
What is Transact as Whole? When an asset is set to "Transact as whole" (on the New/Edit Asset screen > 
Linking tab) any functions (check in, check out, audit, move, etc.) will be performed as a whole for the group. 
This flag is driven from the top down, meaning the selection made for the parent asset will override the selection 
for a child asset. If you want to move only one asset that is a child of this asset, you will need to deselect this 
checkbox. Deselecting it on the Edit Asset > Asset Linking tab for the child asset will not override the 
selection made for this asset, and this group would still be moved as a whole. Similarly, if the Transact as 
whole flag was NOT selected on this tab, but it IS selected for the parent of this asset, the group would still be 
transacted as a whole because the selections made for the parent of this asset would take precedence.   

 
5. When you have entered your selections, tap the Move button.  
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3.6.11 iOS Check Out 

Professional and Enterprise Editions Only 
  

The Check Out Asset transaction provides the ability to check-out assets to a customer or employee, specifying a Due 
Date and Due Time by which the asset should be checked-in. 
  
You have two options for checking out assets, Advanced and Quick.  
  
Advanced check out allows you to check out a number assets to an employee or customer, then view the Summary 
screen where you can collect a signature and/or print a receipt. 
  
Quick check out can be used when you have many assets you want to check out to different customers/employees 
without worrying about gathering signatures on each one. This mode allows you to select a customer or employee and 
check out the asset without having to collect signatures or view the summary screen for each transaction. 
 
Note: Quick check out is not available if the Require a Signature on Device is set to Yes on the Options screen. 
  
Advanced Check Out 
Quick Check Out 

 

Advanced Check Out 

  
1. From the Main Menu tap Check Out. If this is the first time you have accessed this feature the Check Out 

popup menu will appear: 
 
 

 
 
Select Advanced Check Out. 
 
The Advanced Check Out screen appears. 
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Note: The popup menu does not automatically appear on subsequent taps. To change from Quick check out 
to Advanced check out or vice-versa, press and hold the Check Out menu option. The pop up menu will 
appear asking if you want Advanced or Quick check out. 

2. Assets can be checked out to customers or to employees. By default, the Check Out screen is set to 
Customer #. You can switch to Employee # by double tapping on the Customer # label. A screen will 
appear allowing you to select Customer # or Employee #. 
 
 

 
 
 
Tap Employee # or Customer # on this screen.  
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The Check Out screen will show your change. 
 

 

3. Scan, enter using the keyboard or Search for an Employee or Customer.  
 
For information on entering or scanning information in MobileAsset, please refer to the topic Entering or 
Scanning Information. 
 
Keep in mind that you can "pin" fields on this screen. For more information on pinning, please refer to the 
topic iOS Pinning Data. 

4. Scan, enter using the keyboard or Search for an Asset Tag.  
 
 
The Description, Site and Location fields will populate when you select the Asset Tag. 

Note for MobileAsset Professional and Enterprise edition users: If you have installed the Professional or 
Enterprise edition of MobileAsset and are using asset linking, the system will check for the Transact as Whole 
flag. If the flag is turned on for this asset (or the parent of this asset), a message will appear notifying you. You 
can either leave the flag on to perform the transaction on the entire group of linked assets, or select to turn the 
flag off to perform the transaction only on this asset. 
 
 
What is Transact as Whole? When an asset is set to "Transact as whole" (on the New/Edit Asset screen > 
Linking tab) any functions (check in, check out, audit, move, etc.) will be performed as a whole for the group. 
This flag is driven from the top down, meaning the selection made for the parent asset will override the selection 
for a child asset. If you want to move only one asset that is a child of this asset, you will need to deselect this 
checkbox. Deselecting it on the Edit Asset > Asset Linking tab for the child asset will not override the 
selection made for this asset, and this group would still be moved as a whole. Similarly, if the Transact as 
whole flag was NOT selected on this tab, but it IS selected for the parent of this asset, the group would still be 
transacted as a whole because the selections made for the parent of this asset would take precedence.   

 

5. The Due Date will default to Use CO Length, if a check out length was set for this asset type. The default can 
be accepted or overwritten if necessary. To change the Due Date, tap in the field. The options will appear at 
the bottom of the screen. Tap on an option to select it. 
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Due Date options are: 
 
Use CO Length - This uses the check out duration set for the asset type. The Date and Time will be calculate 
and displayed. 
No Due Date - This mean the asset will not have a due date set. 
Custom - Use this option to set a new due date and time. When this option is selected, the Date and Time 
selector appears: 
 

 
 
Scroll through the date and time rollers to select the check out due date and time. 

6. (MobileAsset Web Users Only) If you have created a Reservation on MobileAsset Web, you will see the 
Reservation field (shown below).   
 
The Reservation field displays a drop down list of reservations to which the current asset is tied. Select the 
reservation from the drop down list for which you want to check out this asset.  If you are creating a 
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reservation for the same period for a customer other than the one listed in the reservation, you will receive a 
warning message. 
 
Tap OK on the warning message to continue checking out the asset despite the overlapping period, or click 
No to cancel the check out process. 
 
When you sync the data back to the PC, MobileAsset Web will be updated with the new check out 
information. The status of the selected reservation will be updated to completed. 

7. When you are finished entering information for this asset, tap the Check Out button at the bottom of the 
screen. 
 
iPhone Summary Screen: 
 
Notice that after you select Check Out, a number appears next to the Finish button. 
 

 
 
This indicates how many assets you have checked out to the customer/employee during this session. Tap the 
Finish button to view the summary information. Details of each asset you have checked out will display: 
 

 
 
 
iPad Summary Screen: 
 
After you select Check Out, the Summary will appear at the bottom of the screen as shown below: 
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Tap the up arrow at the top of the Summary to expand it.  
 

8. Depending on the MobileAsset PC options, you may be prompted to obtain a signature or a signature may be 
required. 
 
If you are prompted to obtain a signature, tap Yes on the prompt screen. 
 
If you are not prompted but want to add a signature or print a receipt, slide the Signature and/or Print radio 
buttons to the left. The options will appear green when they are enabled: 
 

 

9. Click the Commit button. 
 
If you have enabled collecting a signature, the signature screen appears: 
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Have the employee or customer sign on the line using their fingertip. 
 
 

 
 
If you are satisfied with the signature, tap Save. If you want to erase the current signature and try again, tap 
Reset. To close the Signature screen without saving the signature, tap Dismiss. 
 
The signature is saved on the device until the next data upload to the PC. Once it is uploaded to the PC, you 
can view it by going to the Transactions List (Main > List Forms > Transactions) highlighting the desired 
transaction and clicking the Signature button. Only those transactions with a Pen icon next to them contain 
signature captures. 
 

 
 
When the Signature button is clicked, the View Signature screen appears. 
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Click the Red X in the upper, right corner to close the View Signature screen. 
 
 
 
If you have enabled printing a receipt, the Print Options screen will appear. For information on printing from 
iOS, please refer to the topic Printing from the MobileAsset App. You can re-print the check out receipt by 
highlighting the check out transaction, then clicking the Reprint Receipt button. 
 
 

 
 
Tap Select Printer to see a list of airprint capable printers on your network. Select a Printer, then tap the - 
and + icons to enter the number of copies you want to print. 
 
Tap Print after you have made your selections. 
 
After collecting a signature and printing a receipt the session is closed and you will be returned to the blank 
check out screen. 
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Quick Check Out 

  
1. From the Main menu, tap Check Out.  If this is the first time you have accessed the Check Out function, a 

pop up menu will appear asking if you want Advanced or Quick check out.   
 
 
Note: The popup menu does not automatically appear on subsequent taps. To change from Quick check out 
to Advanced check out or vice-versa, press and hold the Check Out menu option. The pop up menu will 
appear asking if you want Advanced or Quick check out. 
 
 
Select Quick Check Out.  
 

 
 
The Check Out screen appears: 
 

 
 
Assets can be checked out to customers or to employees. By default, the Check Out screen is set to 
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Customer #. You can switch to Employee # by double tapping on the Customer # label. A screen will 
appear allowing you to select Customer # or Employee #. 
 
 

 
 
 
Tap Employee # or Customer # on this screen.  
 
 

 
 
 
 
The Check Out screen will show your change. 
 

 

2. Scan, enter using the keyboard or Search for an Employee or Customer.  
 
For information on entering or scanning information in MobileAsset, please refer to the topic Entering or 
Scanning Information. 
 
Keep in mind that you can "pin" fields on this screen. For more information on pinning, please refer to the 
topic iOS Pinning Data. 

3. Scan, enter using the keyboard or Search for an Asset Tag.  
 
 
The Description, Site and Location fields will populate when you select the Asset Tag. 

Note for MobileAsset Professional and Enterprise edition users: If you have installed the Professional or 
Enterprise edition of MobileAsset and are using asset linking, the system will check for the Transact as Whole 
flag. If the flag is turned on for this asset (or the parent of this asset), a message will appear notifying you. You 
can either leave the flag on to perform the transaction on the entire group of linked assets, or select to turn the 
flag off to perform the transaction only on this asset. 
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What is Transact as Whole? When an asset is set to "Transact as whole" (on the New/Edit Asset screen > 
Linking tab) any functions (check in, check out, audit, move, etc.) will be performed as a whole for the group. 
This flag is driven from the top down, meaning the selection made for the parent asset will override the selection 
for a child asset. If you want to move only one asset that is a child of this asset, you will need to deselect this 
checkbox. Deselecting it on the Edit Asset > Asset Linking tab for the child asset will not override the 
selection made for this asset, and this group would still be moved as a whole. Similarly, if the Transact as 
whole flag was NOT selected on this tab, but it IS selected for the parent of this asset, the group would still be 
transacted as a whole because the selections made for the parent of this asset would take precedence.   

 

4. The Due Date will default to Use CO Length, if a check out length was set for this asset type. The default can 
be accepted or overwritten if necessary. To change the Due Date, tap in the field. The options will appear at 
the bottom of the screen. Tap on an option to select it. 
 

 
Due Date options are: 
 
Use CO Length - This uses the check out duration set for the asset type. The Date and Time will be calculate 
and displayed. 
No Due Date - This mean the asset will not have a due date set. 
Custom - Use this option to set a new due date and time. When this option is selected, the Date and Time 
selector appears: 
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Scroll through the date and time rollers to select the check out due date and time. 

5. (MobileAsset Web Users Only) If you have created a Reservation on MobileAsset Web, you will see the 
Reservation field (shown below).   
 
The Reservation field displays a drop down list of reservations to which the current asset is tied. Select the 
reservation from the drop down list for which you want to check out this asset.  If you are creating a 
reservation for the same period for a customer other than the one listed in the reservation, you will receive a 
warning message. 
 
Tap OK on the warning message to continue checking out the asset despite the overlapping period, or click 
No to cancel the check out process. 
 
When you sync the data back to the PC, MobileAsset Web will be updated with the new check out 
information. The status of the selected reservation will be updated to completed. 

6. When you are finished entering information for this asset, tap the Check Out button at the bottom of the 
screen. 
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3.6.12 iOS Check In 

Professional and Enterprise Editions Only 
  

The Check In Asset transaction provides the ability to check in assets currently checked out to a customer or 
employee. 
  
You have two options for checking in assets, Advanced and Quick.  
  
Advanced check in allows you to check in a number assets from an employee or customer, then view the Summary 
screen where you can collect a signature and/or print a receipt. 
  
Quick check in can be used when you have many assets you want to check in from different customers or employees 
without worrying about gathering signatures on each one. This mode allows you to select a customer or employee and 
check in the asset without having to collect signatures or view the summary screen for each transaction. 
  
Advanced Check In 
Quick Check In 
  
Keep in mind that you can "pin" fields on this screen. For more information on pinning, please refer to the topic iOS 
Pinning Data. 
 
Note: Most of the screen examples shown in this topic were taken from an iphone. Examples of screens taken from an 
ipad are provided when they differ from the iphone layout. 
  

 

Advanced Check In 

  
1. From the Main Menu tap Check In . If this is the first time you have accessed this feature the Check In popup 

menu will appear. Note: The popup menu does not automatically appear on subsequent taps. To change from 
Quick check out to Advanced check in or vice-versa, press and hold the Check In menu option. The pop up 
menu will appear asking if you want Advanced or Quick check in. 
 
Select Advanced Check In. 
 

 
 
The Check In screen appears: 
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2. Scan, enter using the keyboard or Search for an Asset Tag.  
 
For information on entering or scanning information in MobileAsset, please refer to the topic Entering or 
Scanning Information. The Description, Site and Location will populate based on the Asset Tag entered. 
You can also scan, enter or search for a Site and Location. 

Note for MobileAsset Professional and Enterprise edition users: If you have installed the Professional or 
Enterprise edition of MobileAsset and are using asset linking, the system will check for the Transact as Whole 
flag. If the flag is turned on for this asset (or the parent of this asset), a message will appear notifying you. You 
can either leave the flag on to perform the transaction on the entire group of linked assets, or select to turn the 
flag off to perform the transaction only on this asset. 
 
 
What is Transact as Whole? When an asset is set to "Transact as whole" (on the New/Edit Asset screen > 
Linking tab) any functions (check in, check out, audit, move, etc.) will be performed as a whole for the group. 
This flag is driven from the top down, meaning the selection made for the parent asset will override the selection 
for a child asset. If you want to move only one asset that is a child of this asset, you will need to deselect this 
checkbox. Deselecting it on the Edit Asset > Asset Linking tab for the child asset will not override the 
selection made for this asset, and this group would still be moved as a whole. Similarly, if the Transact as 
whole flag was NOT selected on this tab, but it IS selected for the parent of this asset, the group would still be 
transacted as a whole because the selections made for the parent of this asset would take precedence.   

 

3. When you are done entering information tap the Check In button. 
 
 
iPhone Summary Screen: 
 
Notice that after you select Check In, a number appears next to the Finish button. 
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This indicates how many assets you have checked in during this session. Tap the Finish button to view the 
summary information. Details of each asset you have checked in will display: 
 
 

 
 
 
 
iPad Summary Screen: 
 
After you select Check In, the Summary will appear at the bottom of the screen as shown below: 
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Tap the up arrow at the top of the Summary to expand it.  
 

4. Depending on the MobileAsset PC options, you may be prompted to obtain a signature or a signature may be 
required. 
 
If you are prompted to obtain a signature, tap Yes on the prompt screen. 
 
If you are not prompted but want to add a signature or print a receipt, slide the Signature and/or Print radio 
buttons to the left. The options will appear green when they are enabled: 
 

 

5. Click the Commit button. 
 
If you have enabled collecting a signature, the signature screen appears: 
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Have the employee or customer sign on the line using their fingertip. 
 
 

 
 
If you are satisfied with the signature, tap Save. If you want to erase the current signature and try again, tap 
Reset. To close the Signature screen without saving the signature, tap Dismiss. 
 
The signature is saved on the device until the next data upload to the PC. Once it is uploaded to the PC, you 
can view it by going to the Transactions List (Main > List Forms > Transactions) highlighting the desired 
transaction and clicking the Signature button. Only those transactions with a Pen icon next to them contain 
signature captures. 
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When the Signature button is clicked, the View Signature screen appears. 
 

 
 
Click the Red X in the upper, right corner to close the View Signature screen. 
 
 
 
If you enabled printing a receipt, the Printer Options screen appears. For information on printing from iOS, 
please refer to the topic Printing from the MobileAsset App. You can re-print the check in receipt by 
highlighting the check in transaction, then clicking the Reprint Receipt button. 
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Tap Select Printer to see a list of airprint capable printers on your network. Select a Printer, then tap the - 
and + icons to enter the number of copies you want to print. 
 
Tap Print after you have made your selections. 
 
After collecting a signature and printing a  receipt the session is closed and you will be returned to the blank 
check in screen. 

 

Quick Check In 

1. From the Main menu, tap Check Out.  If this is the first time you have accessed the Check Out function, a 
pop up menu will appear asking if you want Advanced or Quick check out.   
 
 
Note: The popup menu does not automatically appear on subsequent taps. To change from Quick check in 
to Advanced check in or vice-versa, press and hold the Check In menu option. The pop up menu will appear 
asking if you want Advanced or Quick check in. 
 
Select Quick Check In: 
 

 
 
The Check In screen appears: 
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2. Scan, enter using the keyboard or Search for an Asset Tag.  
 
For information on entering or scanning information in MobileAsset, please refer to the topic Entering or 
Scanning Information. The Description, Site and Location will populate based on the Asset Tag entered. 
You can also scan, enter or search for a Site and Location. 

Note for MobileAsset Professional and Enterprise edition users: If you have installed the Professional or 
Enterprise edition of MobileAsset and are using asset linking, the system will check for the Transact as Whole 
flag. If the flag is turned on for this asset (or the parent of this asset), a message will appear notifying you. You can 
either leave the flag on to perform the transaction on the entire group of linked assets, or select to turn the flag off to 
perform the transaction only on this asset. 
 
 
What is Transact as Whole? When an asset is set to "Transact as whole" (on the New/Edit Asset screen > Linking 
tab) any functions (check in, check out, audit, move, etc.) will be performed as a whole for the group. This flag is 
driven from the top down, meaning the selection made for the parent asset will override the selection for a child 
asset. If you want to move only one asset that is a child of this asset, you will need to deselect this checkbox. 
Deselecting it on the Edit Asset > Asset Linking tab for the child asset will not override the selection made for this 
asset, and this group would still be moved as a whole. Similarly, if the Transact as whole flag was NOT selected 
on this tab, but it IS selected for the parent of this asset, the group would still be transacted as a whole because the 
selections made for the parent of this asset would take precedence.   

  
3. When you are done entering information tap the Check In button. 
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3.6.13 iOS Dispose 

Professional and Enterprise Editions Only 
  

The Dispose transaction is used to remove an asset from the database. You will use this function when you no longer 
have an asset. 
  
Keep in mind that once disposed, assets cannot be "un-disposed", meaning there is no way to reactivate the asset. You 
would need to create a new asset if the asset is found. There may be situations where you will want to move an asset to 
a temporary location, rather than disposing of it, if the asset is misplaced. For example, if you regularly have items that 
are not found during an audit, but are found later, you may not want to dispose of them. Moving them to a temporary 
location you set up in MobileAsset enables you to move them back to their regular location when they are found. 
Disposing of these assets requires you to create a new asset later if they are found. 
  
1. From the Main Menu tap Dispose. The Dispose screen appears: 

 

 
2. Scan, enter using the keyboard or Search for an Asset Tag.  

 
For information on entering or scanning information in MobileAsset, please refer to the topic Entering or Scanning 
Information. 
 
The Description, Site and Location fields will populate after you select an Asset Tag. 
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3. Enter a Reason for this Dispose transaction by clicking in the Reason field. A menu will appear listing the options. 
Reasons are: Sale, Lost, Damaged, Trade In, Stolen or Other. 

4. When you are finished entering information, tap the Dispose button. 
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3.6.14 iOS Audit 

Professional and Enterprise Editions Only 
  

The Audit Assets transaction is used to verify or update the location of one or more assets. 
  
Note: The screen examples shown in this topic were taken from an iphone. The Move screen on the ipad is identical in 
look and functionality. 
  
  

1. From the Main Menu tap Audit. The Audit screen appears. 
 

 

2. Select a Site and Location for this audit by scanning, enter using the keyboard or Searching.   
 
For information on entering or scanning information in MobileAsset, please refer to the topic Entering or 
Scanning Information. 
 
Keep in mind that you can "pin" fields on this screen. For more information on pinning, please refer to the topic 
iOS Pinning Data. 

3. Set an Audit Start Time. This feature allows you to stop and restart an audit without auditing the same 
inventory twice by telling MobileAsset to only include those assets that were not audited prior to the entered 
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start date and time. For example, if you begin an audit on November 6, but had to stop at midnight and the audit 
was not completed, you can enter 11/7/2014 at 12am to being the new audit. This means that only items that 
have not been audited as of 12am on November 7 will be included in this audit. 

4. Tap the Find Assets button. The Audit screen will appear listing all assets not yet audited at the selected 
location. 
 

 
 

5. When you have verified the assets are at the location, tap on one or more assets in the list, then tap the Start 
Audit button. Those items will be removed from the list. Keep auditing until your list indicates you have 0 assets 
not audited at the location.  
 
When 0 Assets not audited at location is displayed, you can begin Auditing any assets you have found at that 
Location which asset did not list. 
 
For each asset that MobileAsset did not list, enter a specific Asset Tag by scanning, entering using the 
keyboard or Searching, then tap the Start Audit button. A message will appear notifying you that the asset is 
not at the specified location. You can either move the asset to this location and audit it, or mark it as audited in 
the location it is assigned to in MobileAsset. Keep in mind that whichever option you choose, the asset will be 
audited. 
 
If you know that an asset you have found should not reside at that Location, do not perform any transactions to 
rectify the misplacement. Use the Edit screen to look up the Asset Tag's correct Location, then exit the Edit 
screen, and physically relocate the asset to its correct Location. 
 
If an asset is missing at the location being audited, you must perform a Dispose transaction to declare it 
missing. 
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3.6.15 iOS Funding Audit 

Professional and Enterprise Editions Only 
  

The Funding Audit function allows you to audit those assets associated with a funding source. 
  
Note: The screen examples shown in this topic were taken from an iphone. The Funding Audit screen on the ipad is 
identical in look and functionality. 

  
  

1. From the Main Menu tap Funding Audit. The Funding Audit screen appears. 
 

 

2. Select a Funding source by scanning, enter using the keyboard or Searching.   
 
For information on entering or scanning information in MobileAsset, please refer to the topic Entering or 
Scanning Information. 
 
Keep in mind that you can "pin" fields on this screen. For more information on pinning, please refer to the topic 
iOS Pinning Data. 
 
When you select a Funding source, a list of Sites and Locations containing assets associated with that source 
will appear: 
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3. Enter the Audit Time or use the Magnifying Glass icon to search for a recent Audit. 
 
This feature allows you to stop and restart an audit without auditing the same inventory twice by telling 
MobileAsset to only include those assets that were not audited prior to the entered start date and time. For 
example, if you begin an audit on November 6, but had to stop at midnight and the audit was not completed, 
you can enter 11/7/2014 at 12am to being the new audit. This means that only items that have not been audited 
as of 12am on November 7 will be included in this audit. 
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4. Highlight a Site in the list and tap the Start Audit button. 
 

 

5. The Audit screen appears with a list of assets not yet audited at the selected Site/Location: 
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When you have verified the assets are at the location, tap on one or more assets in the list, then tap the Start 
Audit button. Those items will be removed from the list. Keep auditing until your list indicates you have 0 assets 
not audited at the location.  
 
When 0 Assets not audited at location is displayed, you can begin Auditing any assets you have found at that 
Location which asset did not list. 
 
For each asset that MobileAsset did not list, enter a specific Asset Tag by scanning, entering using the 
keyboard or Searching, then tap the Start Audit button. A message will appear notifying you that the asset is 
not at the specified location. You can either move the asset to this location and audit it, or mark it as audited in 
the location it is assigned to in MobileAsset. Keep in mind that whichever option you choose, the asset will be 
audited. 
 
If you know that an asset you have found should not reside at that Location, do not perform any transactions to 
rectify the misplacement. Use the Edit screen to look up the Asset Tag's correct Location, then exit the Edit 
screen, and physically relocate the asset to its correct Location. 
 
If an asset is missing at the location being audited, you must perform a Dispose transaction to declare it 
missing. 
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3.6.16 iOS Maintenance 

Professional and Enterprise Editions Only 
  

You can mark maintenance as complete for an asset directly on the mobile device. 
  
Note: The screen examples shown in this topic were taken from an iphone. The Move screen on the ipad is identical in 
look and functionality. 

  
  

1. From the Main Menu tap the Maintenance icon. The Maintenance screen appears: 
 

 

2. Scan, enter using the keyboard or Search for an Asset Tag. The Description field will populate. 
 
For information on entering or scanning information in MobileAsset, please refer to the topic Entering or 
Scanning Information. 
 
Keep in mind that you can "pin" fields on this screen. For more information on pinning, please refer to the topic 
iOS Pinning Data. 
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3. Tap the Schedule field to view a list of any scheduled maintenance for this asset.   
 

 
 
If scheduled maintenance exists for this asset, select it from the list or you can choose Unscheduled 
Maintenance. Tap the Magnifying Glass icon to view the details of the scheduled maintenance on the Schedule 
screen. 
 

 
 
Tap the arrow icon at the top of the screen to return to the Maintenance screen. 
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4. Mark this Maintenance as completed by tapping the Completed circle. 

5. Enter a condition for the asset by tapping in the Condition field, then selecting from  the list. Options are Bad, 
Excellent, Fine and Good. 

6. Enter notes in the Notes field as needed. You can search for previously used Maintenance Types to add to the 
Notes field by tapping the Magnifying Glass icon. The Select Maintenance Type screen appears: 
 

 
 
You can create a new Maintenance Type by tapping the yellow + icon. 
 

 
 
The New Maintenance Type screen appears. 
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Enter a Short Name and a Full Description for this Maintenance Type, then tap the OK button. The new 
Maintenance Type will be added to the Select Maintenance Type screen. 
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Tap the Maintenance Type you want to use, then tap the Save button. The Maintenance Type will be added 
to the Notes section. 
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7. If you want to add a picture of the asset to this Maintenance, tap the Picture button. 
 
The Picture screen appears. 
 

 
 
Click the Camera icon.  A screen will appear asking if you want to take a new picture or browse for a picture on 
your device. 
 

 
 
Open Camera - Select this option to access the camera feature on your device. Take the picture as you 
normally would on your device, then select Use this image, or Retake to discard the current picture and take 
another. When you select Use this Image the image will be displayed on the Picture tab. Images taken via the 
camera through the MobileAsset app are not saved to your device. They are transmitted to the MobileAsset 
database. 
 
Choose from Photos - Select this option to browse for a picture on your device. 
 
When you select or take a photo, it will appear in the Picture tab. 
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Click the Trash can icon to delete the image. 
 
The number of pictures you can attach to an asset is limited by the number set in Options > Maximum 
Pictures Captured. The default captures is 5. 
 
Pictures can be viewed on the Transaction List. 

8. When you are finished adding information, tap the Submit button. 
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3.6.17 iOS Settings 

Professional and Enterprise Editions Only 
  

The Settings screen allows you to log out of the MobileAsset app, the upload/sync the data on the device with the 
MobileAsset database.  
  
Note: The screen examples shown in this topic were taken from an iphone. The Move screen on the ipad is identical in 
look and functionality. 

  
  

To access the Settings screen, tap the   icon located at the top of many screen. 
 

 
 
The Settings screen will appear: 
 

 
  
The features contained in the Settings screen are: 
  
  
Sync  
  
Auto Upload 
Upload 
Full Sync 
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Account 
  
<Username> 
Switch Database 
Switch Filter 
View Server Settings 
  
Info 
  
About 
View Log 
View Crash List 
View Printer Settings 
  

 

Auto Upload 

Turn the Auto Upload feature on to enable auto upload of data from the MobileAsset app to the MobileAsset database. 
The upload will take place each time you return to the Main Menu and select a function. 
  

 

Upload 

Tap the Start button in the Upload row to immediately begin a data upload from the MobileAsset app to the 
MobileAsset database. When the upload begins a progress screen will appear: 
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Full Sync 

  
Full Sync uploads data from the MobileAsset App to the MobileAsset database followed by a download of the 
MobileAsset database. This ensures that any changes/new data uploaded from other devices will appear on the current 
device. 
  

 

<Username> 

  
Tap Logout next to your user name to log out of the MobileAsset app. 
  

 

Switch Database 

If your company uses more than one database, the Switch Database function allows you to switch between them. The 
currently connected database will appear here. 
 
If you have transactions on the device that have not yet been uploaded to the database, you will not be able to switch 
databases until the upload is completed. 
  
To change the database, tap the arrow to access the database settings screen: 
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Enter the Server URL, Device Name, your Username and Password, then select Login. 
  

 

Switch Filter 

The Switch Filter feature allows you to switch the filter on the database.  
  
Note: Filters are setup from Mobility > Specify Mobile Device Data Filters screen on the PC. 
  

 

View Server Settings 

  
This option allows you to view the current server settings.  
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About 

  
Tap the About section to view information about the current Database, Filter selection as well as the current version 
of the MobileAsset app. 
  

 
  
Tap Done to close the About screen. 

 

View Log 

  
Tap View Log to view the MobileAsset log page. 
  

 

View Crash List 

  
Tap View Crash List to view a list of any MobileAsset app crashes. 
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View Printer Settings 

  
Tap this option to view, setup or change the current label printer settings.  
 

 
On the Configure Printer screen enter the following information: 
  
IP/DNS - Enter the IP address of the label printer. 
  
Port - Enter the port the label printer is using. 
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Chapter 4 - About Screen 
The About screen allows you to view and manage licenses and provides program version details. 
  
The About screen allows you to: 
  
View Version Number and Basic License Information 
  
View Your Mobile Device License(s) 
  
View Your License Agreement (EULA) 

 
  

4.1 View Version Number and Basic License Information 

  
From the Main screen, select Help > About.  The About screen appears: 
 

 
 
 
This screen displays your version and basic license information. 
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4.2 View Your Mobile Device License(s) 

  
1. On the About screen, click the Licenses button to view additional licenses and your mobile device licenses. 

Below is an example of the Licenses screen: 
 

 
  

2. Click OK to exit the Licenses screen. Click OK again to close the About screen. 
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4.3 View Your License Agreement (EULA) 

  
1. On the About screen, click the View License Agreement button to view additional licenses and your mobile 

device licenses. Below is an example of the License Agreement screen: 
 

 

2. Click Print to print the EULA. 

3. Click Close to close the License Agreement screen. Click OK to close the About screen. 
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Definitions 

Asset 
One or more Assets can be assigned to each Asset Type.  The individual assets are a unique item of a 
specific make and model number.  Each asset is given an Asset Tag that is unique across all Sites and 
Locations. 

  
Asset Linking 

Asset Linking is only available in the Professional and Enterprise editions of MobileAsset.  Asset 
Linking, also known as Asset Kitting, allows you to link two or more assets together to form one new asset. 
 For example, the asset Mary's Computer may consist of 4 separate assets - CPU, Keyboard, Mouse and 
Monitor.  These four individual assets are linked together to form one new asset, Mary's Computer.  In this 
example, Mary's Computer is known as the "Parent" asset and the four component assets are the "Child 
Assets".   
A child asset can have only one parent, however, a parent may have multiple child assets and be a child 
itself.  In this scenario, the linking might look like this: 

 
In the example above, Mary's Computer is the parent of the assets CPU, Monitor, Mouse and Keyboard. 
 CPU is the parent of Network Card and SoundCard.  Therefore, CPU is both the child of Mary's Computer 
and the parent of Network Card and SoundCard. 
  

Asset Tag 
A unique identifier you assign each asset in your database (this is done on the New Asset screen).  The tag 
can be letters or numbers or a combination of both.  The asset tag is printed and attached to the physical 
asset.  Creation of the tags can be done using the Wasp Labeler application that installed when you installed 
the software.  To access Labeler, from the Main screen, click Labels > Asset Tags.  The number on the tag 
corresponds to the asset tag number in the database.  An asset tag usually contains a barcode for quick 
identification and tracking. 
  

Asset Type 
This is the first step in creating an Asset in the software. You must first create your Asset Types, then each 
asset you add to the system must be assigned to a specific Asset Type.  You can  think of Asset Types as a 
classification for assets.  For instance, you may have an Asset Type of IBM Laptop X6000 that defines the 
manufacturer, size specs, etc. of this particular type of computer.  Then specific computers of the same type 
are assigned as assets to the IBM Laptop X6000 asset type.  Asset Types are created in the database using 
the New Asset Type screen, or you can import this information.  You can then assign assets to a specific 
asset type on the New Asset screen. 
  
The Asset Type defines the Description, Depreciation Class, Category, Manufacturer and Model Number of 
the asset. 
  

Description can be any text used to describe the Asset Type. 
Depreciation Class controls whether or not depreciation will be calculated for this Asset Type 
(Depreciation Class is further defined below). 
Category is a superset of the Asset Type.  This can be very broad (furniture, computer equipment, 
etc.) or more specific (desk, chair, lamp, monitor, PC, keyboard, etc.) 
Manufacturer records the brand or maker of the Asset Type.   
Model # records the manufacturer's designation for this Asset Type. 
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Depreciation Class 
Depreciation Classes can be created to determine a specific Depreciation Method.  The Depreciation Class 
is assigned to one or more Asset Types (on the New Asset Type screen).  All assets assigned to that Asset 
Type will follow the Depreciation Method defined in the specified Depreciation Class. 
  

Depreciation Methods 
If you are using the Standard version of MobileAsset, you You have two depreciation methods: None and 
Straight Line.  If you are using the Professional version, you will have six depreciation methods to choose 
from: None, Straight Line, Double Declining Balance, 150% Declining Balance, Declining Balance Custom 
and Sum of the Years' Digits. 
  
Definitions for each of these methods are provided below: 
  

• Straight Line - The simplest and most commonly used depreciation method, straight line 
depreciation is calculated by taking the purchase or acquisition price of an asset subtracted by the 
salvage value divided by the total productive years (Life) the asset can be reasonably expected to 
benefit the company. 
 
Example: 
purchase price of asset – approximate salvage value 
-------------------------- (divided by) -------------------------- 
estimated useful life of asset 
 
Assume you buy a new computer for your business costing approximately $5,000. You expect a 
salvage value of $200 selling parts when you dispose of it. Accounting rules allow a maximum 
useful life of five years for computers; in the past, your business has upgraded its hardware every 
three years, so you think this is a more realistic estimate of useful life, since you are apt to dispose 
of the computer at that time.  Using that information, you would plug it into the formula: 
 
$5,000 purchase price - $200 approximate salvage value 
-------------------------- (divided by) -------------------------- 
3 years estimated useful life 
 
The answer, $1,600, is the depreciation charges your business would take annually if you were 
using the straight line method. 

• Double Declining Balance - The double declining balance depreciation method is similar to the 
straight-line method. To use it, the system first calculates depreciation as if it were the straight line 
method. Then it determines the total percentage of the asset that is depreciated the first year and 
doubles it. Each subsequent year, that same percentage is multiplied by the remaining balance to 
be depreciated. At some point, the value will be lower than the straight-line charge, at which point, 
the double declining method should be scrapped and straight line used for the remainder of the 
asset’s life.  Remember that the IRS does allow businesses to switch depreciation methods one 
time in the life of an asset.  MobileAsset will not make this switch for you.  It is up to the individual 
business to keep track of when the switch to straight line depreciation should be made. 
 
 
In MobileAsset, you must enter at least 100% for the custom declining balance. 
 
Example: 
 
In our straight-line example, we calculated that a $5,000 computer with a $200 salvage value and an 
estimated useful life of three years would be depreciated by $1,600 annually. The first year, we have 
to compare this to the total amount to be depreciated, in this case, $4,800 [$5,000 base - $200 
salvage value = $4,800]. Dividing $1,600 by $4,800, we discover the straight-line depreciation 
charge [$1,600] is 33.33% of the total depreciation amount [$4,800]. Using this information, we 
double the 33.33% figure to 66.67%. 
 
In the first year, we would take $4,800 multiplied by .6667 to get a total depreciation charge of 
approximately $3,200. In the second year, we would take the same percentage [66.67%] and 
multiply it by the remaining amount to be depreciated. Continuing with the example, we find that 
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$1,600 is the remaining amount to be depreciated at the start of the second year [$4,800 - $3,200 = 
$1,600]. Multiply 1,600 by .6667 to get $1,066. This is the depreciation charge for the second year – 
or not! Remember that once the depreciation charges dip below the amount that would be charged 
using the straight-line method, the double declining balance should be scrapped and straight line 
immediately utilized. The straight line method called for charges of $1,600 per year. Obviously, the 
$1,066 charge is smaller than the $1,600 that would have occurred under straight line. Thus, the 
deprecation charge for the second year would be $1,600. 
 
The equation below illustrates this method: 
 
depreciable base * (2 * 100% / useful life in years) 

• 150% Declining Balance - This method uses 150% of the straight-line percentage for the first year. 
The same percentage is then applied to the remaining balance, each succeeding year. 

• Declining Balance Custom - This method allows you to enter a custom declining balance 
percentage.  Declining Balance is a common depreciation-calculation system that involves applying 
the depreciation rate against the non-depreciated balance. Instead of spreading the cost of the 
asset evenly over its life, this system expenses the asset at a constant rate, which results in 
declining depreciation charges each successive period.  
 
Example:   
 
If an asset that costs $1,000 is depreciated at 25% each year, the deduction is $250.00 in the first 
year and $187.50 in the second year, and so forth. 

• Sum of the Years' Digits - To calculate depreciation charges using the sum of the years' digits 
method, take the expected life of an asset (in years) count back to one and add the figures together.  
 
Example: 
 
10 years useful life = 10 + 9 + 8 + 7 + 6 + 5 + 4 + 3 + 2 + 1 Sum of the years = 55 
 
In the first year, the asset would be depreciated 10/55 in value [the fraction 10/55 is equal to 
18.18%] the first year, 9/55 [16.36%] the second year, 8/55 [14.54%] the third year, and so on. 
Going back to our example from the straight-line method: a $5,000 computer with a $200 salvage 
value and 3 years useful life would be calculated as follows: 
 
3 years useful life = 3 + 2 + 1 Sum of the years = 6 
 
Taking $5,000 - $200 we have a depreciable base of $4,800. In the first year, the computer would 
be depreciated by 3/6ths [50%], the second year, by 2/6 [33.33%] and the third and final year by the 
remaining 1/6 [16.67%]. This would have translated into depreciation charges of $2,400 the first 
year, $1,599.84 the second year, and $800.16 the third year. The straight-line example would have 
simply charged $1,600 each year, distributed evenly over the three years of useful life. 

Location 
Locations are places within a particular Site where Assets reside.  Typically, a Site is a building or area that 
contains one or more inventory Locations.  For instance, Sebastian's Office might be a location within the 
site Executive Building A23. 
  

Child Asset 
An asset that is linked to a parent asset.  See the illustration in the Asset Linking definition, above. 
  

Parent Asset 
Any asset that has child assets attached to it. See the illustration in the Asset Linking definition, above. 
  

Serial Number 
If an asset has a Serial Number and you choose to record it, it is associated with a specific Asset, not with 
an Asset Type. 
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Site 
The software can manage assets at one or more Sites (specific buildings or vehicles) depending on the 
version of the software you have.  Typically, a Site is a building that contains one or more asset Locations. 
 For instance, Sebastian's Office might be a location within the site Executive Building A23.  Pay attention to 
the Site you are working with when using Asset. 
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Technical Support 

 Wasp Technical Support, Knowledge Base and Downloads 

 Wasp Barcode Online Store 
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